Bug 79780 - installer deleted partition on windows hard drive
installer deleted partition on windows hard drive
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Sandra Moore
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-12-16 15:35 EST by Christopher Parker
Modified: 2014-08-04 18:23 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-17 17:30:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher Parker 2002-12-16 15:35:02 EST
Description:
I originally had a 20 GB hard drive with Windows 98 installed on it. I wanted 
to try Linux for the first time, so I went out and got Red Hat Linux and two 
Western Digital 100 GB hard drives.

Upon installation of one of these drives, I realized that my system's BIOS 
couldn't handle anything above 32 GB. So, I used an alternate jumper setting, 
recommended by Western Digital until I could upgrade my BIOS. Once the 
alternate jumper setting is used, the BIOS sees the hard drive as a 32 GB hard 
drive.

I used the Data LifeGuard disk that came with the Western Digital hard drive to 
install EZ-BIOS on the new hard drive, and to copy the contents of my old hard 
drive onto the new one.

The contents of the drive copied over successfully, and with EZ-BIOS installed, 
Windows 98 recognized all 100 GB of the hard drive's capacity.

After I had Windows 98 running without a problem on the 100 GB drive, I 
formatted the old 20 GB drive with Windows 98 on it and stored it in a safe 
place.

Time for the second drive to be used for Red Hat Linux...

I installed the second drive without a problem.

I booted from the CD-ROM and got the Linux install screen. I chose the GUI for 
installation.

The installation went fine until the Disk Partitioning Setup phase. I chose 
automatic partition, and then I got messages about both of my hard drives 
having to be initialized.

"The partition table on device hda was unreadable. To create new partitions it 
must be initialized, causing the loss of ALL DATA on this drive.

Would you like to initialize this drive?"

I *INITIALLY* said "NO" to the FIRST request (for my Windows drive) and "YES" 
to the SECOND request. I got up to the point in the installation where it came 
to configure DUAL BOOTING so that I may have used Windows and Linux on this 
machine, and /dev/hda (my windows drive) was not listed... So, I went BACK and 
said "YES" to the first request, "initializing" the drive, understanding that 
the loss of data on the drive would come with creating new partitions, NOT with 
initializing. I did this because I was of the understanding that everything 
would have been okay as long as I deselected /dev/hda on the "AUTOMATIC 
PARITIONING" screen, which I did. It even said it was okay in the installation 
guide, page 45, paragraph 1: "If you have two or more hard drives, you can 
choose which hard drive(s) should contain this installation. Unselected hard 
drives, and any data on them, will not be touched."

So, reading that, I UNSELECTED /dev/hda (my windows drive), and went on with 
the automatic partitioning, but WINDOWS was still not listed in the DUAL BOOT 
section of the installation. Hmmph. Okay. I figured it was something trivial 
and continued to finally finish installation.

I rebooted the computer after installation finished, without a disk in the 
drive, and got the message saying, "Not found any [active partition] in HDD, 
DISK BOOT FAILURE, INSERT SYSTEM DISK AND PRESS ENTER". "Uh-oh," I thought to 
myself.

I inserted the Linux Boot Disk I made, and Linux eventually loaded up without a 
problem.

Please tell me how to get my Windows 98 disk back. There's critical information 
on there that cannot be reproduced. It's the fault of whoever wrote in the 
manual that the contents of my drive wouldn't be touched, so I'm holding THEM 
responsible. I NEED access to my Windows drive and its contents.

I can't do anything with Linux, because it doesn't recognize my D-Link 10/100 
Mbps internal ethernet adaptor, nor does it recognize my NewCom Data/Fax/Voice 
Internal 33.6K modem.

What gives? I spent the money on the boxed set to have a better operating 
system than Windoze, not to have all of my files erased!!!!!

Reproducability: Tried, but couldn't reproduce it
Comment 1 Michael Fulbright 2002-12-16 21:43:20 EST
The message says:

To create new partitions it must be initialized, causing the loss of ALL DATA on
this drive.

I'm not sure how this message could be more clear about what the operation was
going to do beyond destorying all data on the drive.

This appears to be an issue with the documentation, reassiging.
Comment 2 Sandra Moore 2002-12-17 12:07:27 EST
Christopher,

While I am trying to figure out a solution to your problem and a fix for the
documentation, please take the time to register your product and use the support
assistance that comes with the purchase of a Red Hat Linux boxed set. The
support team should be able to help you with this problem -- and you are
entitled to this help since you did spend the money on the boxed set.

As for the hardware that isn't being recognized, the support team may be able to
help you with that as well. At the least, you can refer to the hardware
compatibility list at: http://hardware.redhat.com/hcl/.

Best Regards,
Sandra
Comment 3 Sandra Moore 2002-12-17 17:30:19 EST
While we believe that this may be an error caused by the EZ-BIOS application,
enhancements have been made to the documentation to warn users of partition
table errors and to back up their data before peforming an installation.

The changes in the documentation will be reflected in the next public release of
the Red Hat Linux documentation set.

Thanks again for your feedback and for helping us to improve our manuals.

Regards,
Sandra

Note You need to log in before you can comment on or make changes to this bug.