Bug 797929 - Error message during pulp selinux post-installation
Summary: Error message during pulp selinux post-installation
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Pulp
Classification: Retired
Component: z_other
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: ---
Assignee: James Slagle
QA Contact: Preethi Thomas
URL:
Whiteboard:
Depends On: 797927
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-02-27 14:53 UTC by John Matthews
Modified: 2012-05-25 14:14 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 797927
Environment:
Last Closed: 2012-05-25 14:14:51 UTC


Attachments (Terms of Use)

Description John Matthews 2012-02-27 14:53:07 UTC
+++ This bug was initially created as a clone of Bug #797927 +++

Hello,

installing pulp

Enabling port 5674 for qpidd
Installing : pulp-selinux-server-1.0.0-2.el6.noarch
/usr/sbin/semanage: Command not found

Since we enable this port also during Katello configuration it is not an issue for Katello. Setting low severity.

Comment 1 James Slagle 2012-02-28 21:13:07 UTC
added requirement on /usr/sbin/semanage in pulp.spec for pulp-selinux-server
committed to pulp master: 24160a6a72d45972540dceb422334b7226d5f691

Comment 2 Jeff Ortel 2012-02-29 23:16:14 UTC
build: 0.270

Comment 3 Preethi Thomas 2012-03-01 15:29:52 UTC
verified

[root@preethi-el6-pulp ~]# yum install pulp
Loaded plugins: product-id, security, subscription-manager
Updating certificate-based repositories.
epel/metalink                                            | 9.1 kB     00:00     
epel                                                     | 4.0 kB     00:00     
epel/primary_db                                          | 4.2 MB     00:02     
pulp-dev-testing                                         | 1.3 kB     00:00     
pulp-dev-testing/primary                                 | 6.6 kB     00:00     
pulp-dev-testing                                                          21/21
rhel6                                                    | 4.0 kB     00:00     
rhel6/primary_db                                         | 3.1 MB     00:01     
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package pulp.noarch 0:0.0.270-1.el6 will be installed
--> Processing Dependency: pulp-selinux-server = 0.0.270-1.el6 for package: pulp-0.0.270-1.el6.noarch
--> Processing Dependency: pulp-common = 0.0.270 for package: pulp-0.0.270-1.el6.noarch
--> Processing Dependency: grinder >= 0.0.139 for package: pulp-0.0.270-1.el6.noarch
--> Running transaction check
---> Package grinder.noarch 0:0.0.136-1.el6 will be updated
---> Package grinder.noarch 0:0.0.139-1.el6 will be an update
---> Package pulp-common.noarch 0:0.0.270-1.el6 will be installed
---> Package pulp-selinux-server.noarch 0:0.0.270-1.el6 will be installed
--> Processing Dependency: /usr/sbin/semanage for package: pulp-selinux-server-0.0.270-1.el6.noarch
--> Running transaction check
---> Package policycoreutils-python.x86_64 0:2.0.83-19.18.el6 will be installed
--> Processing Dependency: libsemanage-python >= 2.0.43-4 for package: policycoreutils-python-2.0.83-19.18.el6.x86_64
--> Processing Dependency: audit-libs-python >= 1.4.2-1 for package: policycoreutils-python-2.0.83-19.18.el6.x86_64
--> Processing Dependency: setools-libs-python for package: policycoreutils-python-2.0.83-19.18.el6.x86_64
--> Processing Dependency: libselinux-python for package: policycoreutils-python-2.0.83-19.18.el6.x86_64
--> Running transaction check
---> Package audit-libs-python.x86_64 0:2.1.3-3.el6 will be installed
---> Package libselinux-python.x86_64 0:2.0.94-5.2.el6 will be installed
---> Package libsemanage-python.x86_64 0:2.0.43-4.1.el6 will be installed
---> Package setools-libs-python.x86_64 0:3.3.7-4.el6 will be installed
--> Processing Dependency: setools-libs = 3.3.7-4.el6 for package: setools-libs-python-3.3.7-4.el6.x86_64
--> Processing Dependency: libqpol.so.1(VERS_1.3)(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
--> Processing Dependency: libapol.so.4(VERS_4.1)(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
--> Processing Dependency: libseaudit.so.4(VERS_4.1)(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
--> Processing Dependency: libapol.so.4(VERS_4.0)(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
--> Processing Dependency: libpoldiff.so.1(VERS_1.2)(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
--> Processing Dependency: libpoldiff.so.1(VERS_1.3)(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
--> Processing Dependency: libqpol.so.1(VERS_1.2)(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
--> Processing Dependency: libqpol.so.1(VERS_1.4)(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
--> Processing Dependency: libsefs.so.4(VERS_4.0)(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
--> Processing Dependency: libseaudit.so.4(VERS_4.2)(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
--> Processing Dependency: libseaudit.so.4()(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
--> Processing Dependency: libsefs.so.4()(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
--> Processing Dependency: libapol.so.4()(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
--> Processing Dependency: libpoldiff.so.1()(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
--> Processing Dependency: libqpol.so.1()(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
--> Running transaction check
---> Package setools-libs.x86_64 0:3.3.7-4.el6 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package                  Arch     Version             Repository          Size
================================================================================
Installing:
 pulp                     noarch   0.0.270-1.el6       pulp-dev-testing   763 k
Installing for dependencies:
 audit-libs-python        x86_64   2.1.3-3.el6         rhel6               58 k
 libselinux-python        x86_64   2.0.94-5.2.el6      rhel6              202 k
 libsemanage-python       x86_64   2.0.43-4.1.el6      rhel6               81 k
 policycoreutils-python   x86_64   2.0.83-19.18.el6    rhel6              337 k
 pulp-common              noarch   0.0.270-1.el6       pulp-dev-testing    58 k
 pulp-selinux-server      noarch   0.0.270-1.el6       pulp-dev-testing    50 k
 setools-libs             x86_64   3.3.7-4.el6         rhel6              400 k
 setools-libs-python      x86_64   3.3.7-4.el6         rhel6              222 k
Updating for dependencies:
 grinder                  noarch   0.0.139-1.el6       pulp-dev-testing   136 k

Transaction Summary
================================================================================
Install       9 Package(s)
Upgrade       1 Package(s)

Total download size: 2.3 M
Is this ok [y/N]: y
Downloading Packages:
(1/10): audit-libs-python-2.1.3-3.el6.x86_64.rpm         |  58 kB     00:00     
(2/10): grinder-0.0.139-1.el6.noarch.rpm                 | 136 kB     00:00     
(3/10): libselinux-python-2.0.94-5.2.el6.x86_64.rpm      | 202 kB     00:00     
(4/10): libsemanage-python-2.0.43-4.1.el6.x86_64.rpm     |  81 kB     00:00     
(5/10): policycoreutils-python-2.0.83-19.18.el6.x86_64.r | 337 kB     00:00     
(6/10): pulp-0.0.270-1.el6.noarch.rpm                    | 763 kB     00:01     
(7/10): pulp-common-0.0.270-1.el6.noarch.rpm             |  58 kB     00:00     
(8/10): pulp-selinux-server-0.0.270-1.el6.noarch.rpm     |  50 kB     00:00     
(9/10): setools-libs-3.3.7-4.el6.x86_64.rpm              | 400 kB     00:00     
(10/10): setools-libs-python-3.3.7-4.el6.x86_64.rpm      | 222 kB     00:00     
--------------------------------------------------------------------------------
Total                                           337 kB/s | 2.3 MB     00:06     
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing : setools-libs-3.3.7-4.el6.x86_64                             1/11 
  Installing : setools-libs-python-3.3.7-4.el6.x86_64                      2/11 
  Updating   : grinder-0.0.139-1.el6.noarch                                3/11 
  Installing : pulp-common-0.0.270-1.el6.noarch                            4/11 
  Installing : audit-libs-python-2.1.3-3.el6.x86_64                        5/11 
  Installing : libsemanage-python-2.0.43-4.1.el6.x86_64                    6/11 
  Installing : libselinux-python-2.0.94-5.2.el6.x86_64                     7/11 
  Installing : policycoreutils-python-2.0.83-19.18.el6.x86_64              8/11 
  Installing : pulp-selinux-server-0.0.270-1.el6.noarch                    9/11 
Enabling port 5674 for qpidd
  Installing : pulp-0.0.270-1.el6.noarch                                  10/11 
  Cleanup    : grinder-0.0.136-1.el6.noarch                               11/11 
Installed products updated.

Installed:
  pulp.noarch 0:0.0.270-1.el6                                                   

Dependency Installed:
  audit-libs-python.x86_64 0:2.1.3-3.el6                                        
  libselinux-python.x86_64 0:2.0.94-5.2.el6                                     
  libsemanage-python.x86_64 0:2.0.43-4.1.el6                                    
  policycoreutils-python.x86_64 0:2.0.83-19.18.el6                              
  pulp-common.noarch 0:0.0.270-1.el6                                            
  pulp-selinux-server.noarch 0:0.0.270-1.el6                                    
  setools-libs.x86_64 0:3.3.7-4.el6                                             
  setools-libs-python.x86_64 0:3.3.7-4.el6                                      

Dependency Updated:
  grinder.noarch 0:0.0.139-1.el6                                                

Complete!


[root@preethi-el6-pulp ~]# rpm -q --whatprovides /usr/sbin/semanage
policycoreutils-python-2.0.83-19.18.el6.x86_64
[root@preethi-el6-pulp ~]# 

[root@preethi-el6-pulp ~]#  semanage port -l | grep 5674
amqp_port_t                    tcp      5674, 5671, 5672
amqp_port_t                    udp      5674, 5671, 5672
[root@preethi-el6-pulp ~]#

Comment 4 Jeff Ortel 2012-03-14 13:42:42 UTC
build: 1.0.0-5

Comment 5 Preethi Thomas 2012-03-14 14:54:10 UTC
[root@pulp-v1-server ~]# rpm -q pulp
pulp-1.0.0-5.el6.noarch
[root@pulp-v1-server ~]# 


[root@pulp-v1-server ~]# yum remove pulp*
Loaded plugins: product-id, security, subscription-manager
Updating certificate-based repositories.
Setting up Remove Process
Resolving Dependencies
--> Running transaction check
---> Package pulp.noarch 0:1.0.0-2.el6 will be erased
---> Package pulp-common.noarch 0:1.0.0-2.el6 will be erased
---> Package pulp-selinux-server.noarch 0:1.0.0-2.el6 will be erased
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package                 Arch       Version           Repository           Size
================================================================================
Removing:
 pulp                    noarch     1.0.0-2.el6       @pulp-v1-stable     3.2 M
 pulp-common             noarch     1.0.0-2.el6       @pulp-v1-stable      78 k
 pulp-selinux-server     noarch     1.0.0-2.el6       @pulp-v1-stable     126 k

Transaction Summary
================================================================================
Remove        3 Package(s)

Installed size: 3.4 M
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction

  Erasing    : pulp-1.0.0-2.el6.noarch                                      1/3 
  Erasing    : pulp-common-1.0.0-2.el6.noarch                               2/3 
  Erasing    : pulp-selinux-server-1.0.0-2.el6.noarch                       3/3 
Installed products updated.

Removed:
  pulp.noarch 0:1.0.0-2.el6                  pulp-common.noarch 0:1.0.0-2.el6  
  pulp-selinux-server.noarch 0:1.0.0-2.el6  

Complete!
[root@pulp-v1-server ~]# 
[root@pulp-v1-server ~]# semanage port -l | grep amqp_port_t | grep tcp | grep 5674
amqp_port_t                    tcp      5674, 5671, 5672
[root@pulp-v1-server ~]# semanage port -l | grep amqp_port_t | grep udp | grep 5674
amqp_port_t                    udp      5674, 5671, 5672
[root@pulp-v1-server ~]# 
[root@pulp-v1-server ~]# 
[root@pulp-v1-server ~]# vi /etc/yum.repos.d/rhel-pulp.repo 
[root@pulp-v1-server ~]# 
[root@pulp-v1-server ~]# 
[root@pulp-v1-server ~]# 
[root@pulp-v1-server ~]# yum cleanall
Loaded plugins: product-id, security, subscription-manager
Updating certificate-based repositories.
No such command: cleanall. Please use /usr/bin/yum --help
[root@pulp-v1-server ~]# yum clean all
Loaded plugins: product-id, security, subscription-manager
Updating certificate-based repositories.
Cleaning repos: epel pulp-v1-testing rhel6
Cleaning up Everything
[root@pulp-v1-server ~]# yum install pulp
Loaded plugins: product-id, security, subscription-manager
Updating certificate-based repositories.
epel/metalink                                            | 9.4 kB     00:00     
epel                                                     | 4.0 kB     00:00     
epel/primary_db                                          | 4.2 MB     00:07     
pulp-v1-testing                                          | 1.3 kB     00:00     
pulp-v1-testing/primary                                  | 6.6 kB     00:00     
pulp-v1-testing                                                           21/21
rhel6                                                    | 4.0 kB     00:00     
rhel6/primary_db                                         | 3.1 MB     00:01     
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package pulp.noarch 0:1.0.0-5.el6 will be installed
--> Processing Dependency: pulp-selinux-server = 1.0.0 for package: pulp-1.0.0-5.el6.noarch
--> Processing Dependency: pulp-common = 1.0.0 for package: pulp-1.0.0-5.el6.noarch
--> Running transaction check
---> Package pulp-common.noarch 0:1.0.0-5.el6 will be installed
---> Package pulp-selinux-server.noarch 0:1.0.0-5.el6 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package                 Arch       Version           Repository           Size
================================================================================
Installing:
 pulp                    noarch     1.0.0-5.el6       pulp-v1-testing     713 k
Installing for dependencies:
 pulp-common             noarch     1.0.0-5.el6       pulp-v1-testing      48 k
 pulp-selinux-server     noarch     1.0.0-5.el6       pulp-v1-testing      40 k

Transaction Summary
================================================================================
Install       3 Package(s)

Total download size: 801 k
Installed size: 3.3 M
Is this ok [y/N]: y
Downloading Packages:
(1/3): pulp-1.0.0-5.el6.noarch.rpm                       | 713 kB     00:01     
(2/3): pulp-common-1.0.0-5.el6.noarch.rpm                |  48 kB     00:00     
(3/3): pulp-selinux-server-1.0.0-5.el6.noarch.rpm        |  40 kB     00:00     
--------------------------------------------------------------------------------
Total                                           237 kB/s | 801 kB     00:03     
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing : pulp-selinux-server-1.0.0-5.el6.noarch                       1/3 
  Installing : pulp-common-1.0.0-5.el6.noarch                               2/3 
  Installing : pulp-1.0.0-5.el6.noarch                                      3/3 
Installed products updated.

Installed:
  pulp.noarch 0:1.0.0-5.el6                                                     

Dependency Installed:
  pulp-common.noarch 0:1.0.0-5.el6   pulp-selinux-server.noarch 0:1.0.0-5.el6  

Complete!
[root@pulp-v1-server ~]# semanage port -l | grep amqp_port_t | grep tcp | grep 5674
amqp_port_t                    tcp      5674, 5671, 5672
[root@pulp-v1-server ~]# semanage port -l | grep amqp_port_t | grep udp | grep 5674
amqp_port_t                    udp      5674, 5671, 5672
[root@pulp-v1-server ~]# 
[root@pulp-v1-server ~]#

Comment 6 Preethi Thomas 2012-05-25 14:14:51 UTC
Pulp v1.1 Release


Note You need to log in before you can comment on or make changes to this bug.