Bug 7980 - kickstart: clearpart --all/linux
kickstart: clearpart --all/linux
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
All Linux
medium Severity low
: ---
: ---
Assigned To: Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-12-23 22:38 EST by Vilius Puidokas
Modified: 2015-01-07 18:40 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-18 14:41:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vilius Puidokas 1999-12-23 22:38:15 EST
just got a chance to learn in a hard way the fact that:

'clearpart --all' affects not only all partitions, but also all _drives_.

There's nothing mentioned about multidisk stuff in kickstart. Also one
can't specify on which drive should be exact partition built, so one can
make a very *bad* assumption that "kickstart doesn't touch any other
drives."

let's put at least into documentation, that ks DOES touch other disk drives
(hdb, sdb, sdc...), even if you can't do partitioning on them.

suggestion - what about a possibility to give some kindof mix of these
three tables:
  fstab (where to mount),
  fdisk (what to mount, maybe even let playing with cylinders?)
  and our ks table (--size, --grow, --maxsize..)

also: looks like wiping out partition table is not done very clean (touches
fs data?), at least i failed to restore my 6 ext2 fs :'(
[well, had not much time for that]
Comment 1 Erik Troan 2000-02-18 14:41:59 EST
this is documented in our manual
Comment 2 Vilius Puidokas 2000-02-18 16:03:59 EST
ok, i'll be short this time. But just to keep docs (and RH) accurate:
http://www.redhat.com/support/manuals/RHL-6.1-Manual/ref-guide/s1-kickstart-file.html
(also hardcopy of manual on my desk) contains:

-To clear all partitions from a disk, this line would do the trick:
- clearpart --all

should sound like:
+To clear all partitions from all disks, this line would do the trick:
+ clearpart --all

p.s. if it shouldn't touch other disks then it's a bug.

Note You need to log in before you can comment on or make changes to this bug.