Bug 798102 - back tic in wireless password breaks /etc/sysconfig/network-scripts/keys-<SSID-name> when called from ifup
Summary: back tic in wireless password breaks /etc/sysconfig/network-scripts/keys-<SSI...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: 16
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-02-28 03:40 UTC by Mark
Modified: 2012-03-18 00:46 UTC (History)
7 users (show)

Fixed In Version: NetworkManager-0.9.3.995-0.6.git20120314.fc17
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-03-18 00:46:23 UTC
Type: ---


Attachments (Terms of Use)

Description Mark 2012-02-28 03:40:43 UTC
Description of problem:

having a back tic " ` " in the wireless password causes errors with ifup. 

  
Version-Release number of selected component (if applicable):
fedora 16. 

3.2.7-1

How reproducible:

use a backtic in the wireless password

Steps to Reproduce:
1. setup wireless network that requires a back tic in it . (e.g. wpa2-psk with password of something`bad
2. run ifdown wlan0; ifup wlan0
3. observe unexpected EOF. 
  
Actual results:


output of ifup wlan0:

/etc/sysconfig/network-scripts/keys-mySSID: line 1: unexpected EOF while looking for matching ``'
/etc/sysconfig/network-scripts/keys-mySSID: line 2: syntax error: unexpected end of file
Device state: 30 (disconnected)
/etc/sysconfig/network-scripts/keys-mySSID: line 1: unexpected EOF while looking for matching ``'
/etc/sysconfig/network-scripts/keys-mySSID: line 2: syntax error: unexpected end of file
Active connection state: activating
Active connection path: /org/freedesktop/NetworkManager/ActiveConnection/1
state: activated
Connection activated

Expected results:

no unexpected EOF's

Additional info:

nameserver information might not be getting properly passed down due to this error if using DHCP. not sure about that part though.

Comment 1 Mark 2012-02-29 05:22:38 UTC
Version-Release number of selected component (if applicable):

initscripts-9.34-2.fc16.x86_64


how reproducible:

always on my machine? just use a back tic

Comment 2 Lukáš Nykrýn 2012-03-01 12:57:50 UTC
How have you setup the password? I have suspicion that problem is in NetworkManager, but it seems to escape all problematic chars.

Comment 3 Mark 2012-03-06 04:15:26 UTC
not really sure how to properly describe where in the UI I am inputing the password. 


gnome fall back ui. 

using the wireless icon next to my user name in the upper right. 

click on wireless icon->connect to hidden wireless network-> 
new
SSID-Name
wireless security-> wpa & wpa2- personal. 



applogies for my tardiness in updating the bz.

Comment 4 Lukáš Nykrýn 2012-03-06 08:37:47 UTC
As I know initscripts are only reading this file, so if you didn't edit it manually, this should be caused by NetworkManager.

Comment 5 Jirka Klimes 2012-03-07 14:07:57 UTC
NetworkManager qouted the password (WPA_PSK), but double quotes was not enough to
prevent bash from breaking on strings containing special characters.

A fix has been pushed upstream:
79757f10f30885d436f4c5cf528cb0bd4e0acafb

Comment 6 Fedora Update System 2012-03-13 20:46:13 UTC
NetworkManager-0.9.3.995-0.5.git20120313.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/NetworkManager-0.9.3.995-0.5.git20120313.fc17

Comment 7 Fedora Update System 2012-03-14 18:24:30 UTC
NetworkManager-0.9.3.995-0.6.git20120314.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/NetworkManager-0.9.3.995-0.6.git20120314.fc17

Comment 8 Fedora Update System 2012-03-16 02:43:40 UTC
Package NetworkManager-0.9.3.995-0.6.git20120314.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing NetworkManager-0.9.3.995-0.6.git20120314.fc17'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-3861/NetworkManager-0.9.3.995-0.6.git20120314.fc17
then log in and leave karma (feedback).

Comment 9 Fedora Update System 2012-03-18 00:46:23 UTC
NetworkManager-0.9.3.995-0.6.git20120314.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.