Bug 798161 - "Failed to get stripe-size " error messages are seen in the client log
"Failed to get stripe-size " error messages are seen in the client log
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: stripe (Show other bugs)
mainline
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: shishir gowda
:
Depends On:
Blocks: 817967
  Show dependency treegraph
 
Reported: 2012-02-28 03:14 EST by shylesh
Modified: 2013-12-08 20:29 EST (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 13:40:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description shylesh 2012-02-28 03:14:53 EST
Description of problem:
Kernel compilations fails on the stripe volume

Version-Release number of selected component (if applicable):
Mainline

How reproducible:
Always

Steps to Reproduce:
1. created a stripe volume of count 2 
2. started kernel compile on the mount point

  
Actual results:
Compilation fails

Expected results:
should not fail

Additional info:

012-02-28 01:21:24.665482] E [stripe.c:137:stripe_ctx_handle] 0-volstr-stripe-0: Failed to get stripe-size
[2012-02-28 01:21:24.665500] E [stripe.c:486:stripe_lookup_cbk] 0-volstr-stripe-0: Error getting fctx info from dict
[2012-02-28 01:21:24.666458] W [page.c:978:__ioc_page_error] 0-volstr-io-cache: page error for page = 0x7f067c2148d0 & waitq = 0x7f067c372330
[2012-02-28 01:21:24.668435] E [stripe.c:137:stripe_ctx_handle] 0-volstr-stripe-0: Failed to get stripe-size
[2012-02-28 01:21:24.668453] E [stripe.c:486:stripe_lookup_cbk] 0-volstr-stripe-0: Error getting fctx info from dict
[2012-02-28 01:21:24.669069] E [stripe.c:137:stripe_ctx_handle] 0-volstr-stripe-0: Failed to get stripe-size
[2012-02-28 01:21:24.669085] E [stripe.c:486:stripe_lookup_cbk] 0-volstr-stripe-0: Error getting fctx info from dict
[2012-02-28 01:21:24.671152] E [stripe.c:137:stripe_ctx_handle] 0-volstr-stripe-0: Failed to get stripe-size
[2012-02-28 01:21:24.671170] E [stripe.c:486:stripe_lookup_cbk] 0-volstr-stripe-0: Error getting fctx info from dict
[2012-02-28 01:21:24.671714] E [stripe.c:137:stripe_ctx_handle] 0-volstr-stripe-0: Failed to get stripe-size
[2012-02-28 01:21:24.671730] E [stripe.c:486:stripe_lookup_cbk] 0-volstr-stripe-0: Error getting fctx info from dict
[2012-02-28 01:21:24.673714] E [stripe.c:137:stripe_ctx_handle] 0-volstr-stripe-0: Failed to get stripe-size
[2012-02-28 01:21:24.673737] E [stripe.c:486:stripe_lookup_cbk] 0-volstr-stripe-0: Error getting fctx info from dict
[2012-02-28 01:21:24.675317] E [stripe.c:137:stripe_ctx_handle] 0-volstr-stripe-0: Failed to get stripe-size
[2012-02-28 01:21:24.675333] E [stripe.c:486:stripe_lookup_cbk] 0-volstr-stripe-0: Error getting fctx info from dict
[2012-02-28 01:21:24.678710] E [stripe.c:137:stripe_ctx_handle] 0-volstr-stripe-0: Failed to get stripe-size
[2012-02-28 01:21:24.678733] E [stripe.c:486:stripe_lookup_cbk] 0-volstr-stripe-0: Error getting fctx info from dict
[2012-02-28 01:21:24.679313] E [stripe.c:137:stripe_ctx_handle] 0-volstr-stripe-0: Failed to get stripe-size
[2012-02-28 01:21:24.679328] E [stripe.c:486:stripe_lookup_cbk] 0-volstr-stripe-0: Error getting fctx info from dict
[2012-02-28 01:21:24.681460] E [stripe.c:137:stripe_ctx_handle] 0-volstr-stripe-0: Failed to get stripe-size
[2012-02-28 01:21:24.681480] E [stripe.c:486:stripe_lookup_cbk] 0-volstr-stripe-0: Error getting fctx info from dict
[2012-02-28 01:21:24.681694] E [stripe.c:137:stripe_ctx_handle] 0-volstr-stripe-0: Failed to get stripe-size
[2012-02-28 01:21:24.681709] E [stripe.c:486:stripe_lookup_cbk] 0-volstr-stripe-0: Error getting fctx info from dict
[2012-02-28 01:21:24.683244] E [stripe.c:137:stripe_ctx_handle] 0-volstr-stripe-0: Failed to get stripe-size
[2012-02-28 01:21:24.683262] E [stripe.c:486:stripe_lookup_cbk] 0-volstr-stripe-0: Error getting fctx info from dict
Comment 1 shishir gowda 2012-02-29 02:55:12 EST
The compilation is failing because of io-cache errors:


[2012-02-29 13:17:41.994094] W [page.c:978:__ioc_page_error] 0-stripe-io-cache: page error for page = 0x7ff439516760 & waitq = 0x7ff4394e7c30
[2012-02-29 13:17:42.068873] W [page.c:978:__ioc_page_error] 0-stripe-io-cache: page error for page = 0x7ff4395787e0 & waitq = 0x7ff4394d4740

Will investigate as to why stripe-size related error logs are being seen.
Comment 2 Anand Avati 2012-02-29 22:36:56 EST
CHANGE: http://review.gluster.com/2837 (cluster/stripe: Send xattr request in lookup even when type is INVAL) merged in master by Vijay Bellur (vijay@gluster.com)
Comment 3 shylesh 2012-05-18 06:17:01 EDT
No such log messages are seen now on 3.3.0qa41

Note You need to log in before you can comment on or make changes to this bug.