Bug 798169 - Volume set "auth.allow/auth.reject" should re initiate the client connection
Volume set "auth.allow/auth.reject" should re initiate the client connection
Status: CLOSED NOTABUG
Product: GlusterFS
Classification: Community
Component: cli (Show other bugs)
mainline
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Rajesh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-28 03:34 EST by Shwetha Panduranga
Modified: 2013-07-04 18:43 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-15 06:40:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: DP
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Shwetha Panduranga 2012-02-28 03:34:11 EST
Description of problem:
create a volume with auth.allow set to <ip_address/subnet> of client nodes. Perform I/O operations from the mounts on client nodes. set auth.reject <ip_address/subnet> for same client nodes. 

Since the client has mounted to volume before the auth.reject option is set, client nodes are still able to access data and perform operations on data from the mount points. 
  
Ideally, the auth.reject or auth.allow volume set operations should re establish the client connections.
Comment 1 Rajesh 2012-03-15 06:40:03 EDT
This is the expected behavior. Antecedent connections should not be reset.
Comment 2 Shwetha Panduranga 2012-04-09 11:57:27 EDT
This bug has to be documented.

Note You need to log in before you can comment on or make changes to this bug.