Bug 798185 - RFE: Allow direct guest access with spice-xpi
RFE: Allow direct guest access with spice-xpi
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: virt-viewer (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-28 04:10 EST by Marko Myllynen
Modified: 2012-05-26 04:04 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-26 04:04:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Desktop entry (121 bytes, text/plain)
2012-03-15 05:16 EDT, Peter Hatina
no flags Details

  None (edit)
Description Marko Myllynen 2012-02-28 04:10:23 EST
Description of problem:
A SPICE enabled libvirt guest can be accessed using spicec for example with:

spicec --host localhost --port 5900

It would be great if the spice-xpi plugin would allow accessing guests from a browser directly, for example with:

spice://localhost:5900/

or even (needing also some non-plugin changes):

http://localhost:5900/

Thanks.
Comment 1 Peter Hatina 2012-03-15 05:16:47 EDT
Created attachment 570221 [details]
Desktop entry

You can register custom scheme handler and since then, firefox can open spice://hostname:port by remote-viewer.

Steps, how to register:
1. copy remote-viewer.desktop to ~/.local/share/applications or /usr/share/applications
2. run update-desktop-database ~/.local/share/applications or /usr/share/applications
Comment 2 Marko Myllynen 2012-03-15 12:27:41 EDT
Thanks, it works! Now the obvious question is should virt-viewer or spice-xpi do this by default?
Comment 3 Marc-Andre Lureau 2012-03-15 12:44:45 EDT
(In reply to comment #2)
> Thanks, it works! Now the obvious question is should virt-viewer or spice-xpi
> do this by default?

that would be for virt-viewer in this case
Comment 4 Marko Myllynen 2012-03-15 12:53:21 EDT
> that would be for virt-viewer in this case

ok - reassigning to virt-viewer
Comment 5 Daniel Berrange 2012-04-18 09:21:28 EDT
Thanks for the patch, included upstram

http://git.fedorahosted.org/git/?p=virt-viewer.git;a=commit;h=be3ce01096feaca7d3a51ed07cc35b5b2a87633d
Comment 6 Fedora Update System 2012-05-16 08:35:13 EDT
virt-viewer-0.5.3-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/virt-viewer-0.5.3-1.fc17
Comment 7 Fedora Update System 2012-05-26 04:04:31 EDT
virt-viewer-0.5.3-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.