Bug 798222 - nfs-nlm:cthon lock related crash
nfs-nlm:cthon lock related crash
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: nfs (Show other bugs)
pre-release
Unspecified Unspecified
high Severity urgent
: ---
: ---
Assigned To: Vinayaga Raman
:
: 798919 799861 (view as bug list)
Depends On:
Blocks: 817967
  Show dependency treegraph
 
Reported: 2012-02-28 06:31 EST by Saurabh
Modified: 2016-01-19 01:09 EST (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 13:44:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions: 3.3.0qa29
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Saurabh 2012-02-28 06:31:24 EST
Description of problem:
Missing separate debuginfos, use: debuginfo-install glibc-2.12-1.25.el6_1.3.x86_64 libgcc-4.4.5-6.el6.x86_64
(gdb) bt
#0  0x0000003423a87f40 in memcpy () from /lib64/libc.so.6
#1  0x00007f5edd43460d in nlm_copy_lkowner (dst=0x7fff0434e13c, src=0x7f5edb8bc2f0) at nlm4.c:182
#2  0x00007f5edd4359d5 in nlm4_lock_to_gf_flock (flock=0x7fff0434e120, lock=0x7f5edb8bc2d8, excl=0) at nlm4.c:606
#3  0x00007f5edd438311 in nlm4_unlock_fd_resume (carg=0x7f5edb8bbdf0) at nlm4.c:1425
#4  0x00007f5edd4385a9 in nlm4_cancel_resume (carg=0x7f5edb8bbdf0) at nlm4.c:1468
#5  0x00007f5edd4324b4 in nfs3_fh_resolve_inode_done (cs=0x7f5edb8bbdf0, inode=0x7f5edc3fd174) at nfs3-helpers.c:3545
#6  0x00007f5edd433991 in nfs3_fh_resolve_inode (cs=0x7f5edb8bbdf0) at nfs3-helpers.c:3971
#7  0x00007f5edd433a25 in nfs3_fh_resolve_resume (cs=0x7f5edb8bbdf0) at nfs3-helpers.c:4003
#8  0x00007f5edd433c50 in nfs3_fh_resolve_root (cs=0x7f5edb8bbdf0) at nfs3-helpers.c:4057
#9  0x00007f5edd433e90 in nfs3_fh_resolve_and_resume (cs=0x7f5edb8bbdf0, fh=0x7fff0434efa0, entry=0x0, 
    resum_fn=0x7f5edd43843c <nlm4_cancel_resume>) at nfs3-helpers.c:4104
#10 0x00007f5edd438aed in nlm4svc_cancel (req=0x7f5edd0b104c) at nlm4.c:1522
#11 0x00007f5ee18be0b9 in rpcsvc_handle_rpc_call (svc=0xadaaa0, trans=0xbab140, msg=0xba34f0) at rpcsvc.c:514
#12 0x00007f5ee18be45c in rpcsvc_notify (trans=0xbab140, mydata=0xadaaa0, event=RPC_TRANSPORT_MSG_RECEIVED, data=0xba34f0)
    at rpcsvc.c:610
#13 0x00007f5ee18c3db8 in rpc_transport_notify (this=0xbab140, event=RPC_TRANSPORT_MSG_RECEIVED, data=0xba34f0) at rpc-transport.c:498
#14 0x00007f5edb984270 in socket_event_poll_in (this=0xbab140) at socket.c:1686
#15 0x00007f5edb9847f4 in socket_event_handler (fd=18, idx=9, data=0xbab140, poll_in=1, poll_out=0, poll_err=0) at socket.c:1801
#16 0x00007f5ee1b1e05c in event_dispatch_epoll_handler (event_pool=0xac1290, events=0xba4280, i=0) at event.c:794
#17 0x00007f5ee1b1e27f in event_dispatch_epoll (event_pool=0xac1290) at event.c:856
#18 0x00007f5ee1b1e60a in event_dispatch (event_pool=0xac1290) at event.c:956
#19 0x0000000000407dcc in main (argc=7, argv=0x7fff0434f538) at glusterfsd.c:1612
(gdb) quit
[root@RHSSA1 ~]#

Version-Release number of selected component (if applicable):
3.3.0qa24

How reproducible:


Steps to Reproduce:
1.create a dist-rep volume
2.run cthon lock test
3. nfs restart may cause this issue
  
Actual results:

Expected results:


Additional info:
Comment 1 Krishna Srinivas 2012-03-06 05:16:58 EST
*** Bug 798919 has been marked as a duplicate of this bug. ***
Comment 2 Krishna Srinivas 2012-03-06 05:19:29 EST
*** Bug 799861 has been marked as a duplicate of this bug. ***
Comment 3 Anand Avati 2012-03-07 12:18:59 EST
CHANGE: http://review.gluster.com/2877 (nlm: call nlm4_cancel_fd_resume instead of nlm4_unlock_fd_resume when CANCEL proc is called.) merged in master by Vijay Bellur (vijay@gluster.com)

Note You need to log in before you can comment on or make changes to this bug.