Bug 798308 - Problems after recreating a volume with more bricks
Problems after recreating a volume with more bricks
Status: CLOSED WONTFIX
Product: Fedora EPEL
Classification: Fedora
Component: hekafs (Show other bugs)
el6
Unspecified Linux
low Severity low
: ---
: ---
Assigned To: Kaleb KEITHLEY
Fedora Extras Quality Assurance
:
Depends On: 798023
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-28 10:32 EST by Jeff Darcy
Modified: 2012-07-16 09:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 798023
Environment:
Last Closed: 2012-07-16 09:37:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Darcy 2012-02-28 10:32:25 EST
I add two more bricks to an volume and after remount we did not found andy folders which was on the first 2 bricks. 
Self healing is not working, I can mkdir the folder and the systems tells me that the folder exists but we have a lot of subfolders and can't mkdir to all this folders.

--- Additional comment from jdarcy@redhat.com on 2012-02-28 09:56:09 EST ---

If I recall our conversation on IRC correctly, you said that you had created a new volume with the same name as a previous one, but with more bricks.  This seems a bit problematic with respect to things like brick UUIDs and xattr values.  To diagnose, we'll need some more information, such as:

* client and server logs (especially the embedded volfiles and messages from around each daemon's startup)

* xattr values (anything with "gluster" in the name) from at least the per-tenant directories on each brick

Then again, this seems to be a separate problem so perhaps it should be a separate bug.  Mind if I clone this one?

--- Additional comment from cr@plentysystems.de on 2012-02-28 10:09:24 EST ---

Yes this would be fine, 

I have to recreate an Volume with same name, I did not have an option to expand my Volume,.

client Volfile from hfs_mount:

http://pastie.org/3480507

Volfile Node1:

http://pastie.org/3480544

Volfile Node2:

http://pastie.org/3480550

Volfile Node3:

http://pastie.org/3480558

Volfile Node4:

http://pastie.org/3480563
Comment 1 Kaleb KEITHLEY 2012-07-16 09:37:47 EDT
HekaFS will be merged into core GlusterFS

Note You need to log in before you can comment on or make changes to this bug.