Bug 798344 - Missing kernel source file crypto/signature/key.h
Missing kernel source file crypto/signature/key.h
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.2
x86_64 Linux
unspecified Severity high
: rc
: ---
Assigned To: Jarod Wilson
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-28 12:09 EST by William Boyle
Modified: 2012-03-06 21:04 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
x86_64 RHEL 6.2 installed in VirtualBox VM.
Last Closed: 2012-03-06 17:27:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description William Boyle 2012-02-28 12:09:50 EST
Description of problem: The kernel source file crypto/signature/key.h is missing.


Version-Release number of selected component (if applicable):2.6.32-220


How reproducible:unable to build kernel


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info: I was able to copy the crypto/signature/key.h file from 2.6.32-131 and successfully build the kernel.
Comment 3 William Boyle 2012-02-29 00:26:50 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Source rpm installed and built in local ~/rpmbuild tree. Compilation of kernel fails when it tries to build crypto/signature files. Copying key.h from 2.6.32-131 source rpm into crypto/signature allows the build to continue and successfully complete. This seemed safe to me since no other files in that directory had changed between the 131 and 220 kernels.
Comment 4 Jarod Wilson 2012-03-06 17:27:37 EST
$ rpm -ivh kernel-2.6.32-220.el6.src.rpm
...
$ rpmbuild -bp kernel.spec
...
$ ls ~/rpmbuild/BUILD/kernel-2.6.32-220.el6/
linux-2.6.32-220.el6.x86_64  vanilla-2.6.32-220.el6

$ ls ~/rpmbuild/BUILD/kernel-2.6.32-220.el6/linux-2.6.32-220.el6.x86_64/crypto/signature/
dsa.c  key.h  ksign.c  ksign-keyring.c  ksign-parse.c  ksign-publickey.c  local.h  Makefile

As you can see, key.h is there. Its not in the vanilla-* dir, because its generated on the fly by kernel.spec:

$ grep key.h kernel.spec
scripts/bin2c ksign_def_public_key __initdata <extract.pub >crypto/signature/key.h

There's no bug here, looks like you're just looking in the wrong place.

Note also, that building out-of-tree modules isn't generally supposed to be done against a full rebuild of the running kernel, but rather against the running kernel's kernel-devel package.
Comment 5 Jarod Wilson 2012-03-06 17:27:59 EST
Deleted Technical Notes Contents.

Old Contents:
Source rpm installed and built in local ~/rpmbuild tree. Compilation of kernel fails when it tries to build crypto/signature files. Copying key.h from 2.6.32-131 source rpm into crypto/signature allows the build to continue and successfully complete. This seemed safe to me since no other files in that directory had changed between the 131 and 220 kernels.
Comment 6 William Boyle 2012-03-06 21:04:32 EST
Ok. I was not using rpmbuild to prep the OS, extracting some of those pesky missing parts. Interesting that the kernel built as soon as the key.h file had been restored. Anyway, sorry for the panic.

Note You need to log in before you can comment on or make changes to this bug.