Bug 798376 - Loading sync management page generates potentially thousands of notices
Loading sync management page generates potentially thousands of notices
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: API (Show other bugs)
6.0.1
Unspecified Unspecified
urgent Severity urgent (vote)
: Unspecified
: --
Assigned To: Eric Helms
Og Maciel
: Triaged
Depends On:
Blocks: 798683
  Show dependency treegraph
 
Reported: 2012-02-28 13:35 EST by James Laska
Modified: 2014-09-18 11:32 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-15 14:54:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
production log containing errors (2.69 MB, application/octet-stream)
2012-02-28 13:47 EST, Brad Buckingham
no flags Details

  None (edit)
Description James Laska 2012-02-28 13:35:58 EST
= Abstract = 

Loading sync management page generates potentially thousands of notices

While debugging bug 798007, found that each time a user loads the sync management page, a separate warning notice is being created for each of the errors that occured while syncing the repos.  

In the case of bug 798007, this resulted in over 3000 notices being generated per page load.  This eventually affect the performance of the app.

This needs to be investigated.   If a notice is to be generated, it should probably be a single notices with a summary of the issues found in the notice details.  Alternatively, in this case, perhaps those notices should be generated at sync time and not when loading the page.

= Software Tested =
 * candlepin-0.5.22-1.el6.src.rpm
 * katello-0.1.300-1.el6.src.rpm
 * katello-certs-tools-1.0.2-2.el6.src.rpm
 * katello-cli-0.1.100-2.el6.src.rpm
 * katello-configure-0.1.100-7.el6.src.rpm
 * katello-httpd-ssl-key-pair-1.0-1.src.rpm
 * katello-qpid-broker-key-pair-1.0-1.src.rpm
 * katello-selinux-0.1.7-1.el6.src.rpm
 * katello-trusted-ssl-cert-1.0-1.src.rpm
 * pulp-0.0.267-2.el6.src.rpm
Comment 1 Brad Buckingham 2012-02-28 13:47:56 EST
Created attachment 566379 [details]
production log containing errors

The errors in this log were also generated in the form of notices.  Note: over 3000 notices would be generated based on this log.
Comment 4 Lukas Zapletal 2012-03-01 11:34:12 EST
QA note:

This bug can be verified together with https://bugzilla.redhat.com/show_bug.cgi?id=798007
Comment 6 Eric Helms 2012-03-09 14:46:04 EST
866d297c388460342ab956f86b6189c7bacb4404


    This bug fixes makes a number of changes to how the most recent sync
    status is determined and stored in the database.  Whenever a sync is
    started an object will be created in the databse to track the pulp task
    and be updated as the sync status is updated from pulp.  Further, upon
    completion of a sync, a delayed job will kickoff that will generate a
    success or error notice and if there are errors dump the errors to the
    log.  This change also reduces the number of calls to pulp when
    calculating the overall size of a product in the UI.798376 - Sync
    management page reworked to generate error and success notices once upon
    sync completion.
Comment 7 Ivan Necas 2012-03-12 05:08:45 EDT
Fixing small problem in commit  995d64fd2e9c06a70784d830e50f5da0a4dfbbfb:

Calling repo discovery on CLI caused 'undefined method `length' for 0:Fixnum' error. Setting default value for error_details to [] instead of 0
Comment 8 Ivan Necas 2012-03-13 08:29:59 EDT
Another regressions found in system-tests fixed in commit 2ca51d8b96037a289428d9e8abca26b8abd54dd9
Comment 9 Ivan Necas 2012-03-13 13:58:59 EDT
Another small fix in commit  54c6c3e01b18e3737b057480b3b07603b7ede355: ordering the tasks to get the most recent in UI sync management
Comment 13 Og Maciel 2012-03-16 15:08:41 EDT
Validated:
* candlepin-0.5.26-1.el6.noarch
* candlepin-tomcat6-0.5.26-1.el6.noarch
* katello-0.1.304-1.el6.noarch
* katello-all-0.1.304-1.el6.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.0.4-1.el6.noarch
* katello-cli-0.1.105-1.el6.noarch
* katello-cli-common-0.1.105-1.el6.noarch
* katello-common-0.1.304-1.el6.noarch
* katello-configure-0.1.106-1.el6.noarch
* katello-glue-candlepin-0.1.304-1.el6.noarch
* katello-glue-foreman-0.1.304-1.el6.noarch
* katello-glue-pulp-0.1.304-1.el6.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-0.1.9-1.el6.noarch
* pulp-1.0.0-5.el6.noarch
* pulp-common-1.0.0-5.el6.noarch
* pulp-selinux-server-1.0.0-5.el6.noarch
Comment 14 errata-xmlrpc 2012-05-15 14:54:10 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0665.html
Comment 15 Mike McCune 2013-08-16 13:53:20 EDT
getting rid of 6.0.0 version since that doesn't exist

Note You need to log in before you can comment on or make changes to this bug.