Bug 798393 - SELinux is preventing /usr/lib64/virtualbox/VBoxSVC from 'execute' accesses on the fichier /usr/lib64/virtualbox/VirtualBox.
SELinux is preventing /usr/lib64/virtualbox/VBoxSVC from 'execute' accesses o...
Status: CLOSED DUPLICATE of bug 797437
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:b276e5c1ba619ccfffb2a218098...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-28 14:15 EST by Pascal94
Modified: 2012-02-29 06:25 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-29 06:25:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pascal94 2012-02-28 14:15:20 EST
libreport version: 2.0.8
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.2.7-1.fc16.x86_64
reason:         SELinux is preventing /usr/lib64/virtualbox/VBoxSVC from 'execute' accesses on the fichier /usr/lib64/virtualbox/VirtualBox.
time:           mar. 28 févr. 2012 20:15:10 CET

description:
:SELinux is preventing /usr/lib64/virtualbox/VBoxSVC from 'execute' accesses on the fichier /usr/lib64/virtualbox/VirtualBox.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that VBoxSVC should be allowed execute access on the VirtualBox file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep VBoxSVC /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:boinc_t:s0
:Target Context                system_u:object_r:execmem_exec_t:s0
:Target Objects                /usr/lib64/virtualbox/VirtualBox [ file ]
:Source                        VBoxSVC
:Source Path                   /usr/lib64/virtualbox/VBoxSVC
:Port                          <Inconnu>
:Host                          (removed)
:Source RPM Packages           VirtualBox-OSE-4.1.8-2.fc16.x86_64
:Target RPM Packages           VirtualBox-OSE-4.1.8-2.fc16.x86_64
:Policy RPM                    selinux-policy-3.10.0-75.fc16.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux CM-ELITE-341 3.2.7-1.fc16.x86_64 #1 SMP Tue
:                              Feb 21 01:40:47 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    dim. 26 févr. 2012 11:46:29 CET
:Last Seen                     dim. 26 févr. 2012 11:46:29 CET
:Local ID                      cee1716b-6cc6-48dd-a465-575b02bbc6e2
:
:Raw Audit Messages
:type=AVC msg=audit(1330253189.19:173): avc:  denied  { execute } for  pid=7855 comm="VBoxSVC" name="VirtualBox" dev=sda1 ino=393543 scontext=system_u:system_r:boinc_t:s0 tcontext=system_u:object_r:execmem_exec_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1330253189.19:173): arch=x86_64 syscall=access success=yes exit=0 a0=7f186d3e3740 a1=1 a2=ffffffff a3=65342d633330302d items=0 ppid=1 pid=7855 auid=4294967295 uid=993 gid=990 euid=993 suid=993 fsuid=993 egid=990 sgid=990 fsgid=990 tty=(none) ses=4294967295 comm=VBoxSVC exe=/usr/lib64/virtualbox/VBoxSVC subj=system_u:system_r:boinc_t:s0 key=(null)
:
:Hash: VBoxSVC,boinc_t,execmem_exec_t,file,execute
:
:audit2allow
:
:#============= boinc_t ==============
:allow boinc_t execmem_exec_t:file execute;
:
:audit2allow -R
:
:#============= boinc_t ==============
:allow boinc_t execmem_exec_t:file execute;
:
Comment 1 Miroslav Grepl 2012-02-29 06:25:36 EST

*** This bug has been marked as a duplicate of bug 797437 ***

Note You need to log in before you can comment on or make changes to this bug.