Bug 798394 - SELinux is preventing /usr/lib64/virtualbox/VBoxXPCOMIPCD from 'execute_no_trans' accesses on the fichier /usr/lib64/virtualbox/VBoxXPCOMIPCD.
SELinux is preventing /usr/lib64/virtualbox/VBoxXPCOMIPCD from 'execute_no_tr...
Status: CLOSED DUPLICATE of bug 797437
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2012-02-28 14:15 EST by Pascal94
Modified: 2012-02-29 06:25 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2012-02-29 06:25:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Pascal94 2012-02-28 14:15:46 EST
libreport version: 2.0.8
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.2.7-1.fc16.x86_64
reason:         SELinux is preventing /usr/lib64/virtualbox/VBoxXPCOMIPCD from 'execute_no_trans' accesses on the fichier /usr/lib64/virtualbox/VBoxXPCOMIPCD.
time:           mar. 28 févr. 2012 20:15:37 CET

:SELinux is preventing /usr/lib64/virtualbox/VBoxXPCOMIPCD from 'execute_no_trans' accesses on the fichier /usr/lib64/virtualbox/VBoxXPCOMIPCD.
:*****  Plugin catchall (100. confidence) suggests  ***************************
:If you believe that VBoxXPCOMIPCD should be allowed execute_no_trans access on the VBoxXPCOMIPCD file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:allow this access for now by executing:
:# grep VBoxXPCOMIPCD /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:Additional Information:
:Source Context                system_u:system_r:boinc_t:s0
:Target Context                system_u:object_r:lib_t:s0
:Target Objects                /usr/lib64/virtualbox/VBoxXPCOMIPCD [ file ]
:Source                        VBoxXPCOMIPCD
:Source Path                   /usr/lib64/virtualbox/VBoxXPCOMIPCD
:Port                          <Inconnu>
:Host                          (removed)
:Source RPM Packages           VirtualBox-OSE-4.1.8-2.fc16.x86_64
:Target RPM Packages           VirtualBox-OSE-4.1.8-2.fc16.x86_64
:Policy RPM                    selinux-policy-3.10.0-75.fc16.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux CM-ELITE-341 3.2.7-1.fc16.x86_64 #1 SMP Tue
:                              Feb 21 01:40:47 UTC 2012 x86_64 x86_64
:Alert Count                   2
:First Seen                    dim. 26 févr. 2012 11:46:06 CET
:Last Seen                     dim. 26 févr. 2012 11:46:22 CET
:Local ID                      fdefae0e-40ec-4328-835a-2fe70148b00c
:Raw Audit Messages
:type=AVC msg=audit(1330253182.806:167): avc:  denied  { execute_no_trans } for  pid=7774 comm="VBoxManage" path="/usr/lib64/virtualbox/VBoxXPCOMIPCD" dev=sda1 ino=398707 scontext=system_u:system_r:boinc_t:s0 tcontext=system_u:object_r:lib_t:s0 tclass=file
:type=SYSCALL msg=audit(1330253182.806:167): arch=x86_64 syscall=execve success=yes exit=0 a0=262d3a8 a1=7ffff7774e50 a2=262ed30 a3=7ff42cb88ad0 items=0 ppid=1 pid=7774 auid=4294967295 uid=993 gid=990 euid=993 suid=993 fsuid=993 egid=990 sgid=990 fsgid=990 tty=(none) ses=4294967295 comm=VBoxXPCOMIPCD exe=/usr/lib64/virtualbox/VBoxXPCOMIPCD subj=system_u:system_r:boinc_t:s0 key=(null)
:Hash: VBoxXPCOMIPCD,boinc_t,lib_t,file,execute_no_trans
:#============= boinc_t ==============
:allow boinc_t lib_t:file execute_no_trans;
:audit2allow -R
:#============= boinc_t ==============
:allow boinc_t lib_t:file execute_no_trans;
Comment 1 Miroslav Grepl 2012-02-29 06:25:41 EST

*** This bug has been marked as a duplicate of bug 797437 ***

Note You need to log in before you can comment on or make changes to this bug.