Bug 798464 - [abrt] kernel: WARNING: at drivers/mmc/host/sdhci.c:962 sdhci_send_command+0xc16/0xd00 [sdhci]()
[abrt] kernel: WARNING: at drivers/mmc/host/sdhci.c:962 sdhci_send_command+0x...
Status: CLOSED DUPLICATE of bug 126342
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
abrt_hash:b8ba55dd2dab0e40dce03cd2c4c...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-28 18:06 EST by gcarter
Modified: 2012-02-29 11:04 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-29 11:04:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description gcarter 2012-02-28 18:06:01 EST
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        BOOT_IMAGE=/vmlinuz-3.3.0-rc5-aesgi root=UUID=a18f7c65-dc51-47ce-975f-b66eda77b415 ro radeon.pcie_gen2=1 rd.md=0 rd.lvm=0 rd.dm=0 KEYTABLE=us quiet SYSFONT=latarcyrheb-sun16 rhgb rd.luks=0 LANG=en_US.UTF-8
kernel:         3.3.0-rc5-aesgi
reason:         WARNING: at drivers/mmc/host/sdhci.c:962 sdhci_send_command+0xc16/0xd00 [sdhci]()
time:           Tue 28 Feb 2012 04:55:17 PM CST

backtrace:
:WARNING: at drivers/mmc/host/sdhci.c:962 sdhci_send_command+0xc16/0xd00 [sdhci]()
:Hardware name: W840DI
:Modules linked in: ir_lirc_codec lirc_dev ir_mce_kbd_decoder ir_sanyo_decoder ir_sony_decoder ir_jvc_decoder rc_rc6_mce mceusb ir_rc6_decoder ir_rc5_decoder ir_nec_decoder rc_core snd_hda_codec_hdmi snd_hda_codec_realtek uvcvideo videobuf2_core videodev media btusb v4l2_compat_ioctl32 videobuf2_vmalloc videobuf2_memops hid_logitech_dj bluetooth snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device rfkill r592 snd_pcm snd_timer microcode memstick joydev i2c_i801 sky2 mmc_block pcspkr snd iTCO_wdt iTCO_vendor_support soundcore snd_page_alloc video vhost_net macvtap macvlan tun virtio_net kvm_intel kvm sunrpc binfmt_misc uinput sdhci_pci firewire_ohci sdhci mmc_core firewire_core crc_itu_t radeon ttm drm_kms_helper drm i2c_algo_bit i2c_core [last unloaded: scsi_wait_scan]
:Pid: 0, comm: swapper/1 Not tainted 3.3.0-rc5-aesgi #1
:Call Trace:
: <IRQ>  [<ffffffff8105671f>] warn_slowpath_common+0x7f/0xc0
: [<ffffffff8105677a>] warn_slowpath_null+0x1a/0x20
: [<ffffffffa00895b6>] sdhci_send_command+0xc16/0xd00 [sdhci]
: [<ffffffff812d6a10>] ? swiotlb_tbl_unmap_single+0xe0/0x100
: [<ffffffff812d7170>] ? unmap_single+0x50/0x70
: [<ffffffffa0089e29>] sdhci_finish_data+0xe9/0x380 [sdhci]
: [<ffffffff810822d3>] ? __wake_up+0x53/0x70
: [<ffffffffa008a688>] sdhci_irq+0x3a8/0x8c8 [sdhci]
: [<ffffffff8107d1d2>] ? hrtimer_get_next_event+0xf2/0x100
: [<ffffffff810dfd75>] handle_irq_event_percpu+0x55/0x220
: [<ffffffff8108c7b5>] ? sched_clock_local+0x25/0x90
: [<ffffffff810dff85>] handle_irq_event+0x45/0x70
: [<ffffffff810e30af>] handle_fasteoi_irq+0x5f/0xf0
: [<ffffffff81016280>] handle_irq+0x60/0x150
: [<ffffffff8161cefa>] ? atomic_notifier_call_chain+0x1a/0x20
: [<ffffffff81622e3a>] do_IRQ+0x5a/0xe0
: [<ffffffff816193ae>] common_interrupt+0x6e/0x6e
: <EOI>  [<ffffffff8134d8aa>] ? arch_local_irq_enable+0x8/0xd
: [<ffffffff8108cafa>] ? sched_clock_idle_wakeup_event+0x1a/0x20
: [<ffffffff8134e5e9>] acpi_idle_enter_simple+0xd3/0x115
: [<ffffffff814c0151>] cpuidle_idle_call+0xc1/0x280
: [<ffffffff8101322f>] cpu_idle+0xcf/0x120
: [<ffffffff8160508a>] start_secondary+0x282/0x284

comment:
:Booting up, mmc host controller sdhci has a init issue.
:
:Doesn't happen though once the machine is booted, then media inserted into the mmc has no issues.

smolt_data:
:
:
:General
:=================================
:UUID: 59345252-9f8a-4144-9e0a-e935b851de8b
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: x86_64
:BogoMIPS: 5053.83
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM)2 Extreme CPU Q9300  @ 2.53GHz
:CPU Stepping: 10
:CPU Family: 6
:CPU Model Num: 23
:Number of CPUs: 4
:CPU Speed: 2533
:System Memory: 7982
:System Swap: 0
:Vendor: Intel
:System: W840DI W840.028
:Form factor: Other
:Kernel: 3.3.0-rc5-aesgi
:SELinux Enabled: 0
:SELinux Policy: targeted
:SELinux Enforce: Unknown
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(4523:17251:5663:8314) pci, sky2, ETHERNET, 88E8055 PCI-E Gigabit Ethernet Controller
:(32902:10816:5663:8314) pci, None, HOST/PCI, Mobile 4 Series Chipset Memory Controller Hub
:(32902:10817:5663:8314) pci, pcieport, PCI/PCI, Mobile 4 Series Chipset PCI Express Graphics Port
:(5772:42:6715:4225) pci, None, NETWORK, AW-NE773 802.11abgn Wireless Half-size Mini PCIe Card
:(4277:34340:4277:34340) pci, pcieport, PCI/PCI, PEX 8624 24-lane, 6-Port PCI Express Gen 2 (5.0 GT/s) Switch [ExpressLane]
:(32902:10544:5663:8314) pci, None, SERIAL, 82801I (ICH9 Family) SMBus Controller
:(32902:10536:5663:8314) pci, ata_piix, STORAGE, ICH9M/M-E 2 port SATA IDE Controller
:(32902:10519:5663:8314) pci, None, PCI/ISA, ICH9M-E LPC Interface Controller
:(32902:10541:5663:8314) pci, ata_piix, STORAGE, ICH9M/M-E 2 port SATA IDE Controller
:(6164:1921:6041:33148) pci, rt2800pci, NETWORK, RT2860
:(6523:9056:5663:8314) pci, ahci, STORAGE, JMB360 AHCI Controller
:(4277:34340:4277:34340) pci, pcieport, PCI/PCI, PEX 8624 24-lane, 6-Port PCI Express Gen 2 (5.0 GT/s) Switch [ExpressLane]
:(32902:10549:5663:8314) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #2
:(32902:9288:5663:8314) pci, None, PCI/PCI, 82801 Mobile PCI Bridge
:(32902:10553:5663:8314) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #6
:(32902:10550:5663:8314) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #3
:(4277:34340:4277:34340) pci, pcieport, PCI/PCI, PEX 8624 24-lane, 6-Port PCI Express Gen 2 (5.0 GT/s) Switch [ExpressLane]
:(32902:10554:5663:8314) pci, ehci_hcd, USB, 82801I (ICH9 Family) USB2 EHCI Controller #1
:(32902:10556:5663:8314) pci, ehci_hcd, USB, 82801I (ICH9 Family) USB2 EHCI Controller #2
:(4098:38153:5663:8314) pci, radeon, VIDEO, N/A
:(32902:10564:5663:8314) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 3
:(32902:10566:5663:8314) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 4
:(32902:10560:5663:8314) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 1
:(4480:1426:5663:8314) pci, r592, BASE, R5C592 Memory Stick Bus Host Adapter
:(32902:10568:5663:8314) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 5
:(32902:10558:5663:8314) pci, snd_hda_intel, MULTIMEDIA, 82801I (ICH9 Family) HD Audio Controller
:(4098:38153:5663:8314) pci, radeon, VIDEO, N/A
:(32902:10551:5663:8314) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #4
:(4480:2098:5663:8314) pci, firewire_ohci, FIREWIRE, R5C832 IEEE 1394 Controller
:(32902:10548:5663:8314) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #1
:(4277:34340:4277:34340) pci, pcieport, PCI/PCI, PEX 8624 24-lane, 6-Port PCI Express Gen 2 (5.0 GT/s) Switch [ExpressLane]
:(4480:2082:5663:8314) pci, sdhci-pci, BASE, R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter
:(4098:43544:5663:43544) pci, snd_hda_intel, MULTIMEDIA, Radeon HD 3870 Audio device
:(32902:10552:5663:8314) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #5
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sda2 / ext4 4096 4096 28630139 12198734 10765134 7168000 6261216 6261216
:/dev/sdb1 WITHHELD ext4 4096 4096 121965836 15354552 9249733 30531584 28327512 28327512
:/dev/sda1 /boot ext4 1024 1024 508745 284944 259344 128016 127769 127769
:
Comment 1 Josh Boyer 2012-02-29 11:04:09 EST
(In reply to comment #0)
> libreport version: 2.0.8
> abrt_version:   2.0.7
> cmdline:        BOOT_IMAGE=/vmlinuz-3.3.0-rc5-aesgi
> root=UUID=a18f7c65-dc51-47ce-975f-b66eda77b415 ro radeon.pcie_gen2=1 rd.md=0
> rd.lvm=0 rd.dm=0 KEYTABLE=us quiet SYSFONT=latarcyrheb-sun16 rhgb rd.luks=0
> LANG=en_US.UTF-8
> kernel:         3.3.0-rc5-aesgi
> reason:         WARNING: at drivers/mmc/host/sdhci.c:962
> sdhci_send_command+0xc16/0xd00 [sdhci]()
> time:           Tue 28 Feb 2012 04:55:17 PM CST
> 
> backtrace:
> :WARNING: at drivers/mmc/host/sdhci.c:962 sdhci_send_command+0xc16/0xd00
> [sdhci]()
> :Hardware name: W840DI
> :Modules linked in: ir_lirc_codec lirc_dev ir_mce_kbd_decoder ir_sanyo_decoder
> ir_sony_decoder ir_jvc_decoder rc_rc6_mce mceusb ir_rc6_decoder ir_rc5_decoder
> ir_nec_decoder rc_core snd_hda_codec_hdmi snd_hda_codec_realtek uvcvideo
> videobuf2_core videodev media btusb v4l2_compat_ioctl32 videobuf2_vmalloc
> videobuf2_memops hid_logitech_dj bluetooth snd_hda_intel snd_hda_codec
> snd_hwdep snd_seq snd_seq_device rfkill r592 snd_pcm snd_timer microcode
> memstick joydev i2c_i801 sky2 mmc_block pcspkr snd iTCO_wdt iTCO_vendor_support
> soundcore snd_page_alloc video vhost_net macvtap macvlan tun virtio_net
> kvm_intel kvm sunrpc binfmt_misc uinput sdhci_pci firewire_ohci sdhci mmc_core
> firewire_core crc_itu_t radeon ttm drm_kms_helper drm i2c_algo_bit i2c_core
> [last unloaded: scsi_wait_scan]
> :Pid: 0, comm: swapper/1 Not tainted 3.3.0-rc5-aesgi #1

Fedora didn't build that kernel, and it's certainly not in F16.

If you can recreate on a stock fedora kernel, please open a new bug.

*** This bug has been marked as a duplicate of bug 126342 ***

Note You need to log in before you can comment on or make changes to this bug.