Bug 798480 - SELinux is preventing /opt/google/chrome/chrome-sandbox from 'read' accesses on the None sessions.
SELinux is preventing /opt/google/chrome/chrome-sandbox from 'read' accesses ...
Status: CLOSED DUPLICATE of bug 798479
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:c2799d5abc38df300a78dbe806e...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-28 20:30 EST by Step Schwarz
Modified: 2012-02-29 06:24 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-29 06:24:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Step Schwarz 2012-02-28 20:30:49 EST
libreport version: 2.0.8
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.3.0-0.rc3.git7.2.fc17.x86_64
reason:         SELinux is preventing /opt/google/chrome/chrome-sandbox from 'read' accesses on the None sessions.
time:           Tue 28 Feb 2012 08:30:33 PM EST

description:
:SELinux is preventing /opt/google/chrome/chrome-sandbox from 'read' accesses on the None sessions.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that chrome-sandbox should be allowed read access on the sessions <Unknown> by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep chrome-sandbox /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:chrome_sandbox_t:s0-s0:c
:                              0.c1023
:Target Context                unconfined_u:unconfined_r:chrome_sandbox_t:s0-s0:c
:                              0.c1023
:Target Objects                sessions [ None ]
:Source                        chrome-sandbox
:Source Path                   /opt/google/chrome/chrome-sandbox
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           google-chrome-stable-17.0.963.56-121963.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-89.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.0-0.rc3.git7.2.fc17.x86_64 #1
:                              SMP Fri Feb 17 18:55:53 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    Tue 28 Feb 2012 08:24:36 PM EST
:Last Seen                     Tue 28 Feb 2012 08:24:36 PM EST
:Local ID                      2d0d5edc-e3e1-4fe6-8b98-5816cb141196
:
:Raw Audit Messages
:type=AVC msg=audit(1330478676.262:30): avc:  denied  { read } for  pid=731 comm="NetworkManager" name="sessions" dev="tmpfs" ino=14854 scontext=system_u:system_r:NetworkManager_t:s0 tcontext=system_u:object_r:systemd_logind_sessions_t:s0 tclass=dirnode=(removed) type=AVC msg=audit(1330478777.878:73): avc:  denied  { sys_ptrace } for  pid=1762 comm="chrome-sandbox" capability=19  scontext=unconfined_u:unconfined_r:chrome_sandbox_t:s0-s0:c0.c1023 tcontext=unconfined_u:unconfined_r:chrome_sandbox_t:s0-s0:c0.c1023 tclass=capabilitynode=(removed) type=SYSCALL msg=audit(1330478777.878:73): arch=c000003e syscall=89 success=no exit=-13 a0=7fffc60c8190 a1=7fffc60c8090 a2=ff a3=7fffc60c7d40 items=0 ppid=1750 pid=1762 auid=1000 uid=1000 gid=1000 euid=0 suid=0 fsuid=0 egid=1000 sgid=1000 fsgid=1000 tty=(none) ses=2 comm="chrome-sandbox" exe="/opt/google/chrome/chrome-sandbox" subj=unconfined_u:unconfined_r:chrome_sandbox_t:s0-s0:c0.c1023 key=(null)
:
:
:Hash: chrome-sandbox,chrome_sandbox_t,chrome_sandbox_t,None,read
:
:audit2allow
:
:
:audit2allow -R
:
:
Comment 1 Miroslav Grepl 2012-02-29 06:24:00 EST

*** This bug has been marked as a duplicate of bug 798479 ***

Note You need to log in before you can comment on or make changes to this bug.