Bug 798483 - IOError: No such file or directory: '/mnt/sysimage/boot/grub2/device.map'
IOError: No such file or directory: '/mnt/sysimage/boot/grub2/device.map'
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-28 20:49 EST by John Reiser
Modified: 2012-07-18 19:36 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-18 19:36:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda traceback and debug info (2.05 MB, text/plain)
2012-02-28 20:49 EST, John Reiser
no flags Details

  None (edit)
Description John Reiser 2012-02-28 20:49:44 EST
Created attachment 566439 [details]
anaconda traceback and debug info

Description of problem: Install from DVD for Fedora 17 Alpha x86_64 crashes when installing boot loader on target root partition.


Version-Release number of selected component (if applicable):
anaconda 17.11

How reproducible:


Steps to Reproduce:
1. Use pungi to create install DVD from f17-branched (Alpha), updates, and updates-testing on Tues.Feb.28 (uses anaconda-17.11 and kernel-3.3.0-0.rc4.git1.4.fc17.x86_64)
2. Boot DVD for fresh install, Basic disk devices, Custom partitioning, choose existing partition to reformat as ext4 for root.
3. Put boot loader on beginning of root partition.
  
Actual results:
anaconda 17.11 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 1659, in write_device_map
    dev_map = open(map_path, "w")
  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 1729, in write_config
    self.write_device_map()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 1068, in write
    self.write_config()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 2250, in writeBootloader
    anaconda.bootloader.write()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 383, in dispatch
    self.dir = self.steps[self.step].target(self.anaconda)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 247, in go_forward
    self.dispatch()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1200, in nextClicked
    self.anaconda.dispatch.go_forward()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/progress_gui.py", line 79, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1220, in handleRenderCallback
    self.currentWindow.renderCallback()
IOError: [Errno 2] No such file or directory: '/mnt/sysimage/boot/grub2/device.map'


Expected results: no complaint


Additional info:
Comment 1 Chris Lumens 2012-03-01 10:09:20 EST
Did the grub2 package get dropped from your tree?  From your log files:

17:13:02,806 DEBUG anaconda: no package matching grub2
Comment 2 John Reiser 2012-03-01 11:14:24 EST
I see grub2 package:
-rw-r--r--. 1 root root 1309793 Dec 14 12:21 /var/cache/pungi/fedora-17-branched/packages/grub2-1.99-14.fc17.x86_64.rpm

The only mention of grub2 in lorax-17.6-1.fc17.x86_64 is:
/usr/share/lorax/runtime-cleanup.tmpl:removefrom grub2 /sbin/* /usr/bin/*

How should I check that grub2 should have been included (what caused anaconda's complaint)?
Comment 3 David Lehman 2012-03-01 12:04:55 EST
The issue is that there's no grub2 rpm in your DVD's Packages/ dir. I think pungi is the one that chooses the packages for the DVD. That's where you want to look.
Comment 4 John Reiser 2012-03-01 23:59:28 EST
I cannot find anything in pungi right now.  I'll check again on Tues.Mar.6.
Comment 5 John Reiser 2012-03-06 10:59:30 EST
Immediate cause was old /usr/share/spin-kickstarts/fedora-install-fedora.ks  which did not list grub2, grub-efi, and efibootmgr.  Updating package fedora-kickstarts fixed the immediate problem.

There should be a warning at compose time if grub2, grub-efi, or efibootmgr packages are not present.  I suppose that implicates pungi.
Comment 6 John Reiser 2012-03-06 12:18:08 EST
> There should be a warning at compose time if grub2, grub-efi, or efibootmgr
> packages are not present.  I suppose that implicates pungi.

Upon further review, I believe that anaconda should change this message:
   17:13:02,806 DEBUG anaconda: no package matching grub2
into a full ERROR.  At least, the shell exit status code should be non-zero.
Comment 7 Jesse Keating 2012-07-18 19:36:19 EDT
We don't normally error out if requested packages aren't available.  We don't have a good way of knowing what is "critical" and what isn't, nor do we really want to create such a list.

Note You need to log in before you can comment on or make changes to this bug.