Bug 798504 - 64bit branched fails to build installable images
64bit branched fails to build installable images
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: lorax (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Gracik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-29 00:26 EST by Kevin Fenzi
Modified: 2013-07-04 09:01 EDT (History)
4 users (show)

See Also:
Fixed In Version: lorax-17.7-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-29 02:54:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kevin Fenzi 2012-02-29 00:26:29 EST
The 17 branched compose the 64 bit tree is failing to build images and be installable. 
The 32bit side is working fine. 

See:
http://kojipkgs.fedoraproject.org/mash/branched-20120228/logs/pungify-x86_64.log
and
http://kojipkgs.fedoraproject.org/mash/branched-20120228/logs/pungify-i386.log
(for example)

Excerpt from the x86_64 log: 

populating output tree and building boot images
running x86.tmpl
mount: unknown filesystem type 'hfsplus'
Traceback (most recent call last):
  File "/usr/sbin/mkefiboot", line 105, in <module>
    mkmacboot(opt.bootdir, opt.outfile, opt.label, opt.icon)
  File "/usr/sbin/mkefiboot", line 35, in mkmacboot
    mkhfsimg(None, outfile, label=label, graft=graft)
  File "/usr/lib/python2.7/site-packages/pylorax/imgutils.py", line 292, in mkhfsimg
    mkfsargs=["-v", label], graft=graft)
  File "/usr/lib/python2.7/site-packages/pylorax/imgutils.py", line 272, in mkfsimage
    with Mount(loopdev, mountargs) as mnt:
  File "/usr/lib/python2.7/site-packages/pylorax/imgutils.py", line 190, in __enter__
    self.mnt = mount(self.dev, self.opts, self.mnt)
  File "/usr/lib/python2.7/site-packages/pylorax/imgutils.py", line 101, in mount
    check_call(mount + [dev, mnt])
  File "/usr/lib64/python2.7/subprocess.py", line 511, in check_call
    raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command '['mount', '/dev/loop0', '/tmp/lorax.imgutils.rhw2c2']' returned non-zero exit status 32
template command error in x86.tmpl:
  runcmd mkefiboot --label=ANACONDA --apple --icon=/tmp/treebuild.20120228/output/work/x86_64/installroot/usr/share/pixmaps/bootloader/fedora.icns /tmp/treebuild.20120228/output/17/x86_64/os/EFI/BOOT /tmp/treebuild.20120228/output/17/x86_64/os/images/macboot.img
  NameError: global name 'CalledProcessError' is not defined
Traceback (most recent call last):
  File "/usr/bin/pungi", line 226, in <module>
    main()
  File "/usr/bin/pungi", line 126, in main
    mypungi.doBuildinstall()
  File "/usr/lib/python2.7/site-packages/pypungi/__init__.py", line 849, in doBuildinstall
    workdir=workdir, outputdir=outputdir)
  File "/usr/lib/python2.7/site-packages/pylorax/__init__.py", line 241, in run
    treebuilder.build()
  File "/usr/lib/python2.7/site-packages/pylorax/treebuilder.py", line 196, in build
    self._runner.run(templatefile, kernels=self.kernels)
  File "/usr/lib/python2.7/site-packages/pylorax/ltmpl.py", line 135, in run
    self._run(commands)
  File "/usr/lib/python2.7/site-packages/pylorax/ltmpl.py", line 154, in _run
    f(*args)
  File "/usr/lib/python2.7/site-packages/pylorax/ltmpl.py", line 377, in runcmd
    except CalledProcessError as e:
NameError: global name 'CalledProcessError' is not defined

This could be a pungi bug as well, but looks like it's failing in pylorax. 

Happy to provide more info...

Note You need to log in before you can comment on or make changes to this bug.