Bug 798519 - There is useless "i686" displayed in "Platforms" field
There is useless "i686" displayed in "Platforms" field
Status: CLOSED CURRENTRELEASE
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Hardware Catalog (Show other bugs)
1.4
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Wei Shen
:
Depends On:
Blocks: 807440
  Show dependency treegraph
 
Reported: 2012-02-29 01:54 EST by Wei Shen
Modified: 2014-06-22 21:33 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-19 22:15:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the patch with more comments (2.49 KB, patch)
2012-03-29 22:36 EDT, Wei Shen
wshen: review? (rlandry)
Details | Diff

  None (edit)
Description Wei Shen 2012-02-29 01:54:05 EST
Description of problem:
Please see this cert
https://hardware.redhat.com/show.cgi?id=723425,
Certification Summary section, the platforms show i686 which is not supposed to be there.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Wei Shen 2012-02-29 01:55:54 EST
This is caused by the i686 arch showed in results.xml, we should map this to i386 in Bug.pm
Comment 8 Rob Landry 2012-03-14 17:08:40 EDT
WFM, but comment doesn't explain why it needs to be i386 only that it does.  Can the comment be expanded upon?
Comment 9 Wei Shen 2012-03-14 22:37:33 EDT
Sure, I will put more comments. It is because i386 is used by rpm results and i686 is used by gz results, some certs have both rpm and gz results, then the certs will show i386 and i686 together. However, i386 is enough, need not show i686.
Comment 10 Rob Landry 2012-03-29 13:00:24 EDT
Is there an updated patch with this clarification available?
Comment 11 Wei Shen 2012-03-29 22:36:15 EDT
Created attachment 573865 [details]
the patch with more comments
Comment 12 Wei Shen 2012-03-31 01:36:26 EDT
verified on web2
Comment 13 Wei Shen 2012-04-10 22:48:13 EDT
verified on partner https://partner-hwcert.redhat.com/show.cgi?id=777147

Note You need to log in before you can comment on or make changes to this bug.