Bug 798531 - Failed to build Test-TCP-1.15 while deploying perl dancer
Failed to build Test-TCP-1.15 while deploying perl dancer
Status: CLOSED DUPLICATE of bug 787540
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Troy Dawson
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-29 03:00 EST by jizhao
Modified: 2015-05-14 18:52 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-29 10:24:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jizhao 2012-02-29 03:00:49 EST
Description of problem:
Building Test-TCP-1.15 failed while deploying perl dancer app.

Version-Release number of selected component (if applicable):
rhc-cartridge-perl-5.10-0.18.4-1.el6_2.noarch

How reproducible:
Always

Steps to Reproduce:
https://www.redhat.com/openshift/community/kb/kb-e1014-how-to-deploy-the-perl-dancer-framework-on-openshift-express


Actual results:
<------------output----------->
remote: Building and testing Test-TCP-1.15 ... fatal: The remote end hung up unexpectedly
error: error in sideband demultiplexer
To ssh://9164bffb1b2c43c79912be2a48549d2d@dancer-jizhao.dev.rhcloud.com/~/git/dancer.git/
   db49804..a19c5c7  master -> master
error: failed to push some refs to 'ssh://9164bffb1b2c43c79912be2a48549d2d@dancer-jizhao.dev.rhcloud.com/~/git/dancer.git/'
<----------------------------->

Expected results:
Test-TCP-1.15 should be built successfully.

Additional info:
Comment 1 Troy Dawson 2012-02-29 10:03:11 EST
This is a known problem and will be fixed with the next OpenShift update on March 5 or 6.  Until that time, you need to install your cpan packages, but without the tests.  Once they are installed for your app, you shouldn't have any more problems.
Comment 2 Troy Dawson 2012-02-29 10:21:16 EST
The following is a work around until the new openshift is released.
1 - ssh into your dancer application
  
  rhc-domain-info
(in the dancer application section, find the Git URL section.  You will need everything between ssh:// and the next /.  That is your user ID and the machine you are logging into)
  ssh <UserID>@<app>-<domain>.rhcloud.com

(Example)
  ssh c56ef7ae91dcs52n9cf6224001e144be@dancer-mydomain.rhcloud.com

2 - Install the dancer perl modules by hand, without the tests
(This assumes that you followed the dancer instructions exactly and your application is really called dancer)

  cpanm -n -L ~/dancer/perl5lib Test::Base
  cpanm -n -L ~/dancer/perl5lib YAML
  cpanm -n -L ~/dancer/perl5lib Dancer
  cpanm -n -L ~/dancer/perl5lib Plack::Handler::Apache2

3 - Log out

  exit

4 - Repush your dancer application
  echo "installed perl modules by hand" >> README
  git commit -m "updated README" README
  git push

Everything should work then.
Comment 3 Troy Dawson 2012-02-29 10:24:34 EST

*** This bug has been marked as a duplicate of bug 787540 ***

Note You need to log in before you can comment on or make changes to this bug.