Bug 798546 - [glusterfs-3.3.0qa24]: create set command for md-cache & remove stat-prefetch set
[glusterfs-3.3.0qa24]: create set command for md-cache & remove stat-prefetch...
Status: CLOSED WONTFIX
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
3.7.5
All All
medium Severity medium
: ---
: ---
Assigned To: Raghavendra G
: Reopened, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-29 03:48 EST by Rahul C S
Modified: 2016-01-13 01:23 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-13 01:23:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rahul C S 2012-02-29 03:48:27 EST
Description of problem:
There is no md-cache set option, I know stat-prefetch set does the same thing, but since stat-prefetch is not present now, we need to make a md-cache set/unset command.

gluster volume set md-cache on/off
Comment 2 Amar Tumballi 2012-12-21 00:48:14 EST
still a valid bug, but we need to keep backward compatibility, hence need to keep stat-prefetch, and add md-cache. Need to see how to achieve this.
Comment 3 Kaleb KEITHLEY 2015-10-22 11:40:20 EDT
pre-release version is ambiguous and about to be removed as a choice.

If you believe this is still a bug, please change the status back to NEW and choose the appropriate, applicable version for it.
Comment 4 Sachidananda Urs 2015-12-14 05:27:54 EST
This is still a bug. Since we always refer the feature as md-cache and not stat-prefetch ...

gluster vol set volname md-cache on/off 

Is the intuitive command.
Comment 5 Atin Mukherjee 2016-01-12 23:36:00 EST
This has been already fixed and md-cache option is available now.
Comment 6 Atin Mukherjee 2016-01-13 01:19:52 EST
I misread the code. md-cache option is still not introduced. Reopening the bug. Also assigning it to Raghavendra G as he is the maintainer of performance translators.
Comment 7 Atin Mukherjee 2016-01-13 01:23:43 EST
With the current infrastructure of managing op-versions, this would be difficult to fix considering the backward compatibility. Until and unless we have some design changes of managing the VME table this is not a easy fix. I'd consider not to fix this issue at this stage since GlusterD 2.0 is going to ease out in maintaining the op-versions & backward compatibility.

Note You need to log in before you can comment on or make changes to this bug.