Bug 798548 - environment param is not passed when image import fails
environment param is not passed when image import fails
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity medium
: beta4
: ---
Assigned To: Jan Provaznik
pushpesh sharma
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-29 03:52 EST by Jan Provaznik
Modified: 2014-08-04 18:30 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-15 18:47:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
verified_screenshot (157.80 KB, image/png)
2012-04-17 03:29 EDT, pushpesh sharma
no flags Details

  None (edit)
Description Jan Provaznik 2012-02-29 03:52:53 EST
1. go to image import page
2. fill in some name and image id which doesn't exist
3. press "continue"

a user is redirected to images index page with flash message "The record you tried to access does not exist, it may have been deleted"

expected:
a user is redirected back to image import page with message " The requested image was not found on the provider."

(Environment param should be passed as a param to redirect_to in rescue block of import method.)
Comment 1 Scott Seago 2012-02-29 13:50:30 EST
This has been fixed already -- I can't recall the bz number though, but it's in beta3. Can you re-confirm this with aeolus-image-rubygem and conductor on master?
Comment 2 Jan Provaznik 2012-03-02 12:55:27 EST
Yes, bug is still present, a patch sent: https://fedorahosted.org/pipermail/aeolus-devel/2012-March/009362.html
Comment 3 Jan Provaznik 2012-03-06 10:26:01 EST
pushed, commit d3eda5e7ecc24eba75115724a357ee9a6cb5fffa
Comment 5 pushpesh sharma 2012-04-17 03:28:44 EDT
Marking this as verified.while attempting to import a non-existent ami no from ec2 account fails and displays a proper error message. PFA for detailed screenshot.    


[root@dhcp201-169 ~]# rpm -qa|grep aeolus
aeolus-configure-2.5.2-1.el6.noarch
aeolus-conductor-0.8.7-1.el6.noarch
rubygem-aeolus-cli-0.3.1-1.el6.noarch
aeolus-conductor-doc-0.8.7-1.el6.noarch
aeolus-all-0.8.7-1.el6.noarch
aeolus-conductor-daemons-0.8.7-1.el6.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
Comment 6 pushpesh sharma 2012-04-17 03:29:34 EDT
Created attachment 577927 [details]
verified_screenshot
Comment 7 errata-xmlrpc 2012-05-15 18:47:53 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0583.html

Note You need to log in before you can comment on or make changes to this bug.