Bug 798549 - French :Connection Refused : when given an unreachable url while making blueprint
French :Connection Refused : when given an unreachable url while making bluep...
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity high
: beta6
: ---
Assigned To: Tzu-Mainn Chen
Rehana
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-29 03:56 EST by Shveta
Modified: 2012-05-15 18:47 EDT (History)
7 users (show)

See Also:
Fixed In Version: v0.8.2-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-15 18:47:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
unreachable_url_french (220.08 KB, image/png)
2012-02-29 03:56 EST, Shveta
no flags Details
connection (178.20 KB, image/png)
2012-02-29 03:57 EST, Shveta
no flags Details
Unreachable URL en Francais (311.12 KB, image/png)
2012-03-02 08:20 EST, Angus Thomas
no flags Details
Connection refused (177.85 KB, image/png)
2012-03-05 02:16 EST, Shveta
no flags Details
unreachable_host (178.00 KB, image/png)
2012-03-16 07:56 EDT, Shveta
no flags Details
ss1 (215.39 KB, image/png)
2012-04-03 06:53 EDT, Rehana
no flags Details

  None (edit)
Description Shveta 2012-02-29 03:56:03 EST
Created attachment 566491 [details]
unreachable_url_french

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Enabled french in browser
2. Administer -- content --Default catalog -- create new BP
3. From URL , provide an unreachable url 
  
Actual results:


Expected results:


Additional info:

rpm -qa|grep aeolus
aeolus-conductor-0.8.0-38.el6.noarch
aeolus-all-0.8.0-38.el6.noarch
aeolus-conductor-daemons-0.8.0-38.el6.noarch
aeolus-configure-2.5.0-15.el6.noarch
rubygem-aeolus-image-0.3.0-10.el6.noarch
rubygem-aeolus-cli-0.3.0-11.el6.noarch
aeolus-conductor-doc-0.8.0-38.el6.noarch
Comment 1 Shveta 2012-02-29 03:57:04 EST
Created attachment 566493 [details]
connection
Comment 2 Angus Thomas 2012-03-02 08:20:58 EST
Created attachment 567061 [details]
Unreachable URL en Francais
Comment 3 Angus Thomas 2012-03-02 08:21:59 EST
Works for me in aeolus-conductor-0.8.0-39.el6, using the steps described above to attempt to reproduce.
Comment 4 Shveta 2012-03-05 02:16:29 EST
Created attachment 567492 [details]
Connection refused

I still see the bug ..

rpm -qa|grep aeolus
aeolus-conductor-daemons-0.8.0-40.el6.noarch
aeolus-configure-2.5.0-17.el6.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-conductor-0.8.0-40.el6.noarch
rubygem-aeolus-cli-0.3.0-12.el6.noarch
aeolus-all-0.8.0-40.el6.noarch
aeolus-conductor-doc-0.8.0-40.el6.noarch
Comment 6 Hugh Brock 2012-03-07 13:26:24 EST
Moving this to beta 5 since it's a translation issue and we haven't had time to get through them all yet.
Comment 7 Tzu-Mainn Chen 2012-03-12 23:53:31 EDT
The reported error actually happens when iwhd or imagefactory is down.  I've created a patch:

https://fedorahosted.org/pipermail/aeolus-devel/2012-March/009539.html
Comment 8 Tzu-Mainn Chen 2012-03-13 11:14:15 EDT
Pushed to master:

commit 0233b56d91c876bbe1fa0fa2d0b340c4902b7de1
BZ 798549 removed humanize_error, added in 'require util/conductor'

commit 2bc2100e11a7f696aeb9461c1ba810639605c647
BZ 798549 added exception handling and humanize_error to catch connection refused errors

commit 813182924df12064995b62c039d01d0fca9590d2
BZ 798549 added humanize_error
Comment 10 Shveta 2012-03-16 07:55:50 EDT
Issue is still there in the latest puddle 
http://download.lab.bos.redhat.com/rel-eng/CloudForms/1.0/latest/el6-ce/

Please ping on IRC so that i can help reproduce this issue...


rpm -qa|grep aeolus
rubygem-aeolus-image-0.3.0-12.el6.noarch
rubygem-aeolus-cli-0.3.0-14.el6.noarch
aeolus-conductor-doc-0.8.0-43.el6.noarch
aeolus-conductor-0.8.0-43.el6.noarch
aeolus-configure-2.5.0-18.el6.noarch
aeolus-conductor-daemons-0.8.0-43.el6.noarch
aeolus-all-0.8.0-43.el6.noarch


==================================================

aeolus-check-services 

Checking mongod ...
 Success: mongod (pid 7523) is running...

Checking iwhd ...
 Success: iwhd (pid  7557) is running...

Checking postgresql ...
 Success: postmaster (pid  7359) is running...

Checking httpd ...
 Success: httpd (pid  6966) is running...

Checking qpidd ...
 Success: qpidd (pid  7592) is running...

Checking deltacloud-core ...
 Success: deltacloud-core (pid  7717) is running...

Checking libvirtd ...
 Success: libvirtd (pid  7030) is running...

Checking aeolus-conductor ...
 Success: thin (pid  7472) is running...

Checking conductor-dbomatic ...
 Success: dbomatic (pid  7416) is running...

Checking imagefactory ...
 Success: imagefactory (pid  7655) is running...

Checking ntpd ...
 Success: ntpd (pid  7148) is running...
Comment 11 Shveta 2012-03-16 07:56:25 EDT
Created attachment 570589 [details]
unreachable_host
Comment 12 Hugh Brock 2012-03-16 09:47:04 EDT
Moving this one to beta 6. QE is not consuming beta 5 anyway so there's no point in blocking it on this issue.
Comment 13 Tzu-Mainn Chen 2012-03-16 10:23:20 EDT
Ah. thanks for the clarification on how this error was generated; patch created:

https://fedorahosted.org/pipermail/aeolus-devel/2012-March/009602.html
Comment 14 Tzu-Mainn Chen 2012-03-19 15:27:52 EDT
Pushed to master:

commit 94f0d7c283a5dcfd5d110a0906bf33b34e9cfa25
BZ 798549 added additional rescue cases when trying to import xml from url
Comment 16 wes hayutin 2012-03-30 14:57:58 EDT
assigning to rehana
Comment 17 Rehana 2012-04-03 06:52:03 EDT
Now it displays appropriate error message when tried to access a unreachable URL (pfa:ss1.ong)

Verified the bug on:

rpm -qa | grep aeolus
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-conductor-0.8.7-1.el6.noarch
aeolus-conductor-doc-0.8.7-1.el6.noarch
aeolus-conductor-daemons-0.8.7-1.el6.noarch
aeolus-configure-2.5.2-1.el6.noarch
aeolus-all-0.8.7-1.el6.noarch
rubygem-aeolus-cli-0.3.1-1.el6.noarch
Comment 18 Rehana 2012-04-03 06:53:18 EDT
Created attachment 574823 [details]
ss1
Comment 19 errata-xmlrpc 2012-05-15 18:47:56 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0583.html

Note You need to log in before you can comment on or make changes to this bug.