Bug 798652 - Fix regression in default $status value in case of lists/pipelines
Fix regression in default $status value in case of lists/pipelines
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: tcsh (Show other bugs)
6.2
All Linux
urgent Severity high
: rc
: ---
Assigned To: Vojtech Vitek
Branislav Náter
: Regression, ZStream
Depends On: 784510
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-29 08:57 EST by RHEL Product and Program Management
Modified: 2015-03-04 18:57 EST (History)
22 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, the "anyerror" variable could be selected to set the tcsh exit value behavior. However, "anyerror" is a shell variable and therefore was not propagated to subshells, and could not globally affect csh scripts. This update modifies the tcsh exit value behavior to the default behavior of csh: the new "tcsh_posix_status" variable is now available instead of "anyerror" to allow behavior similar to the POSIX standard.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-23 03:59:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 67142 None None None Never

  None (edit)
Description RHEL Product and Program Management 2012-02-29 08:57:21 EST
This bug has been copied from bug #784510 and has been proposed
to be backported to 6.2 z-stream (EUS).
Comment 9 Eliska Slobodova 2012-05-22 11:41:22 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Previously, the "anyerror" variable could be selected to set the tcsh exit value behavior. However, "anyerror" is a shell variable and therefore was not propagated to subshells, and could not globally affect csh scripts. This update modifies the tcsh exit value behavior to the default behavior of csh: the new "tcsh_posix_status" variable is now available instead of "anyerror" to allow behavior similar to the POSIX standard.
Comment 11 errata-xmlrpc 2012-05-23 03:59:59 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0687.html

Note You need to log in before you can comment on or make changes to this bug.