Bug 798660 - How to PXE install RHEL7?
How to PXE install RHEL7?
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda (Show other bugs)
7.0
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-29 09:23 EST by Qixiang Wan
Modified: 2014-05-28 15:24 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-29 10:42:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Boot from PXE without "root=" specified (42.40 KB, text/plain)
2012-02-29 09:25 EST, Qixiang Wan
no flags Details
Boot from PXE with "root=/" specified (45.82 KB, text/plain)
2012-02-29 09:26 EST, Qixiang Wan
no flags Details

  None (edit)
Description Qixiang Wan 2012-02-29 09:23:24 EST
Description of problem:
When trying to install RHEL7 (20120228.n.0) from pxe, it always asking for "root=" argument, or it will fail with fatal error, then drop to dracut shell.

And tried with "root=/" in the parameters, it will fail with nfs mounting error.

"root=" is not required for Fedora16 and RHEL6. Is this expected in RHEL7? What's the correct 'root=' argument should I provide if it's required?

Version-Release number of selected component (if applicable):
http://download.devel.redhat.com/nightly/RHEL-7.0-20120228.n.0/compose/Server/x86_64/os

How reproducible:
100%

Steps to Reproduce:
1. Boot up a guest or host from PXE.
  
Actual results:
Get a fatal error, and drop to dracut shell.

Expected results:
It should boot up to the menu of installation (select language is the first screen).

Additional info:
log will be attached.
Comment 1 Qixiang Wan 2012-02-29 09:25:42 EST
Created attachment 566554 [details]
Boot from PXE without "root=" specified
Comment 2 Qixiang Wan 2012-02-29 09:26:21 EST
Created attachment 566555 [details]
Boot from PXE with "root=/" specified
Comment 3 David Cantrell 2012-02-29 10:42:25 EST
The root= argument needs to point to the location of the install.img file in the tree.  Looking at the latest nightly tree I see:

http://download.devel.redhat.com/nightly/RHEL-7.0-20120229.n.0/compose/Server/x86_64/os/

The install.img file is in images/install.img, so root= should look like:

root=live:http://download.devel.redhat.com/nightly/RHEL-7.0-20120229.n.0/compose/Server/x86_64/os/images/install.img

NOTE:  This is still alpha-quality software.  Much work is underway in Fedora upstream getting this move to dracut for anaconda's loader working properly.  For now, this is what you need to pass as the root= argument.
Comment 4 Qixiang Wan 2012-02-29 21:58:51 EST
(In reply to comment #3)
> The root= argument needs to point to the location of the install.img file in
> the tree.  Looking at the latest nightly tree I see:
> 
> http://download.devel.redhat.com/nightly/RHEL-7.0-20120229.n.0/compose/Server/x86_64/os/
> 
> The install.img file is in images/install.img, so root= should look like:
> 
> root=live:http://download.devel.redhat.com/nightly/RHEL-7.0-20120229.n.0/compose/Server/x86_64/os/images/install.img
> 
> NOTE:  This is still alpha-quality software.  Much work is underway in Fedora
> upstream getting this move to dracut for anaconda's loader working properly. 
> For now, this is what you need to pass as the root= argument.

Hi David,

I didn't find the os/install.img in tree, is it missed when building the tree? Could you help to check this?
Comment 5 Qixiang Wan 2012-02-29 22:09:15 EST
> Hi David,
> 
> I didn't find the os/install.img in tree, is it missed when building the tree?
> Could you help to check this?

typo: should be images/install.img. I can find it in boot.iso, but not available in the tree.
Comment 6 David Cantrell 2012-03-01 08:45:47 EST
My mistake, the location of the install image file on s390x is os/images/install.img.  On x86_64, the location is os/LiveOS/squashfs.img.  So you want something like this:

root=live:http://download.devel.redhat.com/nightly/RHEL-7.0-20120229.n.0/compose/Server/x86_64/os/LiveOS/squashfs.img
Comment 7 Matthew Galgoci 2014-05-28 15:24:06 EDT
*** Bug 1100464 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.