Bug 798693 - No way to exit installer
No way to exit installer
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-29 10:36 EST by Kamil Páral
Modified: 2012-02-29 15:24 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-29 15:24:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda allows exit only after disk changes are written (69.31 KB, image/png)
2012-02-29 12:09 EST, Kamil Páral
no flags Details

  None (edit)
Description Kamil Páral 2012-02-29 10:36:04 EST
Description of problem:
After booting anaconda from DVD and going through a few dialog (language selection, location, password), I decided I don't want to install anything. I clicked "Back" up to the first screen, but I have found no "Exit installer" button anywhere. There is simply no way to exit installer.

Make it possible to exit anaconda if installation hasn't yet started. Some people may want to use it, really.

Version-Release number of selected component (if applicable):
anaconda 17.11
Comment 1 Kamil Páral 2012-02-29 12:09:06 EST
Quite interestingly, anaconda allows user to exit installation after disk changes have been executed (e.g. all the hard drive could have been wiped out). See exit.png.

I would expect opposite behavior. Until any destructive changes have been performed, it should be easy to quit the installer. After that, it should be hard (warnings displayed) or impossible (I wouldn't like that but could understand that).

CCing Mairin, since this could also affect the new anaconda UI. I have found a mockup where Quit button is present [1], but still CCing just to make sure this is discussed.

[1] http://blog.linuxgrrl.com/wp-content/uploads/2011/07/01-welcome-screen-welcome.png
Comment 2 Kamil Páral 2012-02-29 12:09:46 EST
Created attachment 566595 [details]
anaconda allows exit only after disk changes are written
Comment 3 Chris Lumens 2012-02-29 15:24:04 EST
The new ui will have a prominently placed quit button, so I'm not going to do anything with this bug for F17.  Besides, you can always just reboot.

Note You need to log in before you can comment on or make changes to this bug.