Bug 798744 - SELinux is preventing /usr/sbin/vsftpd from 'search' accesses on the None /home.
SELinux is preventing /usr/sbin/vsftpd from 'search' accesses on the None /home.
Status: CLOSED DUPLICATE of bug 537613
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:445f2a59b79cb4403ae8224d858...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-29 13:06 EST by Ivailo Iliev
Modified: 2012-02-29 14:09 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-29 14:09:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivailo Iliev 2012-02-29 13:06:42 EST
libreport version: 2.0.8
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.2.7-1.fc16.x86_64
reason:         SELinux is preventing /usr/sbin/vsftpd from 'search' accesses on the None /home.
time:           29.02.2012 (ср) 20,06,29 EET

description:
:SELinux is preventing /usr/sbin/vsftpd from 'search' accesses on the None /home.
:
:*****  Plugin file (47.5 confidence) suggests  *******************************
:
:If you think this is caused by a badly mislabeled machine.
:Then you need to fully relabel.
:Do
:touch /.autorelabel; reboot
:
:*****  Plugin file (47.5 confidence) suggests  *******************************
:
:If you think this is caused by a badly mislabeled machine.
:Then you need to fully relabel.
:Do
:touch /.autorelabel; reboot
:
:*****  Plugin catchall (6.38 confidence) suggests  ***************************
:
:If you believe that vsftpd should be allowed search access on the home <Unknown> by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep vsftpd /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:ftpd_t:s0-s0:c0.c1023
:Target Context                system_u:object_r:file_t:s0
:Target Objects                /home [ None ]
:Source                        vsftpd
:Source Path                   /usr/sbin/vsftpd
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           vsftpd-2.3.4-7.fc16.x86_64
:Target RPM Packages           filesystem-2.4.44-1.fc16.x86_64
:Policy RPM                    selinux-policy-3.10.0-75.fc16.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.2.7-1.fc16.x86_64 #1 SMP Tue Feb
:                              21 01:40:47 UTC 2012 x86_64 x86_64
:Alert Count                   4
:First Seen                    29.02.2012 (ср) 19,52,45 EET
:Last Seen                     29.02.2012 (ср) 20,02,46 EET
:Local ID                      c05c7478-22cf-4053-b0f3-e8c541db619e
:
:Raw Audit Messages
:type=AVC msg=audit(1330538566.364:12263): avc:  denied  { search } for  pid=11852 comm="vsftpd" name="/" dev=sdc1 ino=2 scontext=system_u:system_r:ftpd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:file_t:s0 tclass=dirnode=(removed) type=SYSCALL msg=audit(1330538566.364:12263): arch=c000003e syscall=80 success=no exit=-13 a0=7f80919628d0 a1=3e8 a2=0 a3=7fffdb5dda70 items=0 ppid=11845 pid=11852 auid=4294967295 uid=0 gid=0 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 tty=(none) ses=4294967295 comm="vsftpd" exe="/usr/sbin/vsftpd" subj=system_u:system_r:ftpd_t:s0-s0:c0.c1023 key=(null)
:
:
:Hash: vsftpd,ftpd_t,file_t,None,search
:
:audit2allow
:
:
:audit2allow -R
:
:
Comment 1 Daniel Walsh 2012-02-29 14:09:13 EST

*** This bug has been marked as a duplicate of bug 537613 ***

Note You need to log in before you can comment on or make changes to this bug.