Bug 798766 - emacs doesn't compile on ARM
Summary: emacs doesn't compile on ARM
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: emacs
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Karel Klíč
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: ARMTracker
TreeView+ depends on / blocked
 
Reported: 2012-02-29 19:46 UTC by Peter Robinson
Modified: 2013-03-03 23:03 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-03-06 13:32:00 UTC


Attachments (Terms of Use)

Description Peter Robinson 2012-02-29 19:46:33 UTC
Emacs 24 doesn't compile on ARM platforms. v23 use to.

http://arm.koji.fedoraproject.org/koji/buildinfo?buildID=56660

The error is:
Wrong type argument: listp, 2945660

Comment 1 Dan Horák 2012-03-02 18:51:52 UTC
Peter, can you try to build the latest source from http://git.savannah.gnu.org/gitweb/?p=emacs.git;a=summary ? Also please create an upstream bug report, they acted very promptly on my issue on s390.

Comment 2 Peter Robinson 2012-03-06 13:32:00 UTC
The latest snapshot in rawhide now builds


Note You need to log in before you can comment on or make changes to this bug.