Bug 798823 - f17 alpha anaconda kernel won't boot from hard disk install
f17 alpha anaconda kernel won't boot from hard disk install
Status: CLOSED DUPLICATE of bug 785815
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-29 20:23 EST by Tom Horsley
Modified: 2012-02-29 21:13 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-29 21:13:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
picture of screen after installer kernel froze up (261.91 KB, image/jpeg)
2012-02-29 20:24 EST, Tom Horsley
no flags Details

  None (edit)
Description Tom Horsley 2012-02-29 20:23:07 EST
Description of problem:

Just tried to install x86_64 Fedora 17 Alpha from the downloaded DVD iso.
I did my normal hard disk install procedure, copying vmlinuz and initrd.img
to my /mainboot partition where I have a stand alone grub1 setup. I put the
files in the f17 subdir and made this grub.conf entry:

title Install Fedora 17 Alpha
	root (hd0,0)
	kernel /f17/vmlinuz repo=hd:LABEL=ZOOTY:/downloads/otherinbox/Fedora-17-Alpha-x86_64-DVD/
	initrd /f17/initrd.img

When I boot that grub entry, it spews messages for a while then freezes
with an error:

dracut: FATAL: No or empty root= argument


Version-Release number of selected component (if applicable):
Whatever is on the DVD.

How reproducible:
every time

Steps to Reproduce:
1.see above
2.
3.
  
Actual results:
installer can't boot

Expected results:
get into anaconda screen

Additional info:

I'll attach a photo I took of screen after the freeze.

The smolt profile of this machine is at:

http://www.smolts.org/client/show/pub_acf19b21-e2de-403e-89b8-dff38b54302e

My /dev/sda disk is an SSD drive if that matters.

I installed fedora 16 this way with no problems on the same hardware.
Comment 1 Tom Horsley 2012-02-29 20:24:07 EST
Created attachment 566689 [details]
picture of screen after installer kernel froze up
Comment 2 Tom Horsley 2012-02-29 20:49:16 EST
I went ahead and wrote a DVD from the image, and I can boot into anaconda
from a real DVD (with "normal" or UEFI booting). So I'm guessing the problem
isn't hardware.
Comment 3 David Lehman 2012-02-29 21:13:44 EST

*** This bug has been marked as a duplicate of bug 785815 ***

Note You need to log in before you can comment on or make changes to this bug.