Bug 798842 - Remove the Content Specification Server
Remove the Content Specification Server
Status: CLOSED CURRENTRELEASE
Product: PressGang CCMS
Classification: Community
Component: CSProcessor (Show other bugs)
1.x
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lee Newson
:
Depends On:
Blocks: 799821
  Show dependency treegraph
 
Reported: 2012-02-29 22:55 EST by Lee Newson
Modified: 2012-08-20 23:55 EDT (History)
2 users (show)

See Also:
Fixed In Version: 0.22.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-30 00:53:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lee Newson 2012-02-29 22:55:23 EST
Now that the Content Specification Server has no purpose the program can be moved to a client only based application. The reason it has no purpose is that it was originally created as a Web Service because it had to maintain a database and sensitive connection information to Skynet. This however is no longer the case.

The other reason was to help limit data access to the Skynet database when it had direct access. Now it accesses that data via a REST Interface so the controlling should be done within Skynet.

This requires creating builder and processor portable JAR files to include with the client to give it the functionality that the server had. Doing this will also help with Bugs #788328 and #771803.

This change will also affect the users as they will have to change their configuration files, so an automated function with in the client to do this would be best.
Comment 1 Lee Newson 2012-03-05 01:52:26 EST
Done in 0.22.0.

The Server now has no use and will be closed eventually.

There are now three portable JAR files that contain the functionality that was included in the server. They are csprocessor, csbuilder and cscommons. This has also been incorporated into the new client(0.22.0) see Bug #796009. 

Due to the mass amount of changes to the client, none of the old configuration files are relevant so no script will be used to fix the configuration file. Instead a new configuration file will be included in the release and instructions setup on the docspace page on how to setup and use the new client.

Note You need to log in before you can comment on or make changes to this bug.