Bug 798844 - alsa bug causes audio to skip with usb soundcard.
alsa bug causes audio to skip with usb soundcard.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-29 23:18 EST by John Roman
Modified: 2013-08-16 09:21 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-24 09:19:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
full lsusb of the device. (9.71 KB, text/plain)
2012-02-29 23:18 EST, John Roman
no flags Details
Alsa Info (61.77 KB, text/plain)
2013-04-21 02:52 EDT, Nabeel Moidu
no flags Details

  None (edit)
Description John Roman 2012-02-29 23:18:50 EST
Created attachment 566729 [details]
full lsusb of the device.

Description of problem:
audio skips occasionally in alsa with the following error:
[ 6522.516499] ALSA sound/usb/endpoint.c:203 cannot submit sync urb (err = -27)


Versioalsa-utils-1.0.25-7.fc16.x86_64
alsa-lib-1.0.25-1.fc16.x86_64
alsa-tools-firmware-1.0.25-1.fc16.x86_64
alsa-firmware-1.0.25-1.fc16.noarch
n-Release number of selected component (if applicable):


How reproducible:
playing directly to alsa this problem happens approximately every 2-7 minutes.  playing through pulseaudio, this alsa bug is bad enough to cause pulseaudio to crash.

Steps to Reproduce:
1. load up rhythmbox, amarok, or any alsa-aware app
2. play some music, something classy :)
3. dmesg will show the error at the exact time of the skip!
  
Actual results:
[ 6402.586232] ALSA sound/usb/endpoint.c:769 delay: estimated 313, actual 46
[ 6402.586250] ALSA sound/usb/endpoint.c:203 cannot submit sync urb (err = -27)
[ 6522.516416] ALSA sound/usb/endpoint.c:769 delay: estimated 308, actual 132
[ 6522.516435] ALSA sound/usb/endpoint.c:769 delay: estimated 308, actual 44
[ 6522.516450] ALSA sound/usb/endpoint.c:769 delay: estimated 308, actual 132
[ 6522.516466] ALSA sound/usb/endpoint.c:769 delay: estimated 308, actual 44
[ 6522.516479] ALSA sound/usb/endpoint.c:769 delay: estimated 308, actual 132
[ 6522.516499] ALSA sound/usb/endpoint.c:203 cannot submit sync urb (err = -27)


Expected results:
clean smooth audio

Additional info:

usb audio devicein dmesg:
[ 6956.966847] input: www.hirestech.com 2010 REV 1.7 Music Streamer II as /devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.1/1-1.1:1.2/input/input14
[ 6956.967186] generic-usb 0003:4852:0003.0006: input,hidraw0: USB HID v1.00 Device [www.hirestech.com 2010 REV 1.7 Music Streamer II] on usb-0000:00:1a.0-1.1/input2
[ 6956.970766] generic-usb 0003:4852:0003.0007: hiddev0,hidraw1: USB HID v1.00 Device [www.hirestech.com 2010 REV 1.7 Music Streamer II] on usb-0000:00:1a.0-1.1/

the kernel:
Linux virtue 3.2.7-1.fc16.x86_64 #1 SMP Tue Feb 21 01:40:47 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
Comment 1 John Roman 2012-03-09 01:45:23 EST
bus topology


2-1.5:1.0: No such file or directory
/:  Bus 02.Port 1: Dev 1, Class=root_hub, Driver=ehci_hcd/3p, 480M
    |__ Port 1: Dev 2, If 0, Class=hub, Driver=hub/8p, 480M
        |__ Port 1: Dev 19, If 0, Class=audio, Driver=snd-usb-audio, 12M
        |__ Port 1: Dev 19, If 1, Class=audio, Driver=snd-usb-audio, 12M
        |__ Port 1: Dev 19, If 2, Class=HID, Driver=usbhid, 12M
        |__ Port 1: Dev 19, If 3, Class=HID, Driver=usbhid, 12M
        |__ Port 2: Dev 13, If 0, Class=HID, Driver=usbhid, 12M
        |__ Port 5: Dev 5, If 0, Class=vend., Driver=, 12M
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=ehci_hcd/3p, 480M
    |__ Port 1: Dev 2, If 0, Class=hub, Driver=hub/6p, 480M
        |__ Port 1: Dev 5, If 0, Class=HID, Driver=usbhid, 12M
        |__ Port 1: Dev 5, If 1, Class=HID, Driver=usbhid, 12M


this is a laptop, so the total number of ports appear to be less than the total number of devices intentionally.
Comment 2 s.huchler 2012-06-21 17:23:33 EDT
have the same problem here:



[ 7344.431454] ALSA sound/usb/endpoint.c:769 delay: estimated 134, actual 1
[ 7344.543443] ALSA sound/usb/endpoint.c:769 delay: estimated 90, actual 1
[ 7345.255406] ALSA sound/usb/endpoint.c:769 delay: estimated 133, actual 1
[ 7345.383383] ALSA sound/usb/endpoint.c:769 delay: estimated 134, actual 1
[ 7346.095394] ALSA sound/usb/endpoint.c:769 delay: estimated 133, actual 1
[ 7347.335901] ALSA sound/usb/endpoint.c:769 delay: estimated 353, actual 1
[ 7347.335967] ALSA sound/usb/endpoint.c:769 delay: estimated 354, actual 1
[ 7347.336028] ALSA sound/usb/endpoint.c:769 delay: estimated 354, actual 1
[ 7347.336090] ALSA sound/usb/endpoint.c:769 delay: estimated 353, actual 0
[ 7347.336149] ALSA sound/usb/endpoint.c:769 delay: estimated 353, actual 0
[ 7347.336208] ALSA sound/usb/endpoint.c:769 delay: estimated 353, actual 1
[ 7347.336267] ALSA sound/usb/endpoint.c:769 delay: estimated 310, actual 1
[ 7347.336326] ALSA sound/usb/endpoint.c:769 delay: estimated 354, actual 1
[ 7347.336385] ALSA sound/usb/endpoint.c:769 delay: estimated 353, actual 0
[ 7347.336444] ALSA sound/usb/endpoint.c:769 delay: estimated 353, actual 0
[ 7347.336502] ALSA sound/usb/endpoint.c:769 delay: estimated 353, actual 1
[ 7347.336537] ALSA sound/usb/endpoint.c:769 delay: estimated 354, actual 1
[ 7347.336537] ALSA sound/usb/endpoint.c:769 delay: estimated 354, actual 1
[ 7347.336537] ALSA sound/usb/endpoint.c:769 delay: estimated 353, actual 0
[ 7347.336537] ALSA sound/usb/endpoint.c:769 delay: estimated 353, actual 0
[ 7347.336537] ALSA sound/usb/endpoint.c:769 delay: estimated 353, actual 1
[ 7347.336537] ALSA sound/usb/endpoint.c:769 delay: estimated 354, actual 1
[ 7347.336537] ALSA sound/usb/endpoint.c:769 delay: estimated 354, actual 1
[ 7347.336537] ALSA sound/usb/endpoint.c:769 delay: estimated 353, actual 0
[ 7347.336537] ALSA sound/usb/endpoint.c:769 delay: estimated 353, actual 0
[ 7347.336537] ALSA sound/usb/endpoint.c:769 delay: estimated 353, actual 1
[ 7347.336537] ALSA sound/usb/endpoint.c:769 delay: estimated 354, actual 1
[ 7347.336537] ALSA sound/usb/endpoint.c:769 delay: estimated 354, actual 1
[ 7347.336537] ALSA sound/usb/endpoint.c:769 delay: estimated 309, actual 0
[ 7347.336537] ALSA sound/usb/endpoint.c:769 delay: estimated 353, actual 0
[ 7347.336537] ALSA sound/usb/endpoint.c:769 delay: estimated 353, actual 1
[ 7347.336537] ALSA sound/usb/endpoint.c:769 delay: estimated 354, actual 1
[ 7347.336537] ALSA sound/usb/endpoint.c:769 delay: estimated 354, actual 1
[ 7347.336537] ALSA sound/usb/endpoint.c:769 delay: estimated 353, actual 0
[ 7347.336537] ALSA sound/usb/endpoint.c:769 delay: estimated 353, actual 0
[ 7347.336537] ALSA sound/usb/endpoint.c:769 delay: estimated 353, actual 1
[ 7347.336537] ALSA sound/usb/endpoint.c:769 delay: estimated 354, actual 1
[ 7347.336537] ALSA sound/usb/endpoint.c:769 delay: estimated 354, actual 1
[ 7347.336537] ALSA sound/usb/endpoint.c:769 delay: estimated 353, actual 0
[ 7347.336537] ALSA sound/usb/endpoint.c:769 delay: estimated 353, actual 0
[ 7347.336537] ALSA sound/usb/endpoint.c:769 delay: estimated 353, actual 1
[ 7347.336537] ALSA sound/usb/endpoint.c:180 cannot submit urb (err = -27)



have here newest fedora 17, standard kernel and all standard...


Bus 001 Device 007: ID 08bb:2902 Texas Instruments Japan PCM2902 Audio Codec

its a behringer u-control UCA202

works under windows 7 and under ubuntu 12.04.


*********:~$ uname -r
3.3.4-5.fc17.x86_64

its a lenovo thinkpad


between the hub and the notebook there is a usb-switch but I dont think thats the problem...

ask if you want more infos ^^
Comment 3 Adam Williamson 2012-10-18 13:59:47 EDT
kernel devs, anything you can do here? There's a vague suggestion in http://phoronix.com/forums/showthread.php?74475-Fedora-18-Is-Now-One-Month-Behind-Schedule&p=291735#post291735 that it may be fixed upstream, if I'm reading the post correctly.
Comment 4 s.huchler 2012-10-18 18:25:43 EDT
thanx for reassinging that to a better point, that was basicly my biggest point to get support for that. if that happens I will become maybe a happy fedora user and dont kind-of-flame about fedora again ;)

But you read my post wrong, maybe it was my english, but I did refer to the ubuntu bug you postet and that was about a other soundproblem. that seems to be fixed upstream.

So I did not make a statement about upstream of this bug there.
Comment 5 Adam Williamson 2012-10-22 19:22:53 EDT
ah, okay. well, the kernel guys will take a look, but like I said in the forum thread, if there isn't a fix already available to apply, they might not be able to do much, and your best chance is actually to report this to the ALSA project itself. The alsa-devel mailing list, I've found, is the best place to report problems and get fixes:

http://mailman.alsa-project.org/mailman/listinfo/alsa-devel

they might ask you to provide further debugging information - sometimes you have to download special tools and run commands and things - but if you provide them with the info they'll usually be able to fix the bug. It's very useful to give them precise information on when the breakage occurred, if you can - e.g. 'it works in kernel 3.4.6 but not 3.4.7'. that helps a lot.

ALSA does have a bug tracker, allegedly, at https://bugtrack.alsa-project.org/alsa-bug/ ...

but as I write this it seems to be down, and even when it's up, I've found bugs reported there don't get much attention, and the mailing list seems like a better choice.
Comment 6 s.huchler 2012-10-23 07:01:18 EDT
I tested it in fedora 18 with newest kernel and it seems to be fixed there, so its no problem for me anymore.
Comment 7 Dave Jones 2012-10-23 11:25:22 EDT
# Mass update to all open bugs.

Kernel 3.6.2-1.fc16 has just been pushed to updates.
This update is a significant rebase from the previous version.

Please retest with this kernel, and let us know if your problem has been fixed.

In the event that you have upgraded to a newer release and the bug you reported
is still present, please change the version field to the newest release you have
encountered the issue with.  Before doing so, please ensure you are testing the
latest kernel update in that release and attach any new and relevant information
you may have gathered.

If you are not the original bug reporter and you still experience this bug,
please file a new report, as it is possible that you may be seeing a
different problem. 
(Please don't clone this bug, a fresh bug referencing this bug in the comment is sufficient).
Comment 8 Adam Williamson 2012-10-23 18:50:43 EDT
As per Dave's comment, in fact I believe 16, 17 and 18 are now on the same kernel version, 3.6.2 (there are small differences in the build between Fedora releases, but it'll be pretty similar)...so if it's working in F18 there's a decent chance it'll be working in F16 now as well, if you update to 3.6.2. If you could check that so we can close the bug if it is working, that'd be great. Thanks!
Comment 9 s.huchler 2012-10-23 19:14:50 EDT
I did test 3.6.2 kernel so I think its fixed then...
Comment 10 Josh Boyer 2012-10-24 09:19:23 EDT
Thanks for letting us know.
Comment 11 Nabeel Moidu 2013-04-21 02:52:52 EDT
Created attachment 738202 [details]
Alsa Info

alsa-info output
Comment 12 Nabeel Moidu 2013-04-21 02:53:23 EDT
I hit this again on F18. My audio plays on my USB Microsoft headset for some time, and then drops. If I go to the sound settings, change my device for sound output and then change it back to USB, it works again.

[root@nmoidu-laptop ~]# date
Sun Apr 21 12:08:50 IST 2013
[root@nmoidu-laptop ~]# tailf /var/log/messages
Apr 21 12:08:36 nmoidu-laptop dbus-daemon[617]: dbus[617]: [system] Successfully activated service 'net.reactivated.Fprint'
Apr 21 12:08:36 nmoidu-laptop dbus[617]: [system] Successfully activated service 'net.reactivated.Fprint'
Apr 21 12:08:36 nmoidu-laptop dbus-daemon[617]: Launching FprintObject
Apr 21 12:08:36 nmoidu-laptop dbus-daemon[617]: ** Message: D-Bus service launched with name: net.reactivated.Fprint
Apr 21 12:08:36 nmoidu-laptop dbus-daemon[617]: ** Message: entering main loop
Apr 21 12:08:36 nmoidu-laptop dbus-daemon[617]: ** Message: user 'root' claiming the device: 0
Apr 21 12:08:36 nmoidu-laptop dbus-daemon[617]: ** Message: now monitoring fd 10
Apr 21 12:08:36 nmoidu-laptop dbus-daemon[617]: ** Message: device 0 claim status 0
Apr 21 12:08:36 nmoidu-laptop dbus-daemon[617]: ** Message: no longer monitoring fd 10
Apr 21 12:08:36 nmoidu-laptop dbus-daemon[617]: ** Message: released device 0



Apr 21 12:08:57 nmoidu-laptop rtkit-daemon[609]: Warning: Reached burst limit for user '1000', denying request.
Apr 21 12:08:57 nmoidu-laptop rtkit-daemon[609]: Warning: Reached burst limit for user '1000', denying request.
Apr 21 12:08:57 nmoidu-laptop rtkit-daemon[609]: Warning: Reached burst limit for user '1000', denying request.
Apr 21 12:08:57 nmoidu-laptop rtkit-daemon[609]: Warning: Reached burst limit for user '1000', denying request.
Apr 21 12:08:57 nmoidu-laptop rtkit-daemon[609]: Warning: Reached burst limit for user '1000', denying request.
Apr 21 12:09:07 nmoidu-laptop dbus-daemon[617]: ** Message: No devices in use, exit
Apr 21 12:09:46 nmoidu-laptop kernel: [ 4674.543180] ALSA sound/usb/endpoint.c:391 cannot submit urb (err = -27)
Apr 21 12:09:46 nmoidu-laptop kernel: [ 4674.543197] ALSA sound/usb/endpoint.c:391 cannot submit urb (err = -27)
Apr 21 12:09:46 nmoidu-laptop kernel: [ 4674.543211] ALSA sound/usb/endpoint.c:391 cannot submit urb (err = -27)
Apr 21 12:10:04 nmoidu-laptop rtkit-daemon[609]: Warning: Reached burst limit for user '1000', denying request.
Apr 21 12:10:04 nmoidu-laptop rtkit-daemon[609]: Warning: Reached burst limit for user '1000', denying request.
Apr 21 12:10:04 nmoidu-laptop rtkit-daemon[609]: Warning: Reached burst limit for user '1000', denying request.
Apr 21 12:10:04 nmoidu-laptop rtkit-daemon[609]: Warning: Reached burst limit for user '1000', denying request.
Apr 21 12:10:04 nmoidu-laptop rtkit-daemon[609]: Warning: Reached burst limit for user '1000', denying request.
Apr 21 12:10:49 nmoidu-laptop kernel: [ 4737.445544] ALSA sound/usb/endpoint.c:391 cannot submit urb (err = -27)
Apr 21 12:10:49 nmoidu-laptop kernel: [ 4737.445568] ALSA sound/usb/endpoint.c:391 cannot submit urb (err = -27)
Apr 21 12:10:49 nmoidu-laptop kernel: [ 4737.445590] ALSA sound/usb/endpoint.c:391 cannot submit urb (err = -27)
^C
[root@nmoidu-laptop ~]# uname -a
Linux nmoidu-laptop.maprtech.com 3.6.10-4.fc18.x86_64 #1 SMP Tue Dec 11 18:01:27 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
[root@nmoidu-laptop ~]# cat /etc/redhat-release 
Fedora release 18 (Spherical Cow)
[root@nmoidu-laptop ~]# lsusb
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 045e:070f Microsoft Corp. 
Bus 001 Device 004: ID 046d:c31c Logitech, Inc. Keyboard K120 for Business
Bus 001 Device 005: ID 147e:2016 Upek Biometric Touchchip/Touchstrip Fingerprint Sensor
Bus 001 Device 006: ID 04f2:b221 Chicony Electronics Co., Ltd integrated camera
Bus 002 Device 006: ID 04e8:6865 Samsung Electronics Co., Ltd GT-I9300 Phone [Galaxy S III] (PTP mode)
[root@nmoidu-laptop ~]# rpm -qa  | grep alsa
alsa-tools-firmware-1.0.26.1-1.fc18.x86_64
alsa-utils-1.0.26-1.fc18.x86_64
alsa-lib-1.0.26-2.fc18.x86_64
alsa-plugins-pulseaudio-1.0.26-2.fc18.x86_64
alsa-lib-1.0.26-2.fc18.i686
alsa-firmware-1.0.25-2.fc18.noarch
[root@nmoidu-laptop ~]# dmesg | tail -n 12
[ 4737.445422] ALSA sound/usb/pcm.c:1187 delay: estimated 480, actual 96
[ 4737.445439] ALSA sound/usb/pcm.c:1187 delay: estimated 480, actual 96
[ 4737.445457] ALSA sound/usb/pcm.c:1187 delay: estimated 480, actual 96
[ 4737.445475] ALSA sound/usb/pcm.c:1187 delay: estimated 480, actual 96
[ 4737.445493] ALSA sound/usb/pcm.c:1187 delay: estimated 480, actual 96
[ 4737.445511] ALSA sound/usb/pcm.c:1187 delay: estimated 480, actual 96
[ 4737.445529] ALSA sound/usb/pcm.c:1187 delay: estimated 480, actual 96
[ 4737.445544] ALSA sound/usb/endpoint.c:391 cannot submit urb (err = -27)
[ 4737.445554] ALSA sound/usb/pcm.c:1187 delay: estimated 480, actual 96
[ 4737.445568] ALSA sound/usb/endpoint.c:391 cannot submit urb (err = -27)
[ 4737.445576] ALSA sound/usb/pcm.c:1187 delay: estimated 480, actual 96
[ 4737.445590] ALSA sound/usb/endpoint.c:391 cannot submit urb (err = -27)
[root@nmoidu-laptop ~]#
Comment 13 john casey 2013-08-14 11:03:36 EDT
I hit this again on the latest F18. Logitech USB camera/mic while using skype.  I happens pretty regularly - hard to tell what causes it but if I use my mouse while in a skype call - this tends to trigger it.   If I go to sound manager and turn the logitech off and back on it resets and works again for a few seconds.

[root@prava-dev2 ~]# date
Wed Aug 14 08:01:44 PDT 2013

[root@prava-dev2 xinetd.d]# tail /var/log/messages
Aug 14 07:38:06 prava-dev2 kernel: [33600.262463] ALSA sound/usb/clock.c:315 current rate 0 is different from the runtime rate 32000
Aug 14 07:38:38 prava-dev2 kernel: [33632.720304] ALSA sound/usb/endpoint.c:391 cannot submit urb (err = -18)
Aug 14 07:38:38 prava-dev2 kernel: [33632.720313] ALSA sound/usb/endpoint.c:391 cannot submit urb (err = -18)
Aug 14 07:38:38 prava-dev2 kernel: [33632.720318] ALSA sound/usb/endpoint.c:391 cannot submit urb (err = -18)
Aug 14 07:38:38 prava-dev2 kernel: [33632.720323] ALSA sound/usb/endpoint.c:391 cannot submit urb (err = -18)
Aug 14 07:38:38 prava-dev2 kernel: [33632.720327] ALSA sound/usb/endpoint.c:391 cannot submit urb (err = -18)
Aug 14 07:38:38 prava-dev2 kernel: [33632.720332] ALSA sound/usb/endpoint.c:391 cannot submit urb (err = -18)
Aug 14 07:38:38 prava-dev2 kernel: [33632.720336] ALSA sound/usb/endpoint.c:391 cannot submit urb (err = -18)
Aug 14 07:38:38 prava-dev2 kernel: [33632.720341] ALSA sound/usb/endpoint.c:391 cannot submit urb (err = -18)

[root@prava-dev2 ~]# uname -a
Linux prava-dev2.home.lan 3.10.4-100.fc18.x86_64 #1 SMP Thu Aug 1 21:13:27 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

[root@prava-dev2 ~]# lsusb
Bus 002 Device 003: ID 0424:2514 Standard Microsystems Corp. USB 2.0 Hub
Bus 006 Device 002: ID 03f0:0117 Hewlett-Packard LaserJet 3200
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 004: ID 046d:0821 Logitech, Inc. HD Webcam C910

[root@prava-dev2 xinetd.d]# rpm -qa | grep alsa
alsa-plugins-pulseaudio-1.0.26-2.fc18.x86_64
alsa-tools-firmware-1.0.26.1-1.fc18.x86_64
alsa-lib-1.0.26-2.fc18.i686
alsa-utils-1.0.26-1.fc18.x86_64
alsa-lib-1.0.26-2.fc18.x86_64
alsa-firmware-1.0.25-2.fc18.noarch
alsa-lib-devel-1.0.26-2.fc18.x86_64

Note You need to log in before you can comment on or make changes to this bug.