Bug 798848 - Page headers overrun page edge in PDFs
Page headers overrun page edge in PDFs
Status: CLOSED CURRENTRELEASE
Product: Publican
Classification: Community
Component: publican (Show other bugs)
3.0
All All
unspecified Severity medium
: 3.0
: ---
Assigned To: Jeff Fearn
Ruediger Landmann
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-29 23:37 EST by Kate Grainger
Modified: 2012-10-30 23:11 EDT (History)
2 users (show)

See Also:
Fixed In Version: 3.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-30 23:11:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Page header overrun (17.84 KB, image/png)
2012-02-29 23:37 EST, Kate Grainger
no flags Details

  None (edit)
Description Kate Grainger 2012-02-29 23:37:39 EST
Created attachment 566738 [details]
Page header overrun

Description of problem:
For sections with very long titles, these titles can overrun the page width when used as page headers. This behaviour only happens in PDFs.

How reproducible:
The limit seems to be around 100 characters.

Steps to Reproduce:
1. Create a section with a very long title and a few pages of content afterwards.
2. Generate a PDF.
3. Observe over-runnage of section title as page header.
4. Weep, gnash teeth.
  
Actual results:
Very long section title overruns page as page header.

Expected results:
Very long section title does not overrun page header, perhaps through use of a forced line break.

Additional info:
See screen shot for example.
Comment 1 Ruediger Landmann 2012-06-18 01:11:15 EDT
Verified on publican-3.0-0.fc17.t180.noarch

Publican 3.0 uses the chapter or appendix title in place of the section title for page headers, which are probably less likely to contain over-long strings. However, when presented with an over-long chapter of appendix title, Publican 3.0 simply doesn't present anything in the page header, which is certainly better than presenting something broken.

Note You need to log in before you can comment on or make changes to this bug.