Bug 798881 - Install-time warnings
Install-time warnings
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sssd (Show other bugs)
6.3
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Stephen Gallagher
IDM QE LIST
:
Depends On: 753763 799045
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-01 02:37 EST by Michal Nowak
Modified: 2013-03-07 21:13 EST (History)
6 users (show)

See Also:
Fixed In Version: sssd-1.8.0-11.el6
Doc Type: Bug Fix
Doc Text:
No technical note required
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 07:55:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Nowak 2012-03-01 02:37:43 EST
Description of problem:

Got following warnings when updating SSSD:

Non-fatal <unknown> scriptlet failure in rpm package sssd
  Cleanup    : sssd-1.8.0-4.el6.beta3.x86_64                                                                                                                                                                                           47/74 
/var/tmp/rpm-tmp.rAIH7G: line 1: fg: no job control
warning: %triggerun(sssd-1.8.0-4.el6.beta3.x86_64) scriptlet failed, exit status 1


Version-Release number of selected component (if applicable):

sssd-client-1.8.0-10.el6.x86_64
sssd-1.8.0-10.el6.x86_64
Comment 2 Jenny Galipeau 2012-03-01 06:29:19 EST
See this in TPS tests too ... and notified sgallagh yesterday

Error|Fail string detected in rpmOutput, although new packages are present. Upgrade test FAILED Output from RPM Command: /var/tmp/rpm-tmp.zOmz54: line 1: fg: no job control warning: %triggerun(sssd-1.5.1-66.el6_2.3.i686) scriptlet failed, exit status 1
Comment 3 Stephen Gallagher 2012-03-01 07:49:44 EST
Yeah, this is a result of an incorrect attempt to resolve BZ #753763. Jenny and I made the decision to back this change out and convert it to a doc bug.
Comment 6 Steeve Goveas 2012-04-05 07:16:56 EDT
[root@wheeljack ~]# rpm -qa | egrep 'libipa|sssd'
libipa_hbac-1.8.0-4.el6.beta3.x86_64
sssd-1.8.0-4.el6.beta3.x86_64
sssd-client-1.8.0-4.el6.beta3.x86_64
[root@wheeljack ~]# yum update sssd
[root@wheeljack ~]# yum update sssd
Loaded plugins: product-id, security, subscription-manager
Updating certificate-based repositories.
Unable to read consumer identity
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package sssd.x86_64 0:1.8.0-4.el6.beta3 will be updated
---> Package sssd.x86_64 0:1.8.0-17.el6 will be an update
--> Processing Dependency: sssd-client(x86-64) = 1.8.0-17.el6 for package: sssd-1.8.0-17.el6.x86_64
--> Processing Dependency: libipa_hbac(x86-64) = 1.8.0-17.el6 for package: sssd-1.8.0-17.el6.x86_64
--> Running transaction check
---> Package libipa_hbac.x86_64 0:1.8.0-4.el6.beta3 will be updated
---> Package libipa_hbac.x86_64 0:1.8.0-17.el6 will be an update
---> Package sssd-client.x86_64 0:1.8.0-4.el6.beta3 will be updated
---> Package sssd-client.x86_64 0:1.8.0-17.el6 will be an update
--> Finished Dependency Resolution

Dependencies Resolved
...
Is this ok [y/N]: y
Downloading Packages:
(1/3): libipa_hbac-1.8.0-17.el6.x86_64.rpm                                                                                            |  60 kB     00:00     
(2/3): sssd-1.8.0-17.el6.x86_64.rpm                                                                                                   | 2.1 MB     00:00     
(3/3): sssd-client-1.8.0-17.el6.x86_64.rpm                                                                                            |  88 kB     00:00     
-------------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                        4.9 MB/s | 2.3 MB     00:00     
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Updating   : libipa_hbac-1.8.0-17.el6.x86_64                                                                                                           1/6 
  Updating   : sssd-client-1.8.0-17.el6.x86_64                                                                                                           2/6 
  Updating   : sssd-1.8.0-17.el6.x86_64                                                                                                                  3/6 
  Cleanup    : sssd-1.8.0-4.el6.beta3.x86_64                                                                                                             4/6 
  Cleanup    : libipa_hbac-1.8.0-4.el6.beta3.x86_64                                                                                                      5/6 
  Cleanup    : sssd-client-1.8.0-4.el6.beta3.x86_64                                                                                                      6/6 
Installed products updated.
  Verifying  : sssd-1.8.0-17.el6.x86_64                                                                                                                  1/6 
  Verifying  : sssd-client-1.8.0-17.el6.x86_64                                                                                                           2/6 
  Verifying  : libipa_hbac-1.8.0-17.el6.x86_64                                                                                                           3/6 
  Verifying  : sssd-1.8.0-4.el6.beta3.x86_64                                                                                                             4/6 
  Verifying  : sssd-client-1.8.0-4.el6.beta3.x86_64                                                                                                      5/6 
  Verifying  : libipa_hbac-1.8.0-4.el6.beta3.x86_64                                                                                                      6/6 

Updated:
  sssd.x86_64 0:1.8.0-17.el6                                                                                                                                 

Dependency Updated:
  libipa_hbac.x86_64 0:1.8.0-17.el6                                             sssd-client.x86_64 0:1.8.0-17.el6                                            

Complete!
[root@wheeljack ~]#

Verified in version sssd.x86_64 0:1.8.0-17.el6
Comment 7 Steeve Goveas 2012-04-05 07:18:35 EDT
[root@wheeljack ~]# rpm -qa | egrep 'libipa|sssd'
libipa_hbac-1.8.0-4.el6.beta3.x86_64
sssd-1.8.0-4.el6.beta3.x86_64
sssd-client-1.8.0-4.el6.beta3.x86_64
[root@wheeljack ~]# yum update sssd
[root@wheeljack ~]# yum update sssd
Loaded plugins: product-id, security, subscription-manager
Updating certificate-based repositories.
Unable to read consumer identity
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package sssd.x86_64 0:1.8.0-4.el6.beta3 will be updated
---> Package sssd.x86_64 0:1.8.0-17.el6 will be an update
--> Processing Dependency: sssd-client(x86-64) = 1.8.0-17.el6 for package: sssd-1.8.0-17.el6.x86_64
--> Processing Dependency: libipa_hbac(x86-64) = 1.8.0-17.el6 for package: sssd-1.8.0-17.el6.x86_64
--> Running transaction check
---> Package libipa_hbac.x86_64 0:1.8.0-4.el6.beta3 will be updated
---> Package libipa_hbac.x86_64 0:1.8.0-17.el6 will be an update
---> Package sssd-client.x86_64 0:1.8.0-4.el6.beta3 will be updated
---> Package sssd-client.x86_64 0:1.8.0-17.el6 will be an update
--> Finished Dependency Resolution

Dependencies Resolved
...
Is this ok [y/N]: y
Downloading Packages:
(1/3): libipa_hbac-1.8.0-17.el6.x86_64.rpm                                                                                            |  60 kB     00:00     
(2/3): sssd-1.8.0-17.el6.x86_64.rpm                                                                                                   | 2.1 MB     00:00     
(3/3): sssd-client-1.8.0-17.el6.x86_64.rpm                                                                                            |  88 kB     00:00     
-------------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                        4.9 MB/s | 2.3 MB     00:00     
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Updating   : libipa_hbac-1.8.0-17.el6.x86_64                                                                                                           1/6 
  Updating   : sssd-client-1.8.0-17.el6.x86_64                                                                                                           2/6 
  Updating   : sssd-1.8.0-17.el6.x86_64                                                                                                                  3/6 
  Cleanup    : sssd-1.8.0-4.el6.beta3.x86_64                                                                                                             4/6 
  Cleanup    : libipa_hbac-1.8.0-4.el6.beta3.x86_64                                                                                                      5/6 
  Cleanup    : sssd-client-1.8.0-4.el6.beta3.x86_64                                                                                                      6/6 
Installed products updated.
  Verifying  : sssd-1.8.0-17.el6.x86_64                                                                                                                  1/6 
  Verifying  : sssd-client-1.8.0-17.el6.x86_64                                                                                                           2/6 
  Verifying  : libipa_hbac-1.8.0-17.el6.x86_64                                                                                                           3/6 
  Verifying  : sssd-1.8.0-4.el6.beta3.x86_64                                                                                                             4/6 
  Verifying  : sssd-client-1.8.0-4.el6.beta3.x86_64                                                                                                      5/6 
  Verifying  : libipa_hbac-1.8.0-4.el6.beta3.x86_64                                                                                                      6/6 

Updated:
  sssd.x86_64 0:1.8.0-17.el6                                                                                                                                 

Dependency Updated:
  libipa_hbac.x86_64 0:1.8.0-17.el6                                             sssd-client.x86_64 0:1.8.0-17.el6                                            

Complete!
[root@wheeljack ~]#

Verified in version sssd.x86_64 0:1.8.0-17.el6
Comment 8 Stephen Gallagher 2012-04-10 12:51:32 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No technical note required
Comment 10 errata-xmlrpc 2012-06-20 07:55:25 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0747.html

Note You need to log in before you can comment on or make changes to this bug.