Bug 798888 - Eixisting jenkins for jboss app still tries to create an jbossas-7.0 job after migration
Eixisting jenkins for jboss app still tries to create an jbossas-7.0 job af...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
1.x
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Dan McPherson
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-01 03:05 EST by Xiaoli Tian
Modified: 2012-03-02 16:56 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-02 16:56:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xiaoli Tian 2012-03-01 03:05:04 EST
Description of problem:
After migration a jboss app with jenkins embeded, and try to make some changes and git push to trigger jenkins build, it will fail to create the bldr app like following:

INFO: Started provisioning jbossjenkins-build from OpenShift Cloud with 1 executors. Remaining excess workload:-0.75391054
com.openshift.express.client.OpenShiftEndpointException: Could not configure application "jbossjenkinsbldr" at "https://localhost/broker/cartridge"at com.openshift.express.client.OpenShiftService.sendRequest(OpenShiftService.java:454)
....
Caused by: com.openshift.express.internal.client.httpclient.BadRequestException: {"exit_code":1,"messages":"","debug":"","api_c":["placeholder"],"api":"1.1.2","result":"Invalid application type (-t|--type) specified: ''.  Valid application types are (nodejs-0.6, jbossas-7, haproxy-1.4, python-2.6, jenkins-1.4, ruby-1.8, raw-0.1, php-5.3, perl-5.10).","data":"","broker_c":["namespace","rhlogin","ssh","app_uuid","debug","alter","cartridge","cart_type","action","app_name","api"]}

Find this file $uuid/$jenkinsserver/data/jobs/jbossjenkins-build/config.xml in server,it still uses jbossas-7.0
  <properties>
    <hudson.plugins.openshift.OpenShiftBuilderSizeJobProperty>
      <builderSize>large</builderSize>
    </hudson.plugins.openshift.OpenShiftBuilderSizeJobProperty>
    <hudson.plugins.openshift.OpenShiftBuilderTypeJobProperty>
      <builderType>jbossas-7.0</builderType>
    </hudson.plugins.openshift.OpenShiftBuilderTypeJobProperty>
  </properties>



Version-Release number of selected component (if applicable):
devenv-stage_139

How reproducible:
Always

Steps to Reproduce:
1.Create an jboss app with jenkins embeded on an old instance
2.update and migrate
3.change profile to large
4.change code and git push
  
Actual results:
Jenkins fail to build job, and still use jbossas-7.0 create builder

Expected results:
Jenkins should use jbossas-7 now

Additional info:
Comment 1 Dan McPherson 2012-03-01 10:05:24 EST
Fixed for stage.
Comment 2 Xiaoli Tian 2012-03-02 00:27:17 EST
Verified this bug on stage ,it works now.

Note You need to log in before you can comment on or make changes to this bug.