Bug 798936 - enable architectural PMU cpuid leaf for kvm
enable architectural PMU cpuid leaf for kvm
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Gleb Natapov
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-01 05:37 EST by Gleb Natapov
Modified: 2013-12-08 19:56 EST (History)
10 users (show)

See Also:
Fixed In Version: qemu-kvm-0.12.1.2-2.244.el6
Doc Type: Bug Fix
Doc Text:
Cause Running qemu with -cpu host does not expose emulated PMU to a guest. Consequence Guest cannot use PMU counters. Fix If host kernel support PMU emulation expose cpuid.0AH leaf to a guest. Result Guest can use PMU counters to profile itself
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 07:44:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gleb Natapov 2012-03-01 05:37:41 EST
Needed for guest PMU support.
Comment 8 Michal Novotny 2012-05-04 09:02:11 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
NEEDINFO
Comment 9 Gleb Natapov 2012-05-06 06:42:34 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1,11 @@
-NEEDINFO+Cause
+  Running qemu with -cpu host does not expose emulated PMU to a guest.  
+
+Consequence
+ Guest cannot use PMU counters.
+
+Fix
+ If host kernel support PMU emulation expose cpuid.0AH leaf to a guest.
+
+Result
+ Guest can use PMU counters to profile itself
Comment 10 errata-xmlrpc 2012-06-20 07:44:08 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0746.html

Note You need to log in before you can comment on or make changes to this bug.