Bug 798955 - Aeolus CLI Failing to list images
Aeolus CLI Failing to list images
Status: CLOSED CURRENTRELEASE
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity urgent
: beta3
: ---
Assigned To: Matt Wagner
wes hayutin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-01 06:27 EST by Rehana
Modified: 2014-08-17 18:27 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-30 13:16:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rehana 2012-03-01 06:27:53 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.From the aeolus cli
2.enter the command : aeolus-image list --images

  
Actual results:

The command failed with below error, even though the conductor was running,

ERROR:  Service Temporarily Unavailable => Please check that Conductor is running.

help for list displays both the commands,
 
aeolus-image list --images                     # list available images
aeolus-image list --images --environment $env   # list available images for an environment


Expected results:
aeolus-image list --images --> Should list all the comp. outlines
aeolus-image list --images --environment $env -->Should list all the comp. outline in the specified Environment

Info:

[root@hp-z200-06 test]# rpm -qa | grep aeolus
aeolus-conductor-0.8.0-39.el6.noarch
rubygem-aeolus-cli-0.3.0-12.el6.noarch
aeolus-all-0.8.0-39.el6.noarch
aeolus-conductor-daemons-0.8.0-39.el6.noarch
rubygem-aeolus-image-0.3.0-10.el6.noarch
aeolus-conductor-doc-0.8.0-39.el6.noarch
aeolus-configure-2.5.0-16.el6.noarch
Comment 1 wes hayutin 2012-03-01 10:32:32 EST
[root@qeblade30 ~]# aeolus-check-services 

Checking mongod ...
 Success: mongod (pid 11625) is running...

Checking iwhd ...
 Success: iwhd (pid  11768) is running...

Checking postgresql ...
 Success: postmaster (pid  7426) is running...

Checking httpd ...
 Success: httpd (pid  11695) is running...

Checking qpidd ...
 Success: qpidd (pid  11807) is running...

Checking deltacloud-core ...
 Success: deltacloud-core (pid  12114) is running...

Checking libvirtd ...
 Success: libvirtd (pid  7096) is running...

Checking aeolus-conductor ...
 Success: thin (pid  12003) is running...

Checking conductor-dbomatic ...
 Success: dbomatic (pid  11978) is running...

Checking imagefactory ...
 Success: imagefactory (pid  11899) is running...

Checking ntpd ...
 Success: ntpd (pid  28896) is running...
[root@qeblade30 ~]# aeolus-image list --images

ERROR:  Service Temporarily Unavailable => Please check that Conductor is running.
Comment 2 Matt Wagner 2012-03-01 11:23:24 EST
This is ultimately caused by https://bugzilla.redhat.com/show_bug.cgi?id=798853 behind the scenes. That one is back ON_QA, so this one should be, too.
Comment 3 Shveta 2012-03-01 23:42:22 EST
aeolus-image list --images
ID                                       Name             Environment     OS         OS Version     Arch       Description     
------------------------------------     ------------     -----------     ------     ----------     ------     -----------     
0759bde4-641f-11e1-ae79-00215e203092     Fedora 15        default         Fedora     15             x86_64     desc            
7720b929-6496-43b0-8917-61e3addf69c2     ami-4fd00526     default                                                              
7f354dd8-641f-11e1-ae79-00215e203092     Fedora 15        default         Fedora     15             x86_64     desc            
18ba2a44-f1d8-420a-a002-701652ae51ae     xml-name         default                                                              
9adb6b3e-66ae-4eeb-b915-fab5d7864c00     xml-name         default      

===================================================================

rpm -qa|grep aeolus
aeolus-conductor-doc-0.8.0-39.el6.noarch
rubygem-aeolus-cli-0.3.0-12.el6.noarch
aeolus-all-0.8.0-39.el6.noarch
aeolus-conductor-0.8.0-39.el6.noarch
rubygem-aeolus-image-0.3.0-11.el6.noarch
aeolus-configure-2.5.0-16.el6.noarch
aeolus-conductor-daemons-0.8.0-39.el6.noarch

Note You need to log in before you can comment on or make changes to this bug.