Bug 798972 - liveusb fails with non illogical error message
liveusb fails with non illogical error message
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: liveusb-creator (Show other bugs)
17
Unspecified Linux
unspecified Severity high
: ---
: ---
Assigned To: Luke Macken
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-01 07:08 EST by Jes Sorensen
Modified: 2016-09-19 22:43 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-01 12:04:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jes Sorensen 2012-03-01 07:08:13 EST
Description of problem:
Fedora 17 Alpha install with updates. Trying to launch liveusb-creator
it fails with the following output:

[jes@mahomaho ~]$ liveusb-creator
Traceback (most recent call last):
  File "/sbin/liveusb-creator", line 89, in <module>
    main()
  File "/sbin/liveusb-creator", line 82, in main
    from liveusb.gui import LiveUSBApp
  File "/usr/lib/python2.7/site-packages/liveusb/__init__.py", line 29, in <module>
    os.environ['LANG'] = lang
  File "/usr/lib64/python2.7/os.py", line 471, in __setitem__
    putenv(key, item)
TypeError: must be string, not None
[jes@mahomaho ~]$ echo $LANG
en_US.UTF-8
[jes@mahomaho ~]$ 

I tried un-setting $LANG, but it results in the same error.

Version-Release number of selected component (if applicable):
[root@mahomaho ~]# rpm -q liveusb-creator 
liveusb-creator-3.11.6-2.fc17.noarch

How reproducible:
Every time

Steps to Reproduce:
1. Install F17 Alpha
2. yum install liveusb-creator
3. run liveusb-creator
  
Actual results:
Fails to start with illogical python backtrace

Expected results:


Additional info:
Comment 1 Luke Macken 2013-03-01 12:04:47 EST
This issue has been fixed with the latest version of the liveusb-creator. Please re-open if you still experience this problem. Thanks!

Note You need to log in before you can comment on or make changes to this bug.