Bug 799003 - pcre-devel manual page fixes
Summary: pcre-devel manual page fixes
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: pcre
Version: 6.2
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Petr Pisar
QA Contact: Lukáš Zachar
URL: http://bugs.exim.org/show_bug.cgi?id=...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-03-01 14:20 UTC by David Kutálek
Modified: 2012-09-07 10:49 UTC (History)
0 users

Fixed In Version: pcre-7.8-5.el6
Doc Type: Bug Fix
Doc Text:
Cause Reading some pcre manual pages (e.g. pcre(3)). Consequence Some misspellings can get linguists dizzy. Fix Form feed, run-time, and white space have been corrected in all pcre manual pages. Result pcre manual pages write form feed, run-time, and white space correctly now.
Clone Of:
: 820978 (view as bug list)
Environment:
Last Closed: 2012-09-07 10:49:00 UTC
Target Upstream Version:


Attachments (Terms of Use)
Fix ported to pcre-7.8 (12.35 KB, patch)
2012-05-14 14:11 UTC, Petr Pisar
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:1240 normal SHIPPED_LIVE pcre bug fix release 2012-09-07 14:47:32 UTC

Description David Kutálek 2012-03-01 14:20:33 UTC
Description of problem:

Checking /usr/share/man/man3/pcrecpp.3.gz for whitespace: FAIL
Checking /usr/share/man/man3/pcrebuild.3.gz for runtime: FAIL
Checking /usr/share/man/man3/pcre_compile.3.gz for whitespace: FAIL
Checking /usr/share/man/man3/pcresyntax.3.gz for whitespace: FAIL
Checking /usr/share/man/man3/pcresyntax.3.gz for formfeed: FAIL
Checking /usr/share/man/man3/pcreapi.3.gz for Whitespace: FAIL
Checking /usr/share/man/man3/pcreapi.3.gz for whitespace: FAIL
Checking /usr/share/man/man3/pcreapi.3.gz for formfeed: FAIL
Checking /usr/share/man/man3/pcrepattern.3.gz for whitespace: FAIL
Checking /usr/share/man/man3/pcrepattern.3.gz for formfeed: FAIL
Checking /usr/share/man/man3/pcre.3.gz for whitespace: FAIL
Checking /usr/share/man/man3/pcre_compile2.3.gz for whitespace: FAIL

Version-Release number of selected component (if applicable):

pcre-devel-7.8-4.el6

How reproducible:

ALways

Steps to Reproduce:
1. grep man pages from pcre-devel for these misspelled words:
2. whitespace, runtime, formfeed, Whitespace
3.
  
Actual results:

These words are present.

Expected results:

white space, run-time, form feed, White space

Additional info:

Comment 2 Petr Pisar 2012-05-11 12:30:28 UTC
Patch posted to upstream (http://bugs.exim.org/show_bug.cgi?id=1245).

Comment 3 Petr Pisar 2012-05-14 14:11:52 UTC
Created attachment 584369 [details]
Fix ported to pcre-7.8

Comment 4 Petr Pisar 2012-05-28 07:11:37 UTC
Comment on attachment 584369 [details]
Fix ported to pcre-7.8

The patch has been accepted by upstream as SVN revision r968.

Comment 9 Petr Pisar 2012-08-23 12:02:48 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause
    Reading some pcre manual pages (e.g. pcre(3)).
Consequence
    Some misspellings can get linguists dizzy.
Fix
    Form feed, run-time, and white space have been corrected in
    all pcre manual pages.
Result
    pcre manual pages write form feed, run-time, and white space
    correctly now.

Comment 14 errata-xmlrpc 2012-09-07 10:49:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1240.html


Note You need to log in before you can comment on or make changes to this bug.