Bug 799004 - [Indic] The glyph for SA in Lohit Devanagari should have the horizontal bar connected
[Indic] The glyph for SA in Lohit Devanagari should have the horizontal bar c...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: lohit-devanagari-fonts (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pravin Satpute
Fedora Extras Quality Assurance
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-01 09:29 EST by Shriramana Sharma
Modified: 2012-05-26 03:31 EDT (History)
3 users (show)

See Also:
Fixed In Version: lohit-devanagari-fonts-2.5.1-3.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-10 10:26:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Current and suggested appearance of Lohit Devanagari SA (62.46 KB, application/pdf)
2012-03-01 09:29 EST, Shriramana Sharma
no flags Details

  None (edit)
Description Shriramana Sharma 2012-03-01 09:29:18 EST
Created attachment 566857 [details]
Current and suggested appearance of Lohit Devanagari SA

Description of problem:

The glyph for SA in Lohit Devanagari currently does not have the horizontal bar within the SA connected with the left part of the glyph. While on superficial reading and especially at low point sizes this is not a problem, it would be preferable to have the horizontal bar fully connected, especially when viewed at high point sizes. 

This would greatly improve legibility and recognizability as SA (and not as RA + something), especially for the future development of Devanagari OCRs to parse documents printed using Lohit Devanagari.

The glyphs for half-SA and the ligated SRA should also be likewise corrected.

Thank you.

Version-Release number of selected component (if applicable):

2.5.1

How reproducible:

Steps to Reproduce:
1. Install Lohit Devanagari font
2. Type स स्व स्र etc by selecting that font.
3. Increase the point size to a large number like 48.
  
Actual results:

The horizontal bar within the SA glyph, half-SA glyph and the SRA ligature is not connected to the left side of the glyph. This does not look good at large point sizes. It would also be difficult for Devanagari OCRs to parse this as the current appearance of स is somewhat similar to रा.

Expected results:

The SA glyph, half-SA glyph, SRA ligature (and any other current or future derivatives) should have the horizontal bar connected to the left side of the glyph.
Comment 1 Shriramana Sharma 2012-03-01 09:32:04 EST
I forgot to mention that since now we are shipping Lohit Marathi and other Lohit Devanagari derivatives, this should be corrected there as well. So far there is no known requirement for a particular localization of Devanagari to have the SA glyph look like something specific, and the OCR situation would be common there also.
Comment 2 Pravin Satpute 2012-03-02 01:51:04 EST
Good catch, even Unicode shows shape with connected horizontal bar. I have committed changes in upstream, this will be available with next release.
Comment 3 Shriramana Sharma 2012-03-25 08:13:58 EDT
Just noticed that even the glyph for STRA (glyph $0175) has to be corrected. That makes a total of four glyphs: SA S_half SRA and STRA.
Comment 4 Fedora Update System 2012-04-25 11:26:46 EDT
lohit-devanagari-fonts-2.5.1-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/lohit-devanagari-fonts-2.5.1-3.fc16
Comment 5 Fedora Update System 2012-04-25 11:28:13 EDT
lohit-devanagari-fonts-2.5.1-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/lohit-devanagari-fonts-2.5.1-3.fc17
Comment 6 Fedora Update System 2012-05-03 11:58:23 EDT
Package lohit-devanagari-fonts-2.5.1-3.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing lohit-devanagari-fonts-2.5.1-3.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-7181/lohit-devanagari-fonts-2.5.1-3.fc17
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2012-05-10 10:26:30 EDT
lohit-devanagari-fonts-2.5.1-3.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2012-05-26 03:31:34 EDT
lohit-devanagari-fonts-2.5.1-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.