Bug 799035 - abrt-install-ccpp-hook won't (un)install hook
abrt-install-ccpp-hook won't (un)install hook
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: abrt (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jiri Moskovcak
qe-baseos-tools
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-01 11:06 EST by Michal Nowak
Modified: 2015-02-01 17:55 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-05 09:34:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
trace from hook install (30.57 KB, text/plain)
2012-03-01 11:06 EST, Michal Nowak
no flags Details

  None (edit)
Description Michal Nowak 2012-03-01 11:06:58 EST
Created attachment 566874 [details]
trace from hook install

Description of problem:

# abrt-install-ccpp-hook is-installed && abrt-install-ccpp-hook uninstall && cat /proc/sys/kernel/core_pattern 
|/usr/libexec/abrt-hook-ccpp %s %c %p %u %g %t e

From strace:

stat("/var/run/abrt/saved_core_pattern", 0x7fff2ec67270) = -1 ENOENT (No such file or directory)
[...]
exit_group(0)                           = ?

I guess abrt-install-ccpp-hook should say something about that.

And:

# abrt-install-ccpp-hook install ; cat /var/run/abrt/saved_core_pattern
core

Version-Release number of selected component (if applicable):

abrt-2.0.8-1.el6.x86_64
libreport-2.0.9-1.el6.x86_64

How reproducible:

always

Expected results:

"core" or something like that.

Additional info:
Comment 2 Jiri Moskovcak 2012-04-05 09:25:09 EDT
Works for me on rhel6 with abrt-2.0.8-2.el6, can you please verify it?

Note You need to log in before you can comment on or make changes to this bug.