Bug 799038 - Add Spice foreign menu support
Add Spice foreign menu support
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Daniel Berrange
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-01 11:13 EST by Marc-Andre Lureau
Modified: 2012-06-20 08:11 EDT (History)
6 users (show)

See Also:
Fixed In Version: virt-viewer-0.5.2-1.el6
Doc Type: Bug Fix
Doc Text:
No documentation needed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 08:11:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Marc-Andre Lureau 2012-03-01 11:13:36 EST
Legacy USB redirection support requires "foreign menu" support.

Virt-viewer needs to serve a "foreign menu" socket in order for the old usb redirection client-side to start correctly in rhel6, and to allow switching redirected devices with the "foreign menu".

virt-viewer upstream has the necessary bits, and should fix that bug with the upcoming 0.5.2 release.
Comment 1 Marc-Andre Lureau 2012-03-01 11:14:00 EST
virt-viewer upstream has the necessary bits, and should fix that bug with the
upcoming 0.5.2 release.
Comment 6 Geyang Kong 2012-03-12 04:02:03 EDT
I cannot get enough information from comments in this bug. So I'm not sure how to test this bug. Please provide me some more details so I can get clear what should I do for this bug. Thanks.
Comment 7 Geyang Kong 2012-03-12 05:07:20 EDT
This menu is visible on build virt-viewer-0.5.2-1.el6.x86_64, but bug 758645 and bug 758104 are not verified. I cannot test its function now.
Comment 8 Geyang Kong 2012-03-26 03:31:42 EDT
Verified pass on the build 
virt-viewer-0.5.2-3.el6.x86_64
qemu-kvm-0.12.1.2-2.248.el6.x86_64

Reproduced steps:
1. Follow this link: https://fedoraproject.org/wiki/Features/UsbNetworkRedirection
2. Click "input->Select USB devices for redirection"
3. Choose devices and click OK.

Actual result:
1. USB devices can be redirected to guest successfully.

Change this bug to VERIFIED.
Comment 9 Daniel Berrange 2012-04-17 07:33:43 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No documentation needed.
Comment 11 errata-xmlrpc 2012-06-20 08:11:48 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0772.html

Note You need to log in before you can comment on or make changes to this bug.