Bug 799103 - no mapping for s390x product cert included in the subscription-manager-migration-data
no mapping for s390x product cert included in the subscription-manager-migrat...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager-migration-data (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Michael Stead
:
Depends On:
Blocks: 738066
  Show dependency treegraph
 
Reported: 2012-03-01 14:24 EST by John Sefler
Modified: 2012-06-20 09:37 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 09:37:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 John Sefler 2012-03-01 14:34:10 EST
Description of problem:
Included in the subscription-manager-migration-data is a product cert for Red Hat Enterprise Linux for IBM System z (Server-Server-s390x-80067fc0de3c-72.pem).  However the channel-cert-mapping.txt does not map this product cert to any RHN Channels.  This seems incorrect.  In fact, the [rcm/rhn-definitions.git]/cdn/product-baseline.json is also missing all RHN Channels matching rhel-s390x*.  This seems wrong to me too.

Version-Release number of selected component (if applicable):
[root@jsefler-r63-server ~]# rpm -q subscription-manager-migration-data
subscription-manager-migration-data-1.12.1-1.git.4.7b6cf92.el6.noarch


How reproducible:


Steps to Reproduce:
[root@jsefler-r63-server ~]# rpm -ql subscription-manager-migration-data | grep s390
/usr/share/rhsm/product/RHEL-6/Server-Server-s390x-80067fc0de3c-72.pem
[root@jsefler-r63-server ~]# grep Server-Server-s390x-80067fc0de3c-72.pem /usr/share/rhsm/product/RHEL-6/channel-cert-mapping.txt
[root@jsefler-r63-server ~]# 

^^^ Expected the grep for the s390 product cert to match something in channel-cert-mapping.txt
Comment 2 Dennis Gregorovic 2012-03-01 15:22:18 EST
[rcm/rhn-definitions.git]/cdn/product-baseline.json has been fixed to includes the s390x channels.
Comment 3 Alex Wood 2012-03-19 14:27:55 EDT
Committed to the RHEL6 and RHEL6.3 branches of subscription-manager-migration-data 4a24dadb7b2a9b9f8c0cf396bc303586a5f8f23a
Comment 5 John Sefler 2012-03-19 16:31:23 EDT
Verifying Version...
[root@jsefler-r63-server ~]# rpm -q subscription-manager-migration-data
subscription-manager-migration-data-1.12.1.1-1.git.6.ea6813e.el6.noarch

[root@jsefler-r63-server ~]# rpm -ql subscription-manager-migration-data | grep s390
/usr/share/rhsm/product/RHEL-6/Server-Server-s390x-80067fc0de3c-72.pem
[root@jsefler-r63-server ~]# grep Server-Server-s390x-80067fc0de3c-72.pem /usr/share/rhsm/product/RHEL-6/channel-cert-mapping.txt
rhel-s390x-server-6: Server-Server-s390x-80067fc0de3c-72.pem
rhel-s390x-server-6-beta: Server-Server-s390x-80067fc0de3c-72.pem
rhel-s390x-server-6-beta-debuginfo: Server-Server-s390x-80067fc0de3c-72.pem
rhel-s390x-server-6-debuginfo: Server-Server-s390x-80067fc0de3c-72.pem
rhel-s390x-server-optional-6: Server-Server-s390x-80067fc0de3c-72.pem
rhel-s390x-server-optional-6-beta: Server-Server-s390x-80067fc0de3c-72.pem
rhel-s390x-server-optional-6-beta-debuginfo: Server-Server-s390x-80067fc0de3c-72.pem
rhel-s390x-server-optional-6-debuginfo: Server-Server-s390x-80067fc0de3c-72.pem
rhel-s390x-server-supplementary-6: Server-Server-s390x-80067fc0de3c-72.pem
rhel-s390x-server-supplementary-6-beta: Server-Server-s390x-80067fc0de3c-72.pem
rhel-s390x-server-supplementary-6-beta-debuginfo: Server-Server-s390x-80067fc0de3c-72.pem
rhel-s390x-server-supplementary-6-debuginfo: Server-Server-s390x-80067fc0de3c-72.pem
[root@jsefler-r63-server ~]# 

^^^ That looks better.
The s390x channels are mapped to the s390x product cert for rhel server
Comment 7 John Sefler 2012-04-17 18:15:50 EDT
moving to VERIFIED in version...
[root@jsefler-r63-server ~]# rpm -q subscription-manager-migration-data
subscription-manager-migration-data-1.12.1.3-1.el6.noarch

[root@jsefler-r63-server ~]# rpm -ql subscription-manager-migration-data | grep s390
/usr/share/rhsm/product/RHEL-6/Server-Server-s390x-80067fc0de3c-72.pem
[root@jsefler-r63-server ~]# grep Server-Server-s390x-80067fc0de3c-72.pem /usr/share/rhsm/product/RHEL-6/channel-cert-mapping.txt
rhel-s390x-server-6: Server-Server-s390x-80067fc0de3c-72.pem
rhel-s390x-server-6-beta: Server-Server-s390x-80067fc0de3c-72.pem
rhel-s390x-server-6-beta-debuginfo: Server-Server-s390x-80067fc0de3c-72.pem
rhel-s390x-server-6-debuginfo: Server-Server-s390x-80067fc0de3c-72.pem
rhel-s390x-server-optional-6: Server-Server-s390x-80067fc0de3c-72.pem
rhel-s390x-server-optional-6-beta: Server-Server-s390x-80067fc0de3c-72.pem
rhel-s390x-server-optional-6-beta-debuginfo: Server-Server-s390x-80067fc0de3c-72.pem
rhel-s390x-server-optional-6-debuginfo: Server-Server-s390x-80067fc0de3c-72.pem
rhel-s390x-server-supplementary-6: Server-Server-s390x-80067fc0de3c-72.pem
rhel-s390x-server-supplementary-6-beta: Server-Server-s390x-80067fc0de3c-72.pem
rhel-s390x-server-supplementary-6-beta-debuginfo: Server-Server-s390x-80067fc0de3c-72.pem
rhel-s390x-server-supplementary-6-debuginfo: Server-Server-s390x-80067fc0de3c-72.pem
[root@jsefler-r63-server ~]#
Comment 9 errata-xmlrpc 2012-06-20 09:37:38 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0823.html

Note You need to log in before you can comment on or make changes to this bug.