Bug 799115 - Unable to do PXE install on Intel Patsburg RAID-1 with RHEL6.2
Unable to do PXE install on Intel Patsburg RAID-1 with RHEL6.2
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.2
Unspecified Unspecified
medium Severity high
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
:
Depends On:
Blocks: 727267
  Show dependency treegraph
 
Reported: 2012-03-01 14:46 EST by tom.backwinkel
Modified: 2012-07-03 15:15 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-03 15:15:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
storage log (19.69 KB, application/octet-stream)
2012-03-01 14:46 EST, tom.backwinkel
no flags Details
dmesg and storage log (19.69 KB, application/octet-stream)
2012-03-01 14:47 EST, tom.backwinkel
no flags Details

  None (edit)
Description tom.backwinkel 2012-03-01 14:46:13 EST
Created attachment 566924 [details]
storage log

Summary:  Unable to do PXE install on Intel Patsburg RAID-1 with RHEL6.2

When trying to install RHEL6.2 via PXE on a system with Intel C600 Patsburg RAID-1 configured (RSTe), it adds the RAID md device to the reject list and does not install to the RAID/md device.   While still in anaconda, I can see that the 'isci' driver has been loaded, and 'fdisk -l' shows the /dev/md127 device.  I can manually partition /dev/md127 and create a filesystem.
Looking at the /tmp/storage.log, it appears that anaconda has decided to add the md device to the reject list:
  15:21:38,904 DEBUG   : device 'md127' not in exclusiveDisks
 15:21:38,905 DEBUG   : lvm filter: adding md127 to the reject list
The storage.log and dmesg.log from the PXE session are attached.

The RHEL6.2 install works fine from local media to the same configuration on the same system, which has an Intel S2600CO motherboard.

We noticed the issue below from Fedora, but the suggested kernel parameters did not help in this case.
Please advise whether there is a workaround for this issue in RHEL6.2.

---
PXE install can have problems with RAID arrays or encrypted devices 
link to this item - Bugzilla: #787744 
When installing Fedora 17 Alpha via PXE, some kernel parameters are not passed which are passed with other installation methods and, with previous releases, were automatically passed on PXE installations as well. These parameters prevent RAID arrays and encrypted partitions from being activated at initramfs initialization time, which interferes with their analysis and/or use by the installer. 
If you are performing a PXE install to a system with RAID devices or LUKS-encrypted partitions, you should add the following kernel parameters to ensure the installer does not encounter problems: rd.luks=0 rd.md=0 rd.dm=0. If you do not, you may encounter an installer crash with an error RuntimeError: device is already mapped, or similar problems. 
---
Comment 1 tom.backwinkel 2012-03-01 14:47:11 EST
Created attachment 566925 [details]
dmesg and storage log
Comment 3 RHEL Product and Program Management 2012-05-03 01:01:01 EDT
Since RHEL 6.3 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 4 David Cantrell 2012-07-03 15:15:50 EDT
While Red Hat welcomes bug reports on Red Hat products here in our public bugzilla database, please keep in mind that bugzilla is not a support tool or means of accessing support.  If you would like technical support please visit our support portal at access.redhat.com or call us for information on subscription offerings to suit your needs.

Note You need to log in before you can comment on or make changes to this bug.