Bug 79913 - IBM ThinkPad T30 + port replicator/dock + IMPS/2 scroll mouse makes mouse go nuts
IBM ThinkPad T30 + port replicator/dock + IMPS/2 scroll mouse makes mouse go ...
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2002-12-17 19:07 EST by Pam Huntley
Modified: 2007-04-18 12:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-09-24 14:55:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
XF86Config for a T23 exhibiting the same problem. (3.21 KB, text/plain)
2002-12-20 18:32 EST, Pam Huntley
no flags Details
XFree86 log for the T23 (64.08 KB, text/plain)
2002-12-20 18:33 EST, Pam Huntley
no flags Details
output of dmesg on the T23 (14.58 KB, text/plain)
2002-12-20 18:33 EST, Pam Huntley
no flags Details
/var/log/messages from the T23. (303.22 KB, text/plain)
2002-12-20 18:35 EST, Pam Huntley
no flags Details

  None (edit)
Description Pam Huntley 2002-12-17 19:07:36 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.4)
Gecko/20011128 Netscape6/6.2.1

Description of problem:
I have an IBM ThinkPad T30, and when I plug an IMPS/2 optical scroll mouse into
the PS/2 port of the dock (or port replicator, the problem occurs in both), the
mouse just goes nuts. 

If I plug in a USB IMPS/2 mouse, no problem.  If I configure the scroll mouse
for standard PS/2 (and lose the scroll feature), it works.  But if I try and use
the external PS/2 port on the dock/port rep with an IMPS/2 protocol, it goes nuts.  

Only the dock/port rep has an external PS/2 port, so I'm not able to test if it
works without the dock.  I did test under Windows to confirm that the hardware
was capable of this feature, it worked.

I used mouseconfig to set the mouse up, and we saw similar problems in gpm.

On one or two occaisions, we were able to get the IMPS/2 mouse to work, but we
couldn't ever get it to work in gpm and X at the same time, and we couldn't
replicate it working with any frequency.

We thought maybe it had to do with how the port was initialized, so we pulled
some code from kudzu that reset the mouse, but it didn't work reliably either,
although running kudzu would occaisionally get it to work.  Very frustrating!!!!

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.  put T30 in dock/port rep, plug in scroll mouse in PS/2 port on dock
2.  boot
3.  configure mouse with mouse-config for IMPS/2
4.  don't work.
5.  reboot.
6.  don't work.

Actual Results:  screwy jumping around mouse 99.99% of the time.

Expected Results:  happy happy IMPS/2 mouse.

Additional info:

I will check an see if it also occurs on the T23 ThinkPad.
I'll also try and add the logs from the T30 here tomorrow.
Comment 1 Pam Huntley 2002-12-20 18:32:31 EST
Created attachment 88837 [details]
XF86Config for a T23 exhibiting the same problem.

The T23 also has the mouse go crazy when you try and configure it as an IMPS/2
5 button Intellimouse on a PS/2 port, with a docking station.

I might be able to get a port replicator for Red Hat to borrow for a couple of
months, but that would be the longest time I could loan it out.  :-(
Comment 2 Pam Huntley 2002-12-20 18:33:03 EST
Created attachment 88838 [details]
XFree86 log for the T23
Comment 3 Pam Huntley 2002-12-20 18:33:23 EST
Created attachment 88839 [details]
output of dmesg on the T23
Comment 4 Pam Huntley 2002-12-20 18:35:22 EST
Created attachment 88840 [details]
/var/log/messages from the T23.
Comment 5 Mike A. Harris 2002-12-27 14:45:51 EST
Are you plugging the mouse in at runtime, after X is started, or are you
plugging it in prior to powering up the machine?

XFree86 does not support runtime mouse hotplugging.  Any pointer devices
that will be used during the X session must be configured int the XFree86
config file, and plugged into the machine physically when the X server
is started.
Comment 6 Pam Huntley 2003-01-10 18:34:54 EST
Hi.  Here is some additional info for you:

1.  I installed RHL without a docking station.  Later I powered down, and 
docked the machine, then booted up. 
2.  To connect the PS/2 mouse, I booted with the external PS/2 mouse connected
to the docking station via the PS/2 port(or port replicator, same difference),
used 'mouseconfig' to configure the mouse as a Microsoft Intellimouse PS/2.  I
applied the changes to X as well as gpm.  Then, whether I rebooted or not (I
tried both) I observed the erratic mouse behavior.

3.  I also tried plugging the mouse into the USB port on the docking station, 
and configuring it as Microsoft Intellimouse USB, and did not observe erratic 

4.  I plugged the mouse into the USB port on the ThinkPad itself, reconfigured 
as Microsoft Intellimouse USB, and did not observe erratic behavior.

5.  There is no external PS/2 port on the back of the T30's, so I was not able 
to test this behavior, although we were able to reproduce it just from the
external PS/2 port on the T23's, without the docking station.

Comment 7 Mike A. Harris 2004-09-24 14:55:26 EDT
Please upgrade to Fedora Core 2 or later, and if this issue turns
out to still be reproduceable, please file a bug report in the
X.Org bugzilla located at http://bugs.freedesktop.org in the
"xorg" component.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes
that become available for consideration in future updates.

Note You need to log in before you can comment on or make changes to this bug.