Bug 799140 - excessive speech engine dependencies
excessive speech engine dependencies
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: speech-dispatcher (Show other bugs)
21
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Robinson
Fedora Extras Quality Assurance
:
: 962021 (view as bug list)
Depends On:
Blocks: 799144
  Show dependency treegraph
 
Reported: 2012-03-01 16:01 EST by Bill Nottingham
Modified: 2015-04-22 18:56 EDT (History)
6 users (show)

See Also:
Fixed In Version: speech-dispatcher-0.8.2-4.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-04-22 18:56:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2012-03-01 16:01:35 EST
Description of problem:

speech-dispatcher has:
- a library dependency on espeak, bringing in the full espeak installation
- a hardcoded dep on festival-freebsoft-utils, bringing in the full festival installation
- a library dependency on flite, bringing in a full flite installation

Seems overkill in a livecd context.

Version-Release number of selected component (if applicable):

speech-dispatcher-0.7.1-7.fc17.x86_64
Comment 1 Peter Robinson 2012-03-02 05:01:26 EST
> Seems overkill in a livecd context.

Funnily enough a livecd isn't the only context this is used :-)

The reason for the dependencies is support for various languages on various different hardware for disabled users. I've spend a relatively large amount of time on IM/IRC/email working through problems with users so our support generally works pretty well for most users.

The problem with a lot of the HW devices out there is the mix of software / hardware and languages makes various combinations of all of them works.

It's not an ideal situation but without someone who has coding skills and the available hardware (often old, esoteric with requirements of things like serial ports) to test and fix the various combinations we're out of luck.

I've not investigated if we can split some of the supported options out into subpackages.

It seems a bit self defeating to improve support for disabled users it the upper stacks of the software only to remove that support further down the stack.
Comment 2 Bill Nottingham 2012-03-02 11:15:04 EST
(In reply to comment #1)
> The reason for the dependencies is support for various languages on various
> different hardware for disabled users. I've spend a relatively large amount of
> time on IM/IRC/email working through problems with users so our support
> generally works pretty well for most users.

That's the information I needed. Although it would be nice if a single backend worked for everything.
Comment 3 Peter Robinson 2012-03-02 11:25:06 EST
> That's the information I needed. Although it would be nice if a single backend
> worked for everything.

I wholeheartedly agree. The world of disabled technology seems to be fragmented and full of disagreements and in fighting. It really needs someone to choose one of the software technologies and merge any missing bits in and run with it but it's a matter of finding someone who's either interested or who will pay for it. I was sort of hoping the gnome or mozilla foundations might as part of their push. I don't remember how I managed to acquire this group of packages (likely some sort of OLPC related bit) but it's all a bit antiquated and strange.
Comment 4 Peter Robinson 2013-05-11 11:30:17 EDT
moving to 19
Comment 5 Peter Robinson 2013-05-11 11:31:25 EDT
*** Bug 962021 has been marked as a duplicate of this bug. ***
Comment 6 Matthias Clasen 2013-05-11 14:03:00 EDT
> I've not investigated if we can split some of the supported options out into subpackages.

The duplicate bug 962021 has a patch to that effect. Please investigate it.
Comment 7 Kalev Lember 2013-08-13 07:09:12 EDT
Any chance we could try landing the subpackage split in F20? https://bugzilla.redhat.com/show_bug.cgi?id=962021#c2 has a patch for that.
Comment 8 Matthias Clasen 2013-09-05 15:13:16 EDT
Peter, f19 has come and gone. f20 looms, and once again we need to cut things to make the live cd fit. Can we please have the subpackage split ?!
Comment 9 Peter Robinson 2013-09-05 15:27:53 EDT
(In reply to Matthias Clasen from comment #8)
> Peter, f19 has come and gone. f20 looms, and once again we need to cut
> things to make the live cd fit. Can we please have the subpackage split ?!

How do you propose splitting it up. I read back through years of email to remember exactly why we did it that way in the first place. The reason is language support.
Comment 10 Matthias Clasen 2013-09-06 09:15:24 EDT
See https://bugzilla.redhat.com/show_bug.cgi?id=962021#c2
Comment 12 Kalev Lember 2014-07-11 08:46:39 EDT
Ping? Peter, can you look at the patch in https://bugzilla.redhat.com/show_bug.cgi?id=962021#c2 to see if it can be included in F21, please?
Comment 13 Peter Robinson 2014-07-11 08:49:28 EDT
I'm looking at this, upstream is suppose to be doing a release soon so I was awaiting that landing with other fixes too
Comment 14 Fedora Update System 2015-03-24 06:51:09 EDT
speech-dispatcher-0.8.2-3.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/speech-dispatcher-0.8.2-3.fc22
Comment 15 Fedora Update System 2015-03-26 17:45:44 EDT
Package speech-dispatcher-0.8.2-3.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing speech-dispatcher-0.8.2-3.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-4572/speech-dispatcher-0.8.2-3.fc22
then log in and leave karma (feedback).
Comment 16 Kalev Lember 2015-03-26 18:40:32 EDT
I've tested the change now and it fails to speak anything in the default configuration. The problem is that the espeak module, which is the default, is now split out.

Would be great if you could move the espeak module back in the the main speech-dispatcher package.

The patch in https://bugzilla.redhat.com/show_bug.cgi?id=962021#c2 left espeak in the main package as well.
Comment 17 Kalev Lember 2015-03-26 18:59:49 EDT
Oh, and thanks again for making the split finally happen! I'm happy to help fix up the issue with the espeak module if you want me to.
Comment 18 Peter Robinson 2015-03-27 05:21:24 EDT
(In reply to Kalev Lember from comment #16)
> I've tested the change now and it fails to speak anything in the default
> configuration. The problem is that the espeak module, which is the default,
> is now split out.

what if you're spanish or chinese need flite or festival because it works with your language
Comment 19 Kalev Lember 2015-03-27 06:44:01 EDT
espeak supports those languages. Try it yourself:

yum install speech-dispatcher-espeak speech-dispatcher-utils
spd-say -y es "Hola, mi nombre es Peter."

What I'd like to have is a speech-dispatcher that works out of the box without needing any additional configuration. If it works and produces some output, that enables users to change things and install additional voices or additional speech-dispatcher modules, if they so desire.

It's like having working English keyboard layout out of the box. It might not be ideal for everyone, but it works and enables users to switch to their own keyboard layout when they've gotten their systems installed.

I would be open to changing this once we get proper "Recommends:" support in yum/dnf, but right now we don't. Once we have that, it might make sense to break out the espeak module too and have speech-dispatcher "Recommends: speech-dispatcher-espeak".
Comment 20 Kalev Lember 2015-03-27 06:52:20 EDT
One more issue I noticed is that the Obsolete versions are wrong. They should have 0.8.2, not 0.8.1.
Comment 21 Fedora Update System 2015-04-16 16:03:17 EDT
speech-dispatcher-0.8.2-4.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/speech-dispatcher-0.8.2-4.fc22
Comment 22 Kalev Lember 2015-04-16 16:08:07 EDT
Thanks Peter!
Comment 23 Fedora Update System 2015-04-22 18:56:14 EDT
speech-dispatcher-0.8.2-4.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.