Bug 799143 - Firewall prevented dnsmasq from working with virtual bridge network
Firewall prevented dnsmasq from working with virtual bridge network
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: dnsmasq (Show other bugs)
16
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Tomáš Hozza
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-01 16:10 EST by Scott Doty
Modified: 2012-11-19 06:32 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-19 06:32:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Doty 2012-03-01 16:10:28 EST
Description of problem:

DHCP functionality didn't work with Windows 8 public beta until firewall rule was removed.  I thought at first this was an interoperability problem, but removing the last INPUT chain firewall rule (the catchall that sends back an icmp access denied) seems to have fixed the problem.

Version-Release number of selected component (if applicable):

dnsmasq-2.58-2.fc16.x86_64

How reproducible:

I used the i686 iso from here:

http://windows.microsoft.com/en-US/windows-8/iso

Steps to Reproduce:
1. install into virt
2. boot virt
  
Actual results:

OS sense out dhcp requests that dnsmasq does not answer.

Expected results:

dnsmasq answering dhcp request, configuring the OS.

Additional info:

I went to re-create the problem & capture the packets with tcpdump -- but this time, it worked.  Only thing different now from when it didn't work is firewall changes.
Comment 1 Fedora Admin XMLRPC Client 2012-10-22 09:21:28 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 2 Tomáš Hozza 2012-11-19 06:32:54 EST
From the problem description this was a problem with your firewall settings. dnsmasq communication is filtered by firewall settings therefore you should check if there is any firewall rule preventing dnsmasq from receiving/sending packets.

Closing as NOTABUG since this is a firewall settings issue.

If your issue persists, please consider creating a bug for another component (firewall/libvirt/virt-manager).

Note You need to log in before you can comment on or make changes to this bug.