Bug 799172 - Anaconda does not automatically resolve dependencies for curry
Anaconda does not automatically resolve dependencies for curry
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: curry (Show other bugs)
17
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Gérard Milmeister
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-01 20:25 EST by Dan Mashal
Modified: 2012-03-09 00:08 EST (History)
4 users (show)

See Also:
Fixed In Version: curry-0.9.11-11.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-08 23:52:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Mashal 2012-03-01 20:25:06 EST
Description of problem:

When selecting curry on FC17 install Anacdona only warns about curry dependency at final stage before install.

Version-Release number of selected component (if applicable):


How reproducible:

Start install of FC17 via DVD image, select curry as a package, 

Steps to Reproduce:
1. Start install of FC17 via DVD image
2. Choose customize now when selecting packages
3. Choose to install Curry
4. Start install
  
Actual results:

Anaconda warns abotu curry dependency.

Expected results:

Anaconda should automatically resolve the dependency.

Additional info:

This also effects yum update after install if warning is ignored:

http://fpaste.org/RXCS/
Comment 1 Chris Lumens 2012-03-01 22:50:05 EST
anaconda warns because there's an unresolvable dependency, giving you a chance to either continue on without the package or change your selections.  This means there's a problem with the package.
Comment 2 Dan Mashal 2012-03-02 01:12:21 EST
Right, but shouldn't it advise you on how to resolve the dependency? Because it seems curry was installed anyway. It didn't "continue on without the package" because curry was installed.
Comment 3 Jens Petersen 2012-03-05 02:59:38 EST
Should be fixed by curry-0.9.11-11.fc17.
Comment 4 Fedora Update System 2012-03-05 03:03:38 EST
curry-0.9.11-11.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/curry-0.9.11-11.fc17
Comment 5 Dan Mashal 2012-03-05 10:43:55 EST
Sounds good, will be on the look out.
Comment 6 Fedora Update System 2012-03-05 15:56:03 EST
Package curry-0.9.11-11.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing curry-0.9.11-11.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-2864/curry-0.9.11-11.fc17
then log in and leave karma (feedback).
Comment 7 Jens Petersen 2012-03-08 19:33:41 EST
Dan, would be nice to know if the update works for you.
Comment 8 Fedora Update System 2012-03-08 23:52:09 EST
curry-0.9.11-11.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Dan Mashal 2012-03-09 00:08:17 EST
Jens, curry works now. I will double check it with a reinstall tonight.

Note You need to log in before you can comment on or make changes to this bug.