This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 799180 - Sometimes guest become not to respond when change vcpu
Sometimes guest become not to respond when change vcpu
Status: CLOSED DUPLICATE of bug 788562
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.2
Unspecified Unspecified
high Severity medium
: rc
: ---
Assigned To: Red Hat Kernel Manager
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-01 22:17 EST by yuping zhang
Modified: 2013-01-09 19:45 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-23 17:31:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description yuping zhang 2012-03-01 22:17:24 EST
Description of problem:
Perpare a rhel6.2 guest, then change the vcpu,sometimes the guest will become not to respond.

Version-Release number of selected component (if applicable):
qemu-kvm-0.12.1.2-2.234.el6.x86_64
libvirt-0.9.10-3.el6.x86_64
virt-manager-0.9.0-10.el6.x86_64

How reproducible:
90%

Steps to Reproduce:
1.Start a rhel6.2 guest.
#virsh dumpxml rhel6.2-new
...
<currentMemory>1048576</currentMemory>
<vcpu current='2'>4</vcpu>
...
2. Wait for the guest boot completely,then run
#virsh setvcpus rhel6.2-new 1 --live
#virsh setvcpus rhel6.2-new 3 --live
Or
You can use virt-manager to change the Current allocation of CPU,then apply.

3.Check the guest with virt-manager or virt-viewer.

Actual results:
The guest become no respond.

Expected results:
The guest works well and the vcpu will not update.
As we know,the qemu-kvm doesn't support vcpu hotplug now.The libvirt provide the API for it.
But I think the guest should not become not to respond at least.

Additional info:
1. I can reproduce this issue on rhel6 guest 100%,and can not reproduce on rhel5 guest.
2. You can change the vcpus several times if you can not reproduce this issue.
Comment 3 Dave Allan 2012-05-23 16:27:45 EDT
Based on the fact that the reproduction is completely dependent on the guest OS, I believe this BZ is not a libvirt problem, so I'm reassigning to kernel.  Please correct me if I'm wrong about that.
Comment 4 Igor Mammedov 2012-05-23 17:31:12 EDT
Closingas duplicate of bug 788562

Please re-test with RHEL6.3 kernel (kernel-2.6.32-235.el6 or later), where issue is fixed or disable kvm-clock in qemu to workaround issue on RHEL6.2.

Dor:
It might be good idea to clone bug 788562 for RHEL6.2 z stream.

*** This bug has been marked as a duplicate of bug 788562 ***

Note You need to log in before you can comment on or make changes to this bug.