Bug 799185 - Can't start virtual machine when set NIC model to "virtio".
Can't start virtual machine when set NIC model to "virtio".
Status: CLOSED DUPLICATE of bug 799155
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Justin M. Forbes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-01 23:52 EST by Arnold Wang
Modified: 2013-01-09 06:59 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-06 19:16:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Arnold Wang 2012-03-01 23:52:01 EST
Description of problem:
When I tried to start the Windows 7 guest machine when I set its NIC model to
"virtio", I receive the following error message:
qemu-system-x86_64: -netdev tap,fd=24,id=hostnet0,vhost=on,vhostfd=25:
vhost-net support is not compiled in
qemu-system-x86_64: -netdev tap,fd=24,id=hostnet0,vhost=on,vhostfd=25:
vhost-net requested but could not be initialized
qemu-system-x86_64: -netdev tap,fd=24,id=hostnet0,vhost=on,vhostfd=25: Device
'tap' could not be initialized
The relevant command generated by virtual machine manager 0.9.1 is 
"....
-netdev tap,fd=24,id=hostnet0,vhost=on,vhostfd=25 -device
virtio-net-pci,netdev=hostnet0,id=net0,mac=52:54:00:2c:7c:d2,bus=pci.0,addr=0x3
...."  
However, from what I googled, it appears to me vhost-net should be supported by
Fedora 17. In fact, even "lsmod" shows the following:
[awang@mars ~]$ lsmod | grep vhost
vhost_net              33675  0 
macvtap                18183  1 vhost_net
tun                    22768  4 vhost_net

Version-Release number of selected component (if applicable):
[awang@mars ~]$ rpm -qa kernel
kernel-3.2.5-3.fc16.x86_64
[awang@mars rules.d]$ rpm -qa | grep qemu
qemu-kvm-0.15.1-4.fc16.x86_64
qemu-img-0.15.1-4.fc16.x86_64
qemu-common-0.15.1-4.fc16.x86_64
gpxe-roms-qemu-1.0.1-4.fc16.noarch
qemu-system-x86-0.15.1-4.fc16.x86_64


How reproducible:
Create a guest machine, set the NIC model to "virtio" and start it.

Steps to Reproduce:
1.
2.
3.

Actual results:
The guest machine won't run.

Expected results:
The guest machine starts.

Additional info:
The complete Windows 7 guest machine configuration is attached.
Comment 1 Arnold Wang 2012-03-06 19:16:48 EST

*** This bug has been marked as a duplicate of bug 799155 ***

Note You need to log in before you can comment on or make changes to this bug.