Bug 799229 - [abrt] kernel: WARNING: at lib/list_debug.c:53 __list_del_entry+0xa1/0xd0()
[abrt] kernel: WARNING: at lib/list_debug.c:53 __list_del_entry+0xa1/0xd0()
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
abrt_hash:1872c3496854bff1422d79f40bf...
:
Depends On:
Blocks: kernel_hibernate
  Show dependency treegraph
 
Reported: 2012-03-02 02:55 EST by Pierre-Antoine Roiron
Modified: 2012-04-19 12:39 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-19 12:39:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Pierre-Antoine Roiron 2012-03-02 02:55:09 EST
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        BOOT_IMAGE=/vmlinuz-3.2.7-1.fc16.x86_64 root=/dev/mapper/vg_thinkpad-lv_root ro rd.md=0 rd.dm=0 quiet rd.lvm.lv=vg_thinkpad/lv_swap rhgb rd.lvm.lv=vg_thinkpad/lv_root rd.luks=0 KEYTABLE=fr SYSFONT=latarcyrheb-sun16 LANG=fr_FR.UTF-8
kernel:         3.2.7-1.fc16.x86_64
reason:         WARNING: at lib/list_debug.c:53 __list_del_entry+0xa1/0xd0()
time:           ven. 02 mars 2012 08:55:43 CET

backtrace:
:WARNING: at lib/list_debug.c:53 __list_del_entry+0xa1/0xd0()
:Hardware name: 0301GXG
:list_del corruption. prev->next should be ffff88012e782c98, but was           (null)
:Modules linked in: binfmt_misc vfat fat tcp_lp usblp ppdev parport_pc lp parport fuse ebtable_nat ebtables ipt_MASQUERADE iptable_nat nf_nat xt_CHECKSUM iptable_mangle bridge 8021q fcoe libfcoe libfc scsi_transport_fc scsi_tgt garp lockd stp llc rfcomm nf_conntrack_ipv4 bnep nf_defrag_ipv4 ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 xt_state ip6table_filter nf_conntrack ip6_tables snd_hda_codec_hdmi vhost_net macvtap macvlan tun snd_hda_codec_realtek virtio_net kvm_intel snd_hda_intel snd_hda_codec kvm snd_hwdep arc4 snd_seq snd_seq_device btusb iwlwifi bluetooth uvcvideo videodev snd_pcm mac80211 r8169 media v4l2_compat_ioctl32 cfg80211 thinkpad_acpi intel_ips snd_timer mii i2c_i801 iTCO_wdt iTCO_vendor_support sunrpc uinput snd snd_page_alloc rfkill serio_raw microcode soundcore joydev ums_realtek usb_storage i915 drm_kms_helper drm i2c_algo_bit i2c_core video [last unloaded: scsi_wait_scan]
:Pid: 490, comm: udevd Not tainted 3.2.7-1.fc16.x86_64 #1
:Call Trace:
: [<ffffffff8106dd4f>] warn_slowpath_common+0x7f/0xc0
: [<ffffffff8106de46>] warn_slowpath_fmt+0x46/0x50
: [<ffffffff8118f097>] ? d_kill+0xa7/0x100
: [<ffffffff812c9fc1>] __list_del_entry+0xa1/0xd0
: [<ffffffff811a1eca>] inode_wb_list_del+0x5a/0x90
: [<ffffffff81192343>] evict+0x53/0x1a0
: [<ffffffff81192593>] iput+0x103/0x200
: [<ffffffff811eb345>] sysfs_dentry_iput+0x35/0x40
: [<ffffffff8118f08f>] d_kill+0x9f/0x100
: [<ffffffff8118f772>] dput+0xe2/0x1b0
: [<ffffffff811862de>] do_lookup+0x25e/0x3a0
: [<ffffffff81186781>] link_path_walk+0x141/0x880
: [<ffffffff81164dcc>] ? kmem_cache_alloc_trace+0x10c/0x140
: [<ffffffff8126e10a>] ? selinux_file_alloc_security+0x4a/0x80
: [<ffffffff811852ad>] ? path_init+0x2cd/0x3a0
: [<ffffffff81188738>] path_openat+0xb8/0x3c0
: [<ffffffff8113fbc8>] ? handle_mm_fault+0x1f8/0x350
: [<ffffffff81188b62>] do_filp_open+0x42/0xa0
: [<ffffffff8118427b>] ? getname_flags+0x3b/0x260
: [<ffffffff8119489f>] ? alloc_fd+0x4f/0x150
: [<ffffffff811783f7>] do_sys_open+0xf7/0x1d0
: [<ffffffff811784f0>] sys_open+0x20/0x30
: [<ffffffff815e9d82>] system_call_fastpath+0x16/0x1b

smolt_data:
:
:
:Général
:=================================
:UUID: 7e134ac2-e5b2-41c3-b037-6700af223787
:SE: Fedora release 16 (Verne)
:Niveau d'exécution par défaut: Unknown
:Langue: fr_FR.utf8
:Plateforme: x86_64
:BogoMIPS: 5053.11
:Fabricant du processeurs: GenuineIntel
:Modèle de processeur: Intel(R) Core(TM) i3 CPU       M 380  @ 2.53GHz
:Stepping du processeur: 5
:Famille de processeur: 6
:Modèle du processeur: 37
:Nombre de processeurs: 4
:Vitesse du processeur: 2533
:Mémoire du système: 3754
:Swap du système: 5791
:Fabricant: LENOVO
:Système: 0301GXG ThinkPad Edge
:Type d'ordinateur: Notebook
:Noyau: 3.2.7-1.fc16.x86_64
:SELinux activé: 1
:Stratégie SELinux: targeted
:SELinux strict: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Périphériques
:=================================
:(32902:11362:6058:8598) pci, None, HOST/PCI, Core Processor QuickPath Architecture Generic Non-core Registers
:(32902:11521:6058:8598) pci, None, HOST/PCI, Core Processor QuickPath Architecture System Address Decoder
:(32902:68:6058:8579) pci, agpgart-intel, HOST/PCI, Core Processor DRAM Controller
:(32902:11536:6058:8598) pci, None, HOST/PCI, Core Processor QPI Link 0
:(32902:11537:6058:8598) pci, None, HOST/PCI, Core Processor QPI Physical 0
:(32902:11538:6058:8598) pci, None, HOST/PCI, Core Processor Reserved
:(32902:11539:6058:8598) pci, None, HOST/PCI, Core Processor Reserved
:(32902:15152:6058:8551) pci, None, SERIAL, 5 Series/3400 Series Chipset SMBus Controller
:(32902:15145:6058:8552) pci, ahci, STORAGE, 5 Series/3400 Series Chipset 4 port SATA AHCI Controller
:(32902:15113:6058:8550) pci, None, PCI/ISA, Mobile 5 Series Chipset LPC Interface Controller
:(32902:15154:6058:8592) pci, intel ips, NONE, 5 Series/3400 Series Chipset Thermal Subsystem
:(4332:33128:6058:8497) pci, r8169, ETHERNET, RTL8111/8168B PCI Express Gigabit Ethernet controller
:(32902:9288:6058:8549) pci, None, PCI/PCI, 82801 Mobile PCI Bridge
:(32902:15164:6058:8547) pci, ehci_hcd, USB, 5 Series/3400 Series Chipset USB2 Enhanced Host Controller
:(32902:15156:6058:8547) pci, ehci_hcd, USB, 5 Series/3400 Series Chipset USB2 Enhanced Host Controller
:(32902:15204:6058:8543) pci, None, SIMPLE, 5 Series/3400 Series Chipset HECI Controller
:(32902:132:32902:4885) pci, iwlwifi, NETWORK, Centrino Wireless-N 1000 BGN
:(32902:70:6058:8538) pci, i915, VIDEO, Core Processor Integrated Graphics Controller
:(32902:15176:6058:8548) pci, pcieport, PCI/PCI, 5 Series/3400 Series Chipset PCI Express Root Port 4
:(32902:15170:6058:8548) pci, pcieport, PCI/PCI, 5 Series/3400 Series Chipset PCI Express Root Port 1
:(32902:15172:6058:8548) pci, pcieport, PCI/PCI, 5 Series/3400 Series Chipset PCI Express Root Port 2
:(32902:15178:6058:8548) pci, pcieport, PCI/PCI, 5 Series/3400 Series Chipset PCI Express Root Port 5
:(32902:15190:6058:8542) pci, snd_hda_intel, MULTIMEDIA, 5 Series/3400 Series Chipset High Definition Audio
:(32902:15180:6058:8548) pci, pcieport, PCI/PCI, 5 Series/3400 Series Chipset PCI Express Root Port 6
:(32902:15174:6058:8548) pci, pcieport, PCI/PCI, 5 Series/3400 Series Chipset PCI Express Root Port 3
:
:
:Informations sur le système de fichiers
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/vg_thinkpad-lv_root / ext4 4096 4096 13092026 8842755 8711733 3276800 3118420 3118420
:/dev/sda1 /boot ext4 1024 1024 508745 409407 383807 128016 127737 127737
:/dev/mapper/vg_thinkpad-lv_home /home ext4 4096 4096 107255458 85314777 79946150 26845184 26798047 26798047
:/dev/sdb1 WITHHELD vfat 32768 32768 63984 53705 53705 0 0 0
:
Comment 1 Dave Jones 2012-03-09 09:55:35 EST
was this machine suspended/hibernated before this happened ?

can you reproduce it ?
Comment 2 Pierre-Antoine Roiron 2012-03-09 10:37:11 EST
Hi,
unfortunately, this is too old to be sure of what happened, but I'm quite sure it happened after resuming from hibernate state, considering I've encountered numerous bug of this kind since 3.x kernel(not sure, but 2.x kernel seemed much stable on my machine during hibernate actions).
It seems that this problem did  disapear with the 3.2.9 kernel.
Comment 3 Dave Jones 2012-03-09 13:02:01 EST
if you could run the kernel-debug build at http://koji.fedoraproject.org/koji/buildinfo?buildID=304798 and try hibernate/thaw a few times, that might turn up a different trace that might be helpful to us to track this down.
Comment 4 Pierre-Antoine Roiron 2012-03-10 11:04:12 EST
I'm currently running 3.2.9-debug, doing my usual stuff. Tried to hibernate/wake up 3 times with no ABRT showing up. I'll update you if I get the bug.
Comment 5 Pierre-Antoine Roiron 2012-03-10 11:39:34 EST
Well I just had a kernel panic when going into hibernate mode: 
Tried to hibernate and got a kernel panic. After a hard shutdown I booted the
system and had to repair the root filesystem :
fsck.ext4 -y /dev/vg_thinkpad/lv_root
Then Logged in on my usual desktop and get that ABRT warning.

I saved the report as a text file in abrt_journal (default config) but I can't find where ABRT wrote that file? I send the bug to bugzilla.redhat, but it seems to be https://bugzilla.redhat.com/show_bug.cgi?id=797369.
Comment 6 Josh Boyer 2012-03-28 14:01:19 EDT
[Mass hibernate bug update]

Dave Airlied has found an issue causing some corruption in the i915 fbdev after a resume from hibernate.  I have included his patch in this scratch build:

http://koji.fedoraproject.org/koji/taskinfo?taskID=3940545

This will probably not solve all of the issues being tracked at the moment, but it is worth testing when the build completes.  If this seems to clear up the issues you see with hibernate, please report your results in the bug.

Note You need to log in before you can comment on or make changes to this bug.