Bug 799287 - Support for Solaris NLM client
Support for Solaris NLM client
Status: CLOSED CURRENTRELEASE
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterfs (Show other bugs)
1.0
All Linux
high Severity medium
: Release Candidate
: ---
Assigned To: Ric Wheeler
Sachidananda Urs
:
Depends On:
Blocks: 817967
  Show dependency treegraph
 
Reported: 2012-03-02 06:46 EST by Krishna Srinivas
Modified: 2015-08-10 03:44 EDT (History)
4 users (show)

See Also:
Fixed In Version: release-3.3, upstream
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-10 03:44:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Krishna Srinivas 2012-03-02 06:46:44 EST
Description of problem:
Solaris client is not able to use glusterfs NLM for locking

Solaris nfs client is mount like this:
mount -o proto=tcp,vers=3 nfs://HOSTNAME-OR-IPADDRESS:38467/VOLNAME MOUNTDIR

Because of this the NFS client does not do a portmap query of glusterfs NLM server and does not use its locking facility.

Looking at the wireshark dump of solaris nfs client mount from linux kernel nfs server, this is what it does:
1) query portmapper for UDP mountd
2) call MNT procedure on mountd to get root filehandle
3) when fcntl-lock is done, query portmap for TCP NLMv4
4) call NLM lock/unlock operations

But in case of glusterfs-nfs, solaris nfs client never does a portmap query for NLM server.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Krishna Srinivas 2012-03-06 04:09:05 EST
To fix this we need to implement mountd on UDP so that solaris nfs client queries portmapper for NLM after query for MOUNT on UDP is successful.
Comment 3 Sachidananda Urs 2012-06-07 06:34:54 EDT
Verified this, this feature is implemented. sub-directory mount does not work but there is a separate bug for it.

Note You need to log in before you can comment on or make changes to this bug.